system sounds cut off at startup

As Im booting into 11.1 I start to hear the startup tune and then all of the sudden it is cut off and stops. I think there is something that starts up at the same time the tune is playing that kills it. But when I shutdown I get the entire shutdown tune. Anyone else seen this before?

Yea, I’ve noticed that too.

The problem starts when you load compiz on startup. If you disable compiz then the sounds play properly.

Hope it helps

I see… Well thats a whole other problem then because compiz is enabled and when I do disable it and reboot it comes back as enabled. AND when it is enabled it doesn’t work anyway.

I can’t comment on it being Compiz per se, but I can verify that if another program is run during desktop initialization it may overlap with the tune and cut that off. I auto start a superkaramba script, and it has the same effect. I even tried pausing the script execution using a sleep command line, but when bash is called that is what causes the overlap.

I’m agree with mingus725 - I’m not using Compiz but the startup sound stops - for me it’s probably caused by Skype startup sound. It’s worked on 11.0, together with VLC, Amarok, etc. but here nothing works if it is about sound. :\