System settings -> yast doesn't work

Now that I’ve fixed the install mode SNAFU, it’d be nice to reconfigure stuff, but the Yast Control Center doesn’t do anything. Clicking on a selection yields an “I’m working” spinner, then nothing. “dmesg” says weird stuff about hibernation being restricted and having an invalid key. Whatever that’s about. No other obvious messages that might tell me what’s awry. I haven’t even done any sort of customization, aside from mounting the /home directory (which was hidden from the fresh install). Oh, there’s no sound, either. It’s not recognizing either my speakers (plugged into the rear audio port) or headphones (plugged into a front panel port).

Other weird stuff: the display settings are not persistent. I have a portrait and a landscape monitor. It has them turned around in orientation, left/right and primary. It’s inconvenient. In the past, System Settings → Display Config was persistent. It’d be nice to know why it’s having trouble remembering. :frowning:

Is there a way to start these things up from the command line with a verbose setting so I can get some information?

Hmmmm. 15.4 works fine here for some time. Was this some upgrade?? From What? Did you try a different user? What hardware??? What repos?? You have not given much info.

It would be unimaginable to me that this would be a widespread problem. Surely, something I did triggered it. The issue is: what? Sadly, without being able to fire up the stuff in verbose/debug mode, it’s hard to say much.

I did a 100% full openSUSE 15.4 install, stumbling over the fact that I had to disable the “compatibility mode” in the BIOS. Once I worked my way through that, I have /home mounted as a 5TB RAID-0, /tmp as a 16GB spinning disk and the rest a BTRFS partition taking up half a 250GB solid state “disk”. And I’m using 64GB of RAM swapped to a 64GB spinning swap partition. What else would be useful?

Edit: tomorrow, I will try adding a user to see if that new user works. If it does, I’ll fiddle around until it works. I’ll be back tomorrow, US PDT (UTC -7).

I had similar experience with yast last week after update. See thread: No yast apps starting

The cause was some ruby files got deleted. I have no idea how. Reinstalling ruby solved the problem.

Hope it works.

tom kosvic

Thanks. I’ll try that after trying a new user. It seems unlikely though. I fired it up this morning to find that, as expected, my monitor settings were back to default (both are landscape, left and right swapped and my preferred primary isn’t primary). Is the configuration being stored on a tempfs?

Should be on /home/yourname/.config

It certainly is now. I did my 12th install and it’s all working. Finally. I hate upgrades. :frowning:

I avoid upgrades by always doing a fresh install I maintain 2 partitions and alternate installs between them I keep a separate /home and thus keep my data between installs.

Excellent idea! It’s also what I’ve been doing for close to two decades. :slight_smile: I still call it upgrading.
My home directory is on a RAID-0 file system where I also keep /usr/local. I blow away the installed one and replace it with a symlink. (Can’t use a subvol mount since the data antedate BTRFS’s subvolumes. :smiley: )

Anyway, I will now speculate as to the source of my issues here:

The last time I repartitioned my primary drive was years ago, in the interim I’d forgotten that the secondary boot area needs to be closer to the start of the disk. Consequently, when I was reminded that I needed one for a legacy install, I tacked it onto the end because it was easier. The installer said everything was good and proceeded to make an installation that hung on a GRUB prompt. (That would be two installer bugs: allowing for that and failure to message better.)

SO, per suggestions, I turned off compatibility mode and started a new install. However, with compatibility off, my computer’s BIOS refused to boot from either a DVD or a USB drive. It booted up the installed OS straight away. Wow! I was done! (NOT). Since the OS was installed in legacy (compatibility) mode, something in the underlying BIOS was now hostile* to changes being attempted by the user space stuff. Thus, the system configuration stuff all – ALL – failed. That means adding a new user to see if that had an effect was ineffectual.

SO, in the end, I did a legacy install with the boot partition close to the SSD’s start. Lo, and behold, it all works now. I can not do an EFI install because, when not in compatibility mode, my computer’s BIOS refuses to boot from either USB or DVD. That makes the installation too much of a challenge.


* How, exactly? I thought that the BIOS was essentially ignored once the OS was fully up.