System Settings/Audio crash

Hello all,

Well, I’ve had everything working quite well in Suse for a bit.

Today, I started having a problem with the “System Settings” audio option. Basically, when I go to Personal Settings -->Multimedia I get a crash.

This also means that I am not getting sound correctly.

Let me know if anything else can be useful.

Quite odd, as everything worked before…

I am getting the same issue on openSUSE 11.2 and KDE 4.4. Any ideas?

same thing for me as well.

I’m betting it is a config/setting somewhere in .kde4,

I’ve just not had the time to hunt for it. I’ve been noticing a number of odd problems on my system as of late, i think due to beta configurations. system has been sluggish, some programs i can’t alter settings in…
it just hasnt been something i can put my finger on.

I have a very similar problem.

Sometime in the last week an update sems to have broken my KDE Multimedia settings. I’m fully patched using the 11.2 and Packman repo;

From the command line;
speaker-test OK
skype OK
mplayer OK
xine OK
vlc OK

Desktop Settings;
systemsettings - Multimedia - Broken
systemsettings - Notifications - Broken

Multimedia Applications;
Amarok - Broken

Hardware - Sound - OK
(I’ve tried Quick, Normal and Advanced setups)

I not sure how to proceed from here, it looks to me given that many individual applications and Konsole work, but the KDE Notification System and Control Panels don’t, it must be a KDE problem.

Any advice would be greatly appreciated.


Same here, 11.2 KDE 4.4.

I assumed it was just my own KDE problem…

Then…create a new user, login as that user, and see if the problem exists for that user. If so, it’s in your kde4 settings, if not, there’s something wrong with your KDE4 install.

Please let us know what the above does


Not sure if this will help but I found that changing the phonon version from 4.3.1-3.3-i586 to 4.3.80-4.1-i586 sorted this out.


i also encountered this problem.

i fix this problem.
the phonon version is not compatible the kde. just update phonon.