"System Services (Runlevel)" deos not list any services on 11.3

I can see this phenomenon on 2 different systems running 11.3 .
In simple mode and also in expert mode.

What could be the reason for that?

J.

what about : chkconfig ?

chkconfig shows some on, some off,
that looks alright.

Actually when I try to switch a service on, this happens:

root # chkconfig nmb on
insserv: script jexec is broken: incomplete LSB comment.
insserv: missing Required-Stop:' entry: please add even if empty. insserv: script jexec is broken: incomplete LSB comment. insserv: missing Required-Stop:’ entry: please add even if empty.
insserv: script jexec is broken: incomplete LSB comment.
insserv: missing Required-Stop:' entry: please add even if empty. insserv: script jexec is broken: incomplete LSB comment. insserv: missing Required-Stop:’ entry: please add even if empty.

This refers to the RPMs, right?

But a single broken start/stop script doesn’t break the entire runlevel configuration, does it?

No it refers to a script in /etc/init.d. Do you have that script : /etc/init.d/jexec ? Can you show us its content
cat /etc/init.d/jexec

But a single broken start/stop script doesn’t break the entire runlevel configuration, does it?

It depends which one and what it does. Normally, no. But you’ll get such warnings.

Yes, there is such a script.

The entire file is almost 400 lines long,
I assume, this will do:

$ head /etc/init.d/jexec

#!/bin/sh

Copyright 2006 Sun Microsystems, Inc. All rights reserved.

SUN PROPRIETARY/CONFIDENTIAL. Use is subject to license terms.

@(#)jexec 1.1 05/05/24

A script for supporting the direct execution of binary formats through

binfmt_misc.

More information about binfmt_misc is available at the binfmt_misc homepage:

http://www.tat.physik.uni-tuebingen.de/~rguenth/linux/binfmt_misc.html

BEGIN INIT INFO

Provides: binfmt_misc

Required-Start: $local_fs

Default-Start: 1 2 3 4 5

Default-Start: 0 6

chkconfig: 12345 95 05

Description: Supports the direct execution of binary formats.

END INIT INFO

After inserting this line before “# chkconfig: …”,
the above error messages disappeared,
but “System Services (Runlevel)” still didn’t list any services:

Required-Stop:

(“please add even if empty”)

That script is not fully LSB compliant. Add a the following line

# Required-Stop:

in the section above. Take a look on other scripts in /etc/init.d. Maybe System services get confused because of that missing line.

See above, I did that already, and I reported on the result.
Services still don’t get listed.

Thanks for your assistance!

Oh yes you did. Sorry! But that script still doesn’t have a “Default-Stop” line in the INIT INFO section. So I’m not surprised that Services cannot list it properly (and maybe stops listing the others after that error (?))

Well, even with this “INIT INFO” section,
I don’t get the services listed with “System Services (Runlevel)”:

### BEGIN INIT INFO
# Provides: binfmt_misc
# Required-Start: $local_fs
# Default-Start: 1 2 3 4 5
# Default-Start: 0 6
# Default-Stop:
# Required-Stop:
# chkconfig: 12345 95 05
# Description: Supports the direct execution of binary formats.
### END INIT INFO

I hope, the maintainer of the “jre” RPM notices these problems.
Does he?

And this thing is not yet solved.

On 2010-10-21 23:36, Jochen Hayek wrote:

> $ head /etc/init.d/jexec

It is a script known to be broken. Remove it.

It comes from a java package installed from outside the distribution (I don’t remember which), which
perhaps you should also remove.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Do you see the problem?
Try the following INIT INFO instead :

### BEGIN INIT INFO
# Provides: binfmt_misc
# Required-Start: $local_fs
# Required-Stop:
# Default-Start: 1 2 3 4 5
# Default-Stop: 0 6
# chkconfig: 12345 95 05
# Description: Supports the direct execution of binary formats.
### END INIT INFO

or move/remove that script, as Carlos said. That would have been my next suggestion too.

Are you referring to this RPM:

# rpm --query -f /etc/init.d/jexec
jre-1.6.0_19-fcs.i586

yast2’s Software Manager doesn’t know, which repository the RPM comes from,
so I agree to Carlos and please_try_again, and I remove(d) that RPM.

Sadly enough even after removing that RPM “System Services (Runlevel)” still does not list any services.

If I try to “refresh”, a pop-up shows this message:

/etc/init.d/nil status returned 127 (unspecified error):

I am really grateful you are dedicating your time to my problem.

Do you see other errors if you try to enable or disable a service with insserv/insserv -r ?

Alright. But I cannot see worrying messages:

# insserv --verbose --remove smb
insserv: creating .depend.boot
insserv: creating .depend.start
insserv: creating .depend.halt
insserv: creating .depend.stop
# insserv --verbose smb
insserv: enable service ../smb -> /etc/init.d/rc3.d/S10smb
insserv: enable service ../smb -> /etc/init.d/rc3.d/K01smb
insserv: enable service ../smb -> /etc/init.d/rc5.d/S10smb
insserv: enable service ../smb -> /etc/init.d/rc5.d/K01smb
insserv: creating .depend.boot
insserv: creating .depend.start
insserv: creating .depend.halt
insserv: creating .depend.stop

It looks ok now.

Sure, but “System Services (Runlevel)” still does not list any services,
and I am not able to modify services there.

On 2010-10-22 02:36, Jochen Hayek wrote:

> I hope, the maintainer of the “jre” RPM notices these problems.
> Does he?

I’m sure he does, as this issue has been known for months. Either they (SUN) don’t care or don’t
have a clue.

http://lists.opensuse.org/cgi-bin/search.cgi?query=jexec&advanced.x=0&advanced.y=0&advanced=no

[Bug 461199] System gets stuck on jexec – rank: 1000
→ resolved duplicate
[Bug 504596] New: Is the script “jexec” broken? – rank: 890
→ resolved invalid (report at SUN, not suse)
[Bug 471179] New: starting jexec at boot blocks; makes suspend to disk f – rank: 854
→ resolved duplicate
[Bug 462550] New: boot hiccup with jexec initialisation – rank: 823
→ resolved duplicate
… 468970] Change from openjdk to sun Java breaks jexec – rank: 776
→ resolved duplicate


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

On 2010-10-22 11:36, Jochen Hayek wrote:
>
> robin_listas;2241862 Wrote:

> Are you referring to this RPM:
>
>
> Code:
> --------------------
> # rpm --query -f /etc/init.d/jexec
> jre-1.6.0_19-fcs.i586
> --------------------

Yes, should be.

> yast2’s Software Manager doesn’t know, which repository the RPM comes
> from, so I agree to Carlos and please_try_again, and I remove(d) that RPM.

Surely there are official packages with java you can install instead.

> Sadly enough even after removing that RPM “System Services (Runlevel)”
> still does not list any services.
>
> If I try to “refresh”, a pop-up shows this message:
>
> Code:
> --------------------
> /etc/init.d/nil status returned 127 (unspecified error):
> --------------------

Find out what rpm that “nil” is coming from. I’m almost certain it is again some extraneous package.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)