System REALLLLYYY slow during install of OpenSUSE 12.1 on Corei7 2600K with 32GB RAM

Folks,

I’m hoping this hasn’t already been answered in someone else’s post and I just missed it.

I installed OpenSuse 12.1 32bit on a MicroCenter Powerspec G212 system with the following:

  • Corei7 2600K
  • 32GB RAM
  • 2 x 1.9TB HDs, not mirrored

The boot CD booted fine and saw the components. Moved through the installation options OK with no issues and speed during initial installation was good.

However, on first bootup after installation, system got past POST and initial driver load and started graphical system. That’s when system slowed to worse than a crawl. It’s been at the message “Preparing the 1st system configuration …” for about 45 minutes now without releasing the mouse or completing the screen draw.

I know this is not normal and I’m hoping there’s a simple BIOS setting or mismatch somewhere that can explain and correct this issue.

BTW - I saw exactly the same behavior on the same system using Fedora 16 32bit. I loaded Fedora on this system first just to see the OS and play a bit before installing the final OpenSUSE 12.1. Because of this I don’t believe it’s a simple OS configuration issue unless there’s a default setting that I am missing.

I also don’t see anything obvious in the /var/log/messages file.

Any suggestions would be appreciated.

thanks.

Shaun.

On 2012-02-05 23:06, shauncw wrote:

> I installed OpenSuse 12.1 32bit on a MicroCenter Powerspec G212 system
> with the following:
> - Corei7 2600K
> - 32GB RAM

That big a system with only 32 bit? I don’t understand.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I think you should send me that system. I’ll PM you my address… I think I would probably run 64 bit.

On 02/05/2012 11:06 PM, shauncw wrote:
> system got past POST and
> initial driver load and started graphical system. That’s when system
> slowed to worse than a crawl.

ok, i guess you installed either KDE, or Gnome, or LXDE or Xfce…right?

so what if you put in a Live KDE or Gnome CD and boot from it and at the
first green screen run the disk self test, like http://tinyurl.com/455hbml

and if it tests ok (any error is too many) then boot from the disk
again and select the top choice to run the live Gnome (or KDE) session…

and report back here: does that run ok? or not?

if it does run ok then insert the disk you originally installed from and
do the self test on it–is it also ok?

if so, remove the disk and reboot…at the next green screen press F5
and select “system V” like here:
http://dl.dropbox.com/u/10573557/12.1_Misc/12.1_F5_sysV.jpg

and, tell us how does it run now?


DD http://tinyurl.com/DD-Caveat
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

I understand your confusion. I used the openSUSE 12.1 DVD from a magazine (I was to lazy to download my own 64bit DVD). I was simply checking to see how the distro looked and performed on this box before installing the permanent version.

Thanks for responding.

Shaun

I agree with you and I plan to run 64bit. This was mostly just a test to see what the new distros looked like and performed like on this new system. I planned to download the 64bit version to do the permanent install

Thanks for responding.

Shaun.

I will follow these suggestions and post back the results.

Thanks for responding.

Shaun.

Folks,

It looks like the memory was the problem. Not sure yet if there’s a bad DIMM or just too much. I took out all but one DIMM (8GB) and booted to the Fedora14 x64 LiveCD. Booted just fine. So I booted to the installed OpenSUSE 10.3 installation. Booted fine. I also booted to OpenSUSE 11.4 x64 and OpenSUSE 12.1 x64 LiveCDs. Both booted fine. I then inserted a 2nd DIMM (16GB total) and again, booted to the above with no problems.

I’m going to check each DIMM to verify that none of them have a problem (as I suspect) and then I’m going to search on known issues with this Motherboard (Intel Desktop DP67BG) and 32GB of RAM and Linux distros.

If anyone has any suggestions on possible issues with 32GB ram and this MB and Linux, please let me know. By the way, the system I’m using is:
MicroCenter Powerspec G212
4xCorsair 8G CMZ8GX3M1A1600C10 (1600Mhz, 10-10-10-27, 1.5v)
Corei7 2600K
2x2TB Samsung HD204Ui SATA 5400rpm

I’ll post more information shortly.

Thanks for any and all comments/suggestions/replies.

Shaun.

On 2012-02-10 01:56, shauncw wrote:
>
> Folks,
>
> It looks like the memory was the problem. Not sure yet if there’s a bad
> DIMM or just too much. I took out all but one DIMM (8GB) and booted to
> the Fedora14 x64 LiveCD. Booted just fine. So I booted to the installed
> OpenSUSE 10.3 installation. Booted fine. I also booted to OpenSUSE 11.4
> x64 and OpenSUSE 12.1 x64 LiveCDs. Both booted fine. I then inserted a
> 2nd DIMM (16GB total) and again, booted to the above with no problems.

Ah… interesting.

>
> I’m going to check each DIMM to verify that none of them have a problem
> (as I suspect) and then I’m going to search on known issues with this
> Motherboard (Intel Desktop DP67BG) and 32GB of RAM and Linux distros.

Looks a good plan. Also bios settings, unmatched memory modules perhaps…


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 02/10/2012 01:56 AM, shauncw wrote:
> Not sure yet if there’s a bad DIMM or just too much.

well, i kinda doubt if you can put more RAM into that machine than (any)
Linux can handle…hmmmm, i think the 32 bit PAE kernel might be
limited to 64 G…but, the 64 bit kernel can take a LOT!!

you can check the ram with the install disk, just select “Memory Test”
from the first green screen…

but, you have to let it run a LONG time…12 hours at the very very least
for that much ram…probably more like a GUESS week for complete check…


DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

Folks,

Here’s an update on the problem. Looks like there is some issue with OpenSUSE and 32GB of these memory modules. I’ve already listed the system I’m using and the memory modules. If I boot with only 1 DIMM (8GB), it performs fine. I can swap any one of the 4 DIMMs in and performance is fine. I can run with 2 DIMMs (16GB) and still fine. If I install 3 DIMMs (24GB) I can boot and still seem to function OK, however the system seems a bit slower than normal. Boot takes an extra minute (60 seconds) and opening a FireFox window takes an extra few seconds. Patching takes longer and everything just seems a bit slower. If I install 4 DIMMs (32GB), everything slows to a crawl. Bootup takes about 8-9 minutes. Opening FireFox takes about 3 minutes.

I’ve searched the web and can’t find any issues with 32GB of ram and Linux and honestly I didn’t expect to find any. I’ve confirmed that the LiveCD for Fedora16 gives me the same results. Boot takes FOREVER and moving around is like watching syrup run uphill in winter. I’ve gotten the same behavior in CentOS 5.6 and OpenSUSE 11.4 KDE 64bit LiveCD.

I’ve installed Windows7 for now (and YES, it killed me to do this) since it doesn’t seem to suffer from the same issue but I really want to know if anyone has any ideas why this is a problem. It doesn’t seem to be confined to OpenSUSE 12.1 or just one distro. Multiple distros (RedHat derivations) are giving the same results. I don’t think it’s the memory modules since any one works fine and Windows is fine with all modules installed. That’s also why I’m not willing to believe this is a BIOS issue unless there’s a setting affecting Linux without affecting Windows.

If anyone has any suggestions on the issue or recommendations on what to checkout, please let me know. I’ll try to check this forum over the next few days. I’ll also close the issue by next week if no additional answers are pending.

Thanks.

Shaun.

On 02/14/2012 02:36 PM, shauncw wrote:
> It doesn’t seem to
> be confined to OpenSUSE 12.1 or just one distro. Multiple distros
> (RedHat derivations) are giving the same results. I don’t think it’s the
> memory modules since any one works fine and Windows is fine with all
> modules installed.

what was the result of booting systemv instead of systemd?

and, what was the result of running “Memory Test” from the first green
screen after booting up with the install disk?

to test a single module, remove three and run the test overnight, then
next night install a different module and run the test overnigh, etc
untill you have proven each module ok…

windows uses RAM in ways different to Linux…linux will barf on RAM
that is broken while windows never touches the bad ram…

that is to say, booting windows is NOT a test of RAM for use with Linux!

to me it sounds like the fourth socket is bad…because:

  1. 32 GB of RAM is not a problem with Linux (really! 256 GB is not a
    problem!!)

  2. when only three sockets are filled it works fine with several
    different Linux distros, but when you fill the last socket you have
    trouble with several distros (proof it is not a distro problem, it seems
    to be a hard ware problem

now, it might be that if you always have been putting the same module in
the same socket: if you take the one you have been putting in the last
socket and put it into the first socket you may have the same problem
with only one, two or three installed…

so, figure out either which module is bad or which socket is bad, and
replace the hardware and your “linux problem with 32 GB RAM” will
suddenly disappear!

(take that bad hardware back to where you bought it.)


DD http://tinyurl.com/DD-Caveat
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

On 2012-02-14 14:36, shauncw wrote:

> Here’s an update on the problem. Looks like there is some issue with
> OpenSUSE and 32GB of these memory modules. I’ve already listed the

> I’ve searched the web and can’t find any issues with 32GB of ram and
> Linux and honestly I didn’t expect to find any. I’ve confirmed that the
> LiveCD for Fedora16 gives me the same results. Boot takes FOREVER and
> moving around is like watching syrup run uphill in winter. I’ve gotten
> the same behavior in CentOS 5.6 and OpenSUSE 11.4 KDE 64bit LiveCD.

Then it is not an issue with openSUSE, it is an issue with Linux and your
board.

> If anyone has any suggestions on the issue or recommendations on what
> to checkout, please let me know.

Try the mail list.

> I’ll try to check this forum over the
> next few days. I’ll also close the issue by next week if no additional
> answers are pending.

Issues are never closed here :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Stupid question, but is there a BIOS update out there that might help with this problem?

I understand your frustration … newer hardware sometimes is a bit “fun” to try and get working with Linux. What if you tried booting with all 32GB installed, but you restricted the amount of memory at the boot prompt (I think that the boot prompt is maxmem=<size>)? That might help you determine if there is something magical about the 32GB of RAM on this system, or if it’s a bad memory module.

HTH…

On 2012-02-14 19:36, katanacb wrote:
> you determine if there is something magical about the 32GB of RAM on
> this system, or if it’s a bad memory module.

I don’t think there is a bad memory module. Just a smell. I think something
is done or not done in Linux. I would have a look at the boot log and
messages log to see if something interesting is logged.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Folks,

I eventually ran out of time on this issue. Due to a looming deadline I was overruled and Windows 7 Pro was installed. There was a similar issue with 32GB on Windows but 24GB seems to work fine. I’m thinking the suggestion from DenverD, Katanacb and robin_listas regarding the 4th memory slot was probably right on. I had planned to test this theory out. Unfortunately, the box is now in constant use and testing this will have to wait for another time.

Thanks for all the great suggestions and testing methods. I really appreciate all the help and support. I just wish I had more time to come to a complete diagnosis on this issue.

I’m closing out this issue.

Thanks again to all.

Shaun.

All the talk of bad DIMMs or memory slots is off base. Your bounce buffers are throttling the space needed for DMA and IO.

High Memory Management

The solution is to use 64 bit, or remove memory. Just because it can work with 32 GB of ram doesn’t make it practical, or a good idea.

On 2012-03-02 14:56, kdemello wrote:
> The solution is to use 64 bit, or remove memory. Just because it can
> work with 32 GB of ram doesn’t make it practical, or a good idea.

I understand he did try with 64 bit and got the same problem.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)