System randomly crashes and only rebooting fixes it temporally.

Hello, I have a xps 15 9550 running on tumbleweed and it randomly crashes the system and returning to the login screen but it unable to login again forcing me to hard reboot the system. In the login screen I tried to access the other TTY and I am still unable to login but it spits out these error messages:

 2264.078299 ] BTRFS error (device dm-1): bdev /dev/mapper/system-root errs: wr 2169, rd 91, flush 0, corrupt 0, gen 0
 2264.078419 ] BTRFS error (device dm-1): bdev /dev/mapper/system-root errs: wr 2170, rd 91, flush 0, corrupt 0, gen 0
 2264.078537 ] BTRFS error (device dm-1): bdev /dev/mapper/system-root errs: wr 2171, rd 91, flush 0, corrupt 0, gen 0

For information I am using bumblebee with the proprietary drivers.

Would you mind, telling us more about your disks?
Do you use a RAID array (which level)?
Did you check the health of the disks ? (e.g. with smartctl)
Did you check the file system ? (btrfs check, btrfs scrub, …)


I have a nvme drive on the laptop. I can’t get the smart info of the drive as it failed with error code NVME status 0x4002.

I can’t even check the btrfs as it spits out cannot open files system.

I run the tools on a rescue disk to avoid any errors but it is not the case.

For your information I don’t use raid as I switch it to achieve mode to enable installation. The drive is in a lvm format with separate virtual partions for the root, home and swap.

There is a package named “nvme-cli”. This contains a tool (nvme), which should be able to list information, check S.M.A.R.T values etc., for nvme devices.
As I do not own any nvme hardware, I’m afraid, I can’t give more detailed help here.
Some generic suggestions:

  • check for BIOS updates from the manufacturer of your machine
  • check for firmware updates of the device in question