System/Plasma stops responding

So I installed Leap 15.0 on Saturday (26.05) on my HP Probook 450 G3. I did a fresh install including formatting /home partition. Only settings I copied from previous version were DBeaver, Firefox and Thunderbird.
I use my laptop for work for which I need to use Virtualbox (with Windows), DBeaver and Android Studio. Other than that I also have Spotify up and running (playing), Firefox, Thunderbird, Kadu, KeepassXC and Nextcloud client.
My CPU is Intel Core i7-6500U, I have 8GB of RAM (4GB allocated to VM but it’s not running when I don’t need it) and 256GB SSD with system partitions (/, /boot, /home, swap) and 1TB HDD with data partition, both drives are encrypted (separately), excluding /boot partition.
Everything running with plasmashell from standard repos.

So that’s it for opening. Now to my problem.

After using my laptop for a bit of time (yesterday it took about 4 hours) system stops responding (and yesterday I wasn’t even using Virtualbox). Sometimes mouse pointer won’t even move, sometimes it moves with huge delay (and not really smooth) and sometimes it moves normally but nothing is responding to clicks. Yesterday it happened to be the second option (with huge delay), so I tried to switch to first virtual console (ctrl+alt+f1) and run top. It took a while to switch to that console and I even managed to login but when I tried to start top it just hang in a new line. I was waiting for top to start for about 5 minutes with no effect and canceling with ctrl+c took a few minutes to take effect.

Not sure what data I can provide to help you with helping me so that’s my first question. I’m pretty sure the problem will appear today so I will be able to send some logs or something.
FYI - on my first day of work with Leap 15 my system hang about 3 or more times during 8 hours of work.

Which desktop environment? Wayland or X-server?

systemctl status display-manager
ps -A|grep X

Sorry, I forgot about that.

it’s X-server

Graphics card details?

/usr/sbin/hwinfo --gfxcard
filip@norm07:~> sudo hwinfo --gfxcard
11: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.378]
  Unique ID: _Znp.XUvaxIqCEx6
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Device Name: "Onboard IGD"
  Model: "Intel HD Graphics 520"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x1916 "HD Graphics 520"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x8101 
  Revision: 0x07
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0xf0000000-0xf0ffffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  I/O Ports: 0x4000-0x403f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 126 (2503198 events)
  Module Alias: "pci:v00008086d00001916sv0000103Csd00008101bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #11

A quick search online seems to throw up a number of similar reports describing similar behaviour with Mobile Skylake hardware. A similar report in this thread. In particular, the OP linked to this ArchWiki page which might be relevant:

Enable GuC / HuC firmware loading

For Skylake and newer processors, some video features (e.g. CBR rate control on SKL low-power encoding mode) may require the use of an updated GPU firmware, which is currently (as of 4.16) not enabled by default.
It is necessary to add i915.enable_guc=1 to the kernel parameters to enable it. Alternatively, if the initramfs already includes the i915 module (see Kernel mode setting#Early KMS start), you can set these options through a file in /etc/modprobe.d/. E.g.:
/etc/modprobe.d/i915.conf options i915 enable_guc=1 You can verify that it is enabled by checking dmesg:
2.142029] [drm] GuC loaded (firmware i915/skl_guc_ver6_1.bin [version 6.1])
Alternatively, check:

cat /sys/kernel/debug/dri/0/i915_huc_load_status

cat /sys/kernel/debug/dri/0/i915_guc_load_status

Ok, I’ve added that option to kernel parameters in grub, here’s result of dmesg

    7.752013] [drm] GuC: Loaded firmware i915/skl_guc_ver9_33.bin (version 9.33)

Fortunately, I didn’t have any problem today (even before adding this option).
I will let you know in the next week (we got a long weekend now in Poland and I probably won’t be using my laptop at this time) if I had any more system hangs.

For now, thanks in advance.

Well, at first it looked like it did a trick but yesterday my system stopped responding while using both virtual box and android studio. After accessing virtual console I managed to kill android studio (which was using about 35% of memory, according to top) and I could start it again and get back to work.
Today I was using only android studio and system stopped responding. Top said that android studio (I assume it’s android studio as it is presented as java) was using 25% of memory and next was some Web Content. This time I killed Web Content process and system started responding again but after about half hour it stopped responding again and this time I couldn’t even access virtual console.

It would seem that Android Studio is the problem here but in my opinion it’s something wrong with memory management. I don’t think that 8GB RAM wouldn’t be enough to run a web browser and an IDE.

Here are photos of top command results


. I don’t think that 8GB RAM wouldn’t be enough to run a web browser and an IDE.

Maybe yes maybe no.

  1. run a memory check to test memory maybe some is bad

  2. How big a VM? How many tabs you normally run? FF is a major hog and does not like getting parts moved to swap.

  3. how much swap being used?

Normally I’d say 8 gig is plenty but you are running 3 major memory users plus desktop plus background processes.

  1. will do that today in the evening

  2. VM got 4GB of RAM assigned, it’s main (C: drive) vdi file has 93,4GB (with one snapshot saved) and it got 182MB of GPU RAM assigned. It’s also got option to start second screen enabled (but I only use it when it’s necessery which recently is almost never).
    FF tabs depend mostly on what I’m doing, for few past weeks I got about 8+ tabs open.

  3. It’s hard to tell as I just gave up and went back to 42.3 (with cinnamon), it was impossible to work with so frequent restarts. I had (and still have) 8GB of swap. Now (as I said, on cinnamon) with VM, Android Studio and FF (with 9 tabs open) 3990504 KiB of swap is being used.

Never managed to run memtest but my company got me another 8GB of RAM and that seem to do the trick.