System logs in automatically


I have switched over to SuSE from OSX, or am in the transition to do so. Still quite a lot kinks, but I’m able to get my work done which is the main thing. I’ve been using LEAP 15.0 for a couple of months or so now.

At some point this system has started to login my user automatically. I have NOT selected “Log in automatically” option in System Settings / User Manager. I have also gone through every setting I’ve found regarding this, but can’t find a setting to disable this.

So pretty much this machine has been open for anyone in our office for some time now. Only thing I am 100% sure this machine DID ask login information when I installed it and I’ve been using it daily with only shutdowns happening on some fridays, but mostly this is on 24/7. When I lock the system manually, it stays locked until I login again.

Any help with the settings or debugging this would be appreciated.


Instructions at might work. If they don’t, help us help you by telling us which display manager you are using, and which DE session. GDM? SDDM? LightDM? Plasma? Gnome? XFCE? Other?

That did the trick and now I see login screen every time! Thanks!

But how did this setting get turned on? Because I haven’t done that, if not by accident that is. Do I need to worry about this in the future?

But thanks alot!

/ Janne

That’s actually the installer default. I always turn that off during install.

Yes the installer defaults to auto-login.