System Language changed without my input

Have an odd issue that I cant seem to fix and not sure if this is a security problem or not.

My language settings at some level on my system has changed to Russian without any commands from me. I am currently learning the Russian language and have a dual keyboard and Ive added this to the system and added the plugin to Firefox but that’s all. I change keyboard layout with a keyboard shortcut.

Went to zypper update today and the descriptive language in konsole asking for password, informing of either retrieving or installing and if i need a reboot are now all in Russian. Also the keyboard layout given in the bottom left of the kdm login is also in Russian even if the layout is gb or us. Then went into Yast gui and thats all in Russian.

Firstly how can i return this to English and, second, how can this happen without expressly issuing a command? Is this a security issue?

So firstly

etc/sysconfig/language output:


## Path:        System/Environment/Language
## Type:        string(ibus,fcitx,gcin,scim,scim-bridge,uim,kinput2,kinput2-canna,kinput2-wnn,nabi,wnn,atokx,xcin,none)
## Default:     ""
#
# A default input method to be used in X11 can be selected here.
# If this variable is set and a script with the same name
# as the value of this variable exists in the directory /etc/X11/xim.d/
# this script is sourced when X11 is started to start an input method.
#
# The special value "none" (/etc/X11/xim.d/none) means:
# Do not use any input method at all.
#
# For more details see the comments at the top of /etc/X11/xim.
#
INPUT_METHOD=""
## Path:        System/Environment/Language
## Description: 
## Type:        string(POSIX,C.UTF-8,ca_ES.ISO-8859-1,ca_ES.UTF-8,cs_CZ.ISO-8859-2,cs_CZ.UTF-8,da_DE@euro,da_DK.ISO-8859-1,da_DK.UTF-8,de_DE@euro,de_DE.ISO-8859-1,de_DE.UTF-8,el_GR.ISO-8859-7,el_GR.UTF-8,en_GB.ISO-8859-1,en_GB.UTF-8,en_IE@euro,en_IE.ISO-8859-1,en_US.ISO-8859-1,es_ES@euro,es_ES.ISO-8859-1,>
## Default:     ""
## Config:      OpenOffice.org,groff,ispell,kde,kdm,profiles,susehelp,susewm,tetex,wdm
#
#
# Local users will get RC_LANG as their default language, i.e. the
# environment variable $LANG . $LANG is the default of all $LC_*-variables,
# as long as $LC_ALL is not set, which overrides all $LC_-variables.
# Root uses this variable only if ROOT_USES_LANG is set to "yes".
#
RC_LANG=""

## Type:        string
## Default:     ""
#
# This variable will override all LC-variables!!
# Again, ROOT_USES_LANG must be set to "yes", if an effect on the superuser
# account is desired.
#
RC_LC_ALL=""

## Type:        string
## Default:     ""
#
# This defines the locale in which messages of programs and
# libraries with i18n-support should appear if a translated
# message catalog for the library or the program is installed.
# This also provides localized yes/no answers.
#
RC_LC_MESSAGES=""

## Type:        string
## Default:     ""
#
# This defines the locale for character handling and classification.
# The libc uses this value in language dependent function calls, such
# as e.g. uppercase/lowercase mapping of foreign characters.
#
RC_LC_CTYPE=""

## Type:        string
## Default:     ""
#
# This defines the locale for sorting strings and characters.
# It is used by the libc to obtain the alphabetical order of characters
# (e.g. for string comparisons).
#
RC_LC_COLLATE=""

## Type:        string
## Default:     ""
#
# This defines the locale for date and time output formats.
# i.e.: 06/09/1999 vs. 09.06.1999
#
RC_LC_TIME=""

## Type:        string
## Default:     ""
#
# This defines the locale for formatting and reading numbers.
# i.e.: 1,234.56 vs. 1.234,56
#
RC_LC_NUMERIC=""

## Type:        string
## Default:     ""
#
# This defines the locale for formatting and reading money values.
#
RC_LC_MONETARY=""

I doubt it is in your system configuration. I think it is in your desktop configuration (I guess KDE, but you did not tell us).

You could try to check that by going to locigal console #1 (Ctrl-Alt-F1), log in as root and e.g. do a zypper command there.

Thanks for your quick reply
Yes KDE. Tried that and all in english. but gui…

Ok solved it
I had added Russian as an alternative language in KDE regional settings. However the default and top language on the list was English so don’t know why it used Russian anywhere on the system Ive deleted Russian and rebooted and all back to normal.

1 Like

Nice you solved it. But I still find it strange that KDE switched from your primary to your secondary language without your consent.

1 Like

Because English language catalogs usually do not exist so system selects next available language catalog in order of preference.

If you were not so fast, it had been possible to show which environment variable is responsible.

KDE did exactly what it was told to do. That selecting English as preferred language for message catalogs does not work is IMHO long standing bug in gettext design.