System Keyboard Layout

Hey guys,

I’m trying to setup my Num Lock to stay On at all times, so I set it up to Yes in the System Keyboard Layout Num Lock On but it never does, I have to press the num lock button every time, this is on OpenSuSE 13.2

What can I do?


You need to give far more information. If you are using KDE have you used System settings(Configure Desktop)>Input devices>Keyboard>Advanced?

Under Miscellaneous Compatibility Options, there is Numeric keypad keys always enter digits.

This is what I’m talking about.

But even though it is On, it isn’t.

You still have not said the desktop in use. It does make a difference since there is system setting and desktop settings. Remember that Linux is multiuser so each user can set his/her preferences.

I’m using KDE. and I’m the only user on this one.

That you are the only user is not the point the OS is designed for multiple user thus you have to give each potential user the choice.

So did you follow the instructions above from john hudson??

If you are using KDE have you used System settings(Configure Desktop)>Input devices>Keyboard>Advanced

You have set the system setting but you have to also set your personal. So system functions should default on but personal setting would default on off. Since different desktops differ in how and where this is done you have to tell which you use

Read the left pane carefully: Note that it says settings here do not apply to the GUI keyboard (that is, on the desktop).

Follow the directions given you earlier in this thread.

Hello :wink:

i have a similar issue, using Plasma 5 as gui .

In Bios Numlock is set to ON.

In system settings/human input device/keyboard/Hardware i have ‘Turn on’ for Numlock on KDE Startup.

In system settings/human input device/keyboard/Advanced you mentioned above : i can’t find how to set the numlock On in KDE : where is it exactly ? (i never had to do this before, is this new ?)

In Yast/hardware/keyboard/expert settings it was on “Bios parameters” . What’s the difference between “Bios” and “Yes” options if Bios is set up to yes ?

Thanks :wink: