System keyboard layout switches to US-layout

I have a painful problem with my system keyboard layout configuration which is turning into US layout every time I start up Leap (in Lenovo Z50-75 laptop with Windows 10 OS, and Leap 42.2 in an external USB drive)l. It even switches into US layout during the sessions. My original layout selection in the installation was Finnish. Yast2 can not fix this problem permanently. Any help?

Anybody can help me with this problem:’(. I checked with Yast the etc/sysconfig settings. The hardware/YAST_KEYBOARD = finnish,pc104, and KEYTABLE is empty. Should I change the KAYTABLE value to Finnish? The problem is that I do not know where to find the keytable file. Please, help me.

You must set in two places one is for language used by the system the other for each user in the desktop setting of what ever Desktop you use. Remember Linux is multi user and nothing says different users can not use different languages

Thanks gogalthorp…but I have set my language to en_US and I have only one user with keylayout set to finnish. Have been using Linux for decades, but never met this kind of problem before. If I reset the keyboard layout in Yast to Finnish, it changes back into US after some seconds. One other symptom is that when writing this post the space button does not work at the end of the line.
In Yast language details the original for user root was ctype. I tried also the setting Yes without any impact. Some people say that the problem comes from BIOS, but have not found any advice how to fix it.

Hi,I got the problem solved. I’m normally using the GNOME workspace, but have also the KDE and Cinnamon workspaces installed for testing. I did the changes in KDE plasma workspace … and it started working :). Just wonder how the configuration should have been done in GNOME.

Don’t use gnome but should be an option some where :wink:

You need to modify the GNOME keyboard layout:

Go to Settings > Region & Language > Input Sources

Once there, remove add or whatever you need to do.