System is slow, and I can't figure out why

Firefox is sometimes slow opening new tabs/switching between tabs. If I click on the kickoff application launcher button, it takes a few seconds to open, and typing something in the search makes it hang up for about 20 seconds before it does the search. Clicking on an app takes 16 seconds before the menu window closes and the program begins to start. Then it takes another 30sec-1min before the app is usable. smplayer plays video with tearing.

Like right now I tried taking a screenshot, and it tells me

Error launching /usr/share/applications/kde4/ksnapshot.desktop. Either KLauncher is not running anymore, or it failed to start the application.
while the app worked fine.

I also tried running glxgears right now, and it runs but the gears don’t move, and terminal states

15 frames in 19.0 seconds = 0.789 FPS
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server “:0.0”
after 48 requests (48 known processed) with 15 events remaining.

If I’m on dolphin, and I click a video to start smplayer, it takes about 1 minute for it to start.

Memory is using 1.4GB out of 3.6GB, with 0.08GB/2GB swap

Top shows an average usage of less than 10% average. Xorg is always 25%, kwin is always 10% and then rest of the apps are less than that.

CPU: AMD Athlon™ II X4 620 Processor
Integrated VIdeo: HD4200 with fglrx driver

When I ssh into the computer with x tunneling, the programs start up faster than being on the desktop

What happens if you uninstall the ATI driver? Not that that is a long term solution, but it’s worth a shot to see if it’s your graphics driver that’s causing this. The out of the box driver should work for the HD4200, if I’m not mistaken (check first).

I guess the issue could be varied, but let us know what openSUSE, kernel, and KDE versions your are running. Are you trying to do or run things as a root user from a non root user person? Like trying to edit system files as a normal user but using a Super User file or terminal session when this problem occurs? Has your system ever worked properly since the install or did some past event like a system update bring on this slow condition? Have you noticed high disk activity and are you slowly running out of disk space? Are you by chance using the HP printer driver. Do you have a EXT4 partition for openSUSE? This is just a few questions I would have for you.

Thank You,

if this is on the same computer that you describe in
i HIGHLY suggest you SOLVE completely the mess you describe there
BEFORE you do anything with what you describe here…

because i think most everything here are symptoms of the PROBLEM in
your post of three days ago, which no one has answered…and i can’t…


heh, well…

I was watching something on smplayer, and the image tearing was bothering me, so I turned off compositing to see if it would help. It didn’t change a thing, but what it did do was stop my system from lagging.

Earlier today my system starting lagging again, so I turn off compositing, and immediately turn it back on, and the lag was gone.

But with composite running, the effects are smooth. And there is no noticeable resource logging during the lag. So I have no idea. I’d assume its something with kwin + compositing + fglrx drivers, but I’m not sure. Or just the driver itself? (would explain the tearing while watching on smplayer, but not the smooth effects or Warcraft 3 running smooth in wine)

Open a console and run top

See if something is eating CPU.