System hangs under strange conditions

I’m having this strange problem where the system hangs in conditions as follows:

Bring up the shutdown dialog through the KDE menu. If I move the cursor immediately after it appears on the screen, the computer hangs completely, accepting no input and forcing me to shut down the hard way. If I wait for, say, 2 seconds everything goes fine.

Today I was installing a game and while it installed, doing other little things around the system (none of them which could disturb the installation process). Rapidly moving the cursor to do a task (e.g. closing the menu) would cause the system to freeze up. Interestingly, doing something more taxing than simply rapidly moving a cursor (like running Firefox) wouldn’t cause it to hang. :\

I’m tired of having to creep about my system slowly and quietly like a mouse where a cat is kept for the fear that the system will hang if I don’t.

I’m aware this might be a driver/hardware issue but I don’t know where to start. Any help appreciated. :slight_smile:

P.S. Not ALL rapid movements cause it to freeze up. Still, the system doesn’t crash except when I do something similar to the scenarios described above.

does it happen with mouse only?not touchpad(if !desktop)?
u could reconfigure your mouse from the basics again
not having much idea
Does the cpu usage increase as u move ? which process?

Thanks for the response:

It is a desktop and the only pointing device is a mouse …

Right now I am on a different computer. I’ll check it when I use it again. I don’t feel the problem is a resource-hogging process though …

On second thought, it might be the over-flashy desktop effects? It looks like it because the hang-ups only happen when some fancy desktop animation is being played (menu sliding animation, screen dimming etc.)

Do you mean through Yast? I’ll try that … but I already reinstalled Suse 11.3 another time to see if the problem was fixed and it didn’t work. Still, i’ll try reconfiguring it.

Anyway I’ll look into it … maybe try disabling effects and see what happens. Default settings in oS 11.2 weren’t so emphasizing on eye candy and there were no crashes.
This only started with 11.3.

Video card? Driver?

sorry for the newbie question, but how do I find out exactly which video card I have and the driver? It’s an Intel that I know …

EDIT: figured out the card: (output from lspci)

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

BrownieCat adjusted his/her AFDB on Sun 18 July 2010 14:06 to write:

> On second thought, it might be the over-flashy desktop effects? It
> looks like it because the hang-ups only happen when some fancy desktop
> animation is being played (menu sliding animation, screen dimming etc.)
>
> Anyway I’ll look into it … maybe try disabling effects and see what
> happens. Default settings in oS 11.2 weren’t so emphasizing on eye candy
> and there were no crashes.
> This only started with 11.3.
>
>

There are a couple of plugins that do not play well together and can cause
erratic behaviour.

Try knocking off all effects for a start then add them one by one.


Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

@baskitcaise: I did what you suggested. Everything’s fine now (no having to “move around like a mouse” :p) but didn’t do any hard-core testing. A faulty video driver doesn’t seem to be the issue (graphics-intensive apps work flawlessly).

no having to “move around like a mouse” :stuck_out_tongue:

cat after the mouse