system hangs and then reboots to CLI : .snapshot is full : how to recue ?

My current system is 13.1 and i would like to move to 42.2 . It’s difficult.

I was starting to feel better with this new 42.2 after a few days of work.

But suddenly the system hanged for unknown reasons.

I rebooted by switching to ctl+alt+f1 , logged to root and typed reboot .
Then, no more login screen.
Many complaints like “no space left on device” appeared .

Logged in as root on tty1 and typed :

du -d 1 /

and discovered that .snapshots was saturating the disk
And

df

showed that / was full .
I tried to erase a few gigabytes in my /home/user and rebooted.
The system went back to login screen but it froze again after login and then no login screen after reboot ! :frowning:
So i tried some commands like

snapper rollback

because i read on this forum that snap-something was a big problem with btrfs . But no success. Plus i don’t want to destroy more than what’s been already broken.
I am quite mad because i lost all my work.
I really would like to rescue my system.

I tried to search the forum that i read every day since almost 9 years, but i did not find any clue .

What should i do ?
Please help me.

is home on btrfs?
dont use df etc they dont work
for space: sudo btrfs filesystem usage -h /
list your snapshots: sudo snapper list
you cant delete numbers 0 and 1 + leave last few, also delete pre/post pairs together.
so to remove range: sudo snapper rm num1-num2
IF you cleared space you can now rebalance: /etc/cron.weekly/btrfs-balance

let us know how you get on + prevent from occurring in future
rollbacks are useless for disk-full

Yes / (and /home is on the same partition) is on btrfs

You wrote

you cant delete numbers 0 and 1 + leave last few

Do you mean i “can” or i “can’t” ?

Which one should i delete ?
Can you be more clear please ?

Delete all above zero 0 the list command above should make it obvious

How much space did you give root??

here is snapper instructions

https://en.opensuse.org/Portal:Snapper

I would like to thank both of you for your quick and efficient answers .
I recovered my login screen

I haven’t done this btrfs-balance . Should i do it now ?

Never hurts

And it looks like i spoke too fast : it froze again.
It looks like .local/share/akonadi has exploded again because i am trying to install my mails on my new systems.
Yes, i have tens of thousands of mails, but i have many gigabytes to save it…
Strange

Sorry if i post this in this thread and in another one, but i really need help :
Because i get crashes around 4 or 5 times a week, now i really need to get rid of this ***** snapper : tell me how can i kick it away from my system, please