System froze after update - OpenSuse 12.2


I’m absolutely new to OpenSuse, and I don’t know very much about computer things. I am used to work with Ubuntu and in work all computers are set to OpenSuse. The computer I started using this week had version 12.2 installed. In general it was working fine, but there were some specific problems so i decided to update the system. So, i did (and now I realize that for many reasons I should have been more carefull)

sudo zypper update

and there were many updates to be installed so I let it there updating. The problem is Konsole stopped responding during the proccess (ater about 3 hours, and half an hour after shift) and (again very stupid) I reboot the system. Now, during the initialization proccess it hangs a little in a black and green splash screen (I don’t remember seeing that before). Then, the login screen appears normally, but after I enter with my user, an error related to Consolekit (sorry I cant give details about the error, but I was kinda in a hurry to leave work and got very nervous with what I mught have done). Then, the system loads for a bit and stops in the screen with OpenSuse and the lyzard, from where I can’t do nothing (I only waiter for 1-2 minutes). What I did is I reboot again and shut down in the login screen, and I am planning to go there back early and try something to to fix it.

Now, I imagine that the most experience people will point out the mistake I did by performing an update without backup and also reboot during update and on and on, and I agree it was very dumb what I did. But you might imagine how nervous I am because there are some data from other people in the computer and I don’t know how important it is, and also I need the computer to work. So, I have been searching around the internet and did not found any problem related to that (maybe because nobody else was that irresponsible as I) so I decided to start this thread. I know that you might need more details about how the system is behaving, but I will not be able to provide for at least 11 hours (till I get back to work), so I ask if anybody can suggest something.

Thanks for your help (or even for taking your time to read the long post).

Which updates did you install?
openSUSE 12.2 doesn’t get any updates any more since over a year ago, as it is out of support since January 2014, see here:

You can try to login to text mode (press Ctrl+Alt+F1) and maybe fix your system. Or try to select “IceWM” at the login screen, this should even work without ConsoleKit.
Maybe just running “sudo zypper up” again to continue the aborted update might fix it.
But as 12.2 doesn’t get any updates any more, it would rather sound like you added some repo that’s not intended for 12.2 and this caused your problem in the first place.
Please post your repo list for further advise:

zypper lr -d

But as 12.2 is unsupported, I would rather suggest to download a supported version (13.1 or 13.2) and do an upgrade installation.
This should be the easiest way to fix your system.
If it still doesn’t work then, you might also consider a fresh installation.

Thanks wolfi323.
Let me see if I understand what you mean. You said that maybe only finishing the started updates (zypper up) could solve the problem but it is more likely that, as openSUSE 12.2 isn’t supported, the problem was not with the interrupted update but with what I updated, right?

In this case, you would need the repo list to check where the mistake might be.

Now…the download of the suported version should be done in another computer and the installation with a CD? And, would I be able to kkeet my data in the computer if I installed a new version?

Thanks again.

Yes. As the last update for 12.2 has been released over a year ago, you must have some additional repo(s) where you got updates from.

Or you just didn’t update your 12.2 system when it was still supported (and also not since then)… :wink:

In this case, you would need the repo list to check where the mistake might be.

Yes. If you have some unsuitable (for 12.2) repo, you should better remove it.

Now…the download of the suported version should be done in another computer and the installation with a CD?

Well, it doesn’t matter whether you download it on another computer or this one.
And you can install it from a CD/DVD, or you can also use an USB-stick.
See [noparse][/noparse]

For instructions how to copy the installation medium to an USB-stick, see here:

It is also possible to do a Live-Upgrade, also called Online-Upgrade, in the running system without booting from an installation medium. But as your system is not really running at the moment, this might prove difficult.
Anyway, see here if you’re eager to try that:

So, have you tried to login to IceWM or text mode?
Do you have a working Internet connection then?
As I said, maybe just completing the update would fix your system again. Depends on why it broke of course.

It should be fixable in any case, but you’d likely need some more experience to do that. And guiding you via the forum is probably not so easy either…

And, would I be able to kkeet my data in the computer if I installed a new version?

If you upgrade, nothing is lost. That’s the point of an upgrade versus a fresh installation.

When doing a fresh installation, the system partition would get re-formatted and everything on it deleted. Normally you should have all your data in your home directory though, which by default is on a separate partition which would not be touched either (unless you tell the installer to format it too). You’d lose some system settings though, and all installed programs.

Thanks again, wolfi323.

I managed to login in text mode. At least the data is safe.
I tried first the your suggestion I thought was easy…just did zypper up. It did more updates, now it says it has nothing to do, but now not even the login screen is loading as it stops in the green black splash screen.

I cant copy exactly the output of “zypper lr -d” but here is what I can remember (sorry I cant give it exactly, but its the best I can do, so I figure, why not?)
mozilla, Oss, Non-oss, update (all with 12.2).

I’m start to think, that maybe the best thing to do is save the data, and install or ask someone to do it.
But, is there some magical advice you could give like

“Oh, thats easy, just type X in text mode and it will update the repo list and then type Z and Y and the system will update to a fine working version” lol!

Thanks anyway for your help so far.
Anyone that reads this and can give a fine advice, plese answer.

No you have to do a offline upgrade to 13.1 or 13.2. 13.1 if you want long term support via Evergreen.

But really If you are mixing repo versions or something else 12.2 is dead no update no support the repos may or may not be totally functional because they would most likely be on mirrors near you and it is difficult to know what condition a given mirror is in for a non supported product.

It is really difficult to know what you have done and near imposible to know how to fix it.

In a tipical setup your personal data is all in the home partition and you can do an upgrade from the full DVD and that data will be preserved. But if you run web-servers and databases the data may be on the root partition. We have no means of knowing what you use your machine for you have to tell us then we can advise more fully.

Well, for an Upgrade it doesn’t matter where the data is.
An upgrade doesn’t wipe out anything, it just installs the new packages into the old system, simply put. In this case it doesn’t even matter whether you have a separate /home or not.

If you do a fresh installation, / will be formatted so everything there is lost (although you could tell the installer not to, but that can cause problems). So this is only advisable if you have all your data on a separate partition, or backup all data before you do a fresh installation.

As I already wrote, an upgrade should hopefully fix your system. And the safest way is to do that via an installation CD/DVD/USB-stick (as gogalthorpe stated as well).

It would definitely be possible to fix your old system (without upgrading), but it would be extremely difficult (or even impossible) to guide you through this via the forum. And without exact information from you, it’s impossible to have any idea in what state your system is and what exactly to do to fix it.
In any way, the easiest way to fix it definitely is to boot from an installation medium and do an upgrade installation. If you’d insist on staying with 12.2, you could even download/boot an 12.2 CD/DVD and “upgrade” to that… But as 12.2 is out of support for over a year already, it would be better to upgrade to a supported version instead. I would recommend 13.1 for now, as the gap is not that big (actually it is not really recommended to skip versions when upgrading, but especially via the “offline” method it should work without problems).

One way to diagnose your system a bit at least, would be to login to text mode as root and run “startx”. Do you get a graphical environment? If not, what exact error messages do you get?
Press ESC and/or Ctrl+Alt+F1 to get rid of the splash screen and be able to login.
And running “zypper dup” might also help, but that depends on your repos. If you really only have those that you mentioned (in the 12.2 versions), you should try it though.

I tried startx and the errors are

file /home/****/.serverauth.1961 does not exist

Fatal server error:
Cannot move old log file “/var/log/Xorg.0.log” to “/var/log/Xorg.0.log.old”

xinit failed /usr/bin/Xorg is not setuid, maybe that’s the reason?

So…I initially intended to run zypper dup, but I am insecure with the repos. What repos is the minimum I need to try a zypper dup to fix it?
And, if I can’t do nothing i intend to try an offline upgrade like you said…I am reading about it…does not look that hard… but is it sure the data will be safe? (I know I should backup everything, but the ammount is huge, so I am only saving the most important, but it would be good to save everything).

Thanks again.

By the way, it seems my system has to be updated to run an offline upgrade and it is not recommended to jump releases (my version is 12.2 and so I could not go directly to 13.1 unless I go to 12.3 first).
What can you tell me about that?

You need to run startx as root, so login as root and try that.

So…I initially intended to run zypper dup, but I am insecure with the repos. What repos is the minimum I need to try a zypper dup to fix it?

You should have 4 repos: repo-oss, repo-non-oss, and the corresponding update repos. But the names are arbitrarily.
It’s better to disable anything else for the “zypper dup”. (you can disable repos with “zypper mr -d X”, or use YaST->Software Repositories, this works in text mode too)

If you get conflicts and are not sure, better ask.

And, if I can’t do nothing i intend to try an offline upgrade like you said…I am reading about it…does not look that hard… but is it sure the data will be safe? (I know I should backup everything, but the ammount is huge, so I am only saving the most important, but it would be good to save everything).

As long as you don’t boot from the installation, choose to do a fresh install and explicitely tell the installer to format /home as well, the data should be safe, yes. If you don’t have a separate /home (which is the default), a fresh install with the standard options will remove all data as well though because it will format the / partition.

But if you do an upgrade, even the configuration should stay in place.

The installer should let you choose between a fresh installation and upgrading an existing installation if it finds one.
But please note that this has changed a bit in 13.2. You need to choose at the boot menu there already. If you choose “Install” there this means “do a fresh installation”, there’s no chance to choose “Upgrade” later on.

Well, you can go to 13.1 directly, it’s just not explicitely recommended to skip versions, because only an upgrade to the next version is tested really.
But it should work, especially if you do the offline method.

And you don’t really have to update the system for an offline upgrade, although it would not harm either.

I ran startx as root and a lot appeared in the text before the screen went black and what I can read that looks like an error is :

/usr/bin/gnome-session: symbol lookup error: /usr/lib64/ undefined symbol: g_type_check_instance_is_fundamentally_a
xinit: connection to X server lost

So to run zypper dup I can disable the DEBUG and PHP repos?

You do have to change the repos to point to the new repo before you do a zypper dup. disable all but the base repos

It may or may not work. the offline method is more likely to work. Note doing the online method does not save all that much on the downloads. Hand having a bookable media come in really handy if you have a serious problem.

Well, this definitely sounds like an installation problem… :wink:
Apparently your installed dbus-glib doesn’t match your installed glib.

Running a “zypper dup” with the standard 12.2 repos should hopefully fix that.

But as I wrote: if you get a conflict message and are not sure what to choose, better ask again before you continue.

Yes. You can disable the debug repo anyway, you only need this if you want to investigate a crash.
If you disable the PHP repo, your installed PHP will be switched back to the standard version shipped with 12.2.
But AFAICS there is no php repo for 12.2 any more, so you should actually get error messages if you have it enabled…

But please run “zypper lr -d” and verify that all your (4) enabled repos really have 12.2 in the URL. Such a problem is typically caused by incompatible repos.

I checked the repo and ran zypper dup and the following happens:

2 problems:
Problem: icewn-lite-1.2.38-15.1.2.x86_64 conflicts with icewn default, … by icewn-default-1.3.7-21.1.2.x86_64
Problem: patterns-openSUSE-base-12.2-5.5.1.x86_64 recquires module-init-tools, but could not be provided

Solution 1: desinstall icewn-default-1.3.8-3.1.8.x86_64
Solution 2: desinstall icewn-lite-1.3.8.-3.1.8.x86_64

It is asking me to choose the solution or ignore or cancel and probably after I select it will as the same about error 2

Well, for icewm it should not matter what you choose. Depends on whether you use icewm or not, I suppose. icewm-lite is a bare minimum version, icewm-default contains more stuff. IIRC, icewm-lite was installed by default in earlier versions, so I’d suggest to deinstall icewm-default.

Regarding module-init-tools: they got replaced by kmod-compat in later openSUSE versions, so this would definitely suggest that you had a repo for a later openSUSE version (or Factory/Tumbleweed) added at some point.
I would suggest to cancel for now, then run “sudo zypper in -f module-init-tools”, and then run “zypper dup” again.
You should only get the icewm conflict then, where you can basically choose what you want as mentioned.

I ran the module-init-tools as you said and then this error appeared:

kmod-compact-18-2.2.2.x86_64 installed obsolete module-init-tools < 3.16 by module-init-tools-3.15-3.6.1.x86_64

And then it suggets as solution 1 a very long list of downgrading and as solution 2 not install module-init-tools-3.15-3.6.1.x86_64

Choose 1 there, to downgrade all those things that require kmod-compat.
They are supposedly from a newer openSUSE release (otherwise they wouldn’t require kmod-compat) and would be downgraded by “zypper dup” anyway.

After all downloads were complete the installation stopped during

installing: plymouth-branding-openSUSE-12.2-11-12.1

What’s that?