System freezes when youtube full screen

YouTube videos play fine in Firefox. But when I select fullscreen it freezes. Any idea?

Probably related to your graphics driver or lack of it.
Or possibly a conflict with desktop effects

We need more info than - ‘it freezes’

Tell us about your system/hardware etc…

My system specs
Opensuse 11.3 Gnome
Intel core2duo 7200 CPU
Intel 82G33 Integrated graphics

Intel 82G33 Integrated graphics
New one on me.

Do this in a terminal

/sbin/lspci -nnk

Post the part relating to your graphics, usually at the beginning of the output.

Here is the output:

sriram@linux-rnh7:~> /sbin/lspci -nnk
00:00.0 Host bridge [0600]: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller [8086:29c0] (rev 10)
Kernel driver in use: agpgart-intel
00:01.0 PCI bridge [0604]: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port [8086:29c1] (rev 10)
Kernel driver in use: pcieport
00:02.0 VGA compatible controller [0300]: Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2] (rev 10)
Subsystem: Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2]
Kernel driver in use: i915

I am was going thru the log file and found this:

<6> 2.719728] [drm] Initialized drm 1.1.0 20060810
<6> 2.743684] i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
<7> 2.743689] i915 0000:00:02.0: setting latency timer to 64
<6> 2.745135] uhci_hcd: USB Universal Host Controller Interface driver
<4> 2.762514] mtrr: type mismatch for d0000000,10000000 old: write-back new: write-combining
<6> 2.762516] [drm] MTRR allocation failed. Graphics performance may suffer.
<7> 2.762565] alloc irq_desc for 25 on node -1
<7> 2.762566] alloc kstat_irqs on node -1
<7> 2.762574] i915 0000:00:02.0: irq 25 for MSI/MSI-X
<6> 2.762579] [drm] set up 7M of stolen space
<6> 2.763180] [drm] initialized overlay support
<3> 2.926291] fb: conflicting fb hw usage inteldrmfb vs VESA VGA - removing generic driver
<4> 2.926500] Console: switching to colour dummy device 80x25
<4> 2.926824] Console: switching to colour frame buffer device 180x56
<6> 2.945851] bootsplash: scaling image from 1280x1024 to 1440x900
<6> 3.171485] fb0: inteldrmfb frame buffer device
<6> 3.171487] registered panic notifier

Hope this helps.

I think you are going to have to google around on this one.
Have a look here anyway: openSUSE Graphic Card Practical Theory Guide for Users

I take it you can’t enable desktop effects?
Can you run glxgears? (Just try typing glxgears in a terminal and hit enter)

I can run glxgears from terminal.

I tried Linux Mint and Youtube is working fine in it.

Did you check what driver it was using, compared to your output in SUSE

Just to add.
It might be worth uninstalling the X11-nouveau driver
Also, did you confirm if you have desktop effects and if you tried without it enabled?

Same problem here.

There is an open bug related to the intel graphics card driver which I assume you are using? It has recently been resolved and reopened, but should be pushed to the repos soon. It is a kernel (dkms, I think) bug that is causing the problem with intel cards, so a kernel patch will be coming soon. fingers crossed Ref. bug

Hi, i have the same problem on my desktop with ATI Radeon HD3670 and my laptop (don’t remember but must be Intel), both running opensuse 11.3

IINM nouveau is for nvidia GPUs, not Intel. But this gave me an idea regarding flv poor performance in a sempron with onboard nvidia after upgrading from 11.1 to 11.3. :wink:

Thanks caf4926

your problem will be unrelated to the original post.
There was a problem with full screen freeze on flash video with onboard intel video chips.
Has been addresed with a kernel update a few months back.

Indeed. That bug was fixed in a kernel update to 11.3. There may be an unresolved X bug, as even a blank screensaver starting up can freeze Flash full-screen on my standard 11.3 (fully updated) with intel graphics driver. If it doesn’t clear with Esc key, try Ctrl+Alt+backspace which will probably cause a logout, but better than a reboot.

This is a known issue on intel graphics hardware, check out Novell bugzilla.

I resolved this issue on my notebook by installing “xorg-x11-driver-video-intel-legacy”

you also might want to add the line "Driver “intellegacy” to /etc/X11/xorg.conf.d/50-device.conf

Not on all intel graphics h/w; nor with all available kernel releases.

I had this same problem with the Intel GMA loaded on my EEE 1000HE. I’m running OpenSUSE 11.3 KDE and using Opera… Did the above (although the legacy driver was installed by default, I still had to point x-11 to it) and now all is fine.


Sorry to bring back this old topic up.

Im having this very same issue.

When watching fullscreen HD content on youtube, and then pressing Escape, im turned to a black screen, with the last second of sound repeating forever.

There is no way to get out of the blackscreen but a hard reboot.

This is on an ATI Radeon 4850, opensource drivers.
Latest packages from Xorg repository.