System freezes when attempting to start a Wayland session

I installed the plasma5-session-wayland package and got the login manager to offer Wayland as a session option. Earlier I attempted to log in, but this caused the system to immediately freeze: The screen goes black and nothing responds any more (including system shortcuts such as control + alt + f1).

Does anyone else have this issue and knows what the cause might be? Is it something that can be fixed, or is Wayland currently so broken that it’s impossible to even attempt a login?

I expect that Wayland today has the same requirements as when I did some experimenting on an old (very old) machine a couple years ago…
Wayland wouldn’t run on my very old machine (circa about 2003). Should not have problems on newer hardware.


Last year I did some tests with wayland on Tumbleweed.
With Gnome most things worked, except some apps.
Plasma5 missed some features and on my old, slow hardware, it was awfully slow.
But generally it used to work.
I’m not sure, if this is still true with Plasma 5.9. I think, I’ve read something about a serious bug in this version with wayland, but can’t remember the details. Could be in combination with a certain Qt version.


I do have fairly recent hardware, such as a Core i7 processor and Radeon R7 370 video card. As for Wayland in the past, I wouldn’t know since this is the first time I installed and tried it… I heard it was completely unusable back then, however recent voices say that most things should be working which is why I wanted to give it a shot.

I haven’t tried it on my openSUSE installs but Wayland works fine with Fedora 25 and on lesser hardware (HP 255 G3 Laptop) so I wonder if something is missing? I know this doesn’t really add much except that Wayland is definitely becoming more mature.

I found the version incompatibilities between Plasma 5.9 and Qt 5.8 again:
(section Wayland)