System freezes at log-in screen

I installed Leap 15.1 with no problem. It booted OK, but after I installed Zoom and Thunderbird, I could no longer boot the system. It freezes as soon as I type in my password and press enter.

After encountering this problem for the first time, I reinstalled and tried again. The second time I installed Zoom, rebooted successfully, and then installed Thunderbird. At the next reboot the system froze.

I don’t know if this problem is a a result of the TBird installation, if it is the combination of Zoom and Tbird, or it is something else entirely. Any help will be appreciated. I would really like to give openSuse a try.


Neither Zoom nor Thunderbird can cause such problem. I think most likely during the installation of either of the softwares, you updated and activated nouveau.

Can you explain what your hardware is? Laptop/Desktop, GPU and its model? HDD/SSD setup? and etc.

When you boot,
Try selecting the recovery kernel…
For every kernel installed in your system, the first selection (and typically default if you only have one kernel installed) loads everything.
The second selection will boot your kernel but without optional kernel modules.

If you are able to boot,
Then run the following in an elevated console which should display the last 100 lines of your previous boot and hopefully capture whatever the problem was. You can display entries from earlier boots by decrementing the “-b” parameter and modify the “-n” parameter to display more or fewer lines

journalctl -b -1 -n 100

If you need help interpreting the output, post it here (within CODE tags)


Thank you for your advice. I have learned a bit since my initial post. With Zoom and Thunderbird installed, the system will sometimes boot, sometimes not. Also, the system failed to boot with the recovery kernel as well as with the latest kernel. When it doesn’t boot, it hangs just after entering password and pressing enter (or clicking the button to enter). I was able to install several additional programs, successfully rebooting after each. Although I haven’t reinstalled Suse again (a third time) in order to see if the problem will sometimes occur with no additional programs installed, at this point I think that the failure to boot has nothing to do with individual programs that have been installed.

As the problem appears to be intermittent I elected to run MEMTEST86+. It ran for twelve hours without an error. Also, I haven’t had this problem with the previous linux installation on this machine.

When I entered the terminal to use journalctl I discovered that the hostname is very peculiar. hostnamectl returns:

   Static hostname: n/aTransient hostname:
             Icon name: computer-desktop
                 Chassis: desktop
            Machine ID: e83192d8d3494c70927ec46d58474c27
                 Boot ID: 81c804ff9507435481ac60999633e647
  Operating System: openSUSE Leap 15.1
       CPE OS Name: cpe:/o:opensuse:leap:15.1
                  Kernel: Linux 4.12.14-lp151.28.44-default
          Architecture: x86-64

Where did that come from? I don’t remember if I was asked for a name for the machine during installation, but I would certainly want to change that one!

Journalctl -b -1 -n 100 executed after the first successful boot following several unsuccessful boot attempts returned the following: “Specifying boot ID or boot offset has no effect, no persistent journal was found.” This happened several times.

I noticed an error message flash across the top of the screen a couple of times during the boot process. Something about ASL and excess argument, but too fast to read.

Is there someway to specify that the log files are to be saved? I do see some quick flashes of error messages during the boot process.

I attempted to switch to the nvidia driver. I installed the nvidia repository, but the online update didn’t seem to replace the existing driver.

System information:

Motherboard: from Lenovo ThinkCentre A55 (Product ID 926503U)
CPU: Pentium Dual Core, E2160, 1.8 GHz
Graphics Card: Nvidia GT 218, Geforce 210

I also noticed that the video presentation would shrink horizontally, distorting the panel in such a way as to make the application launcher inaccessible, presumably after the screen had timed out. I set the screen blank to never happen, solving that problem, but I have also now installed the nvidia driver. I did that by adding the nvidia repository and then doing the online update. The update seemed to include a lot of other software as well, although the update application in the system tray had not reported any outstanding updates.

Since changing to the nvidia driver and doing whatever those other updates were, It has booted three times in a row. I still see an error flashing across the screen, something about “ASL” and “ACPI requires 4 arguments.”

I have now experienced a dozen startups with no problem. I conclude that the problem was either with the nouveau video card driver or one of the many other programs that were updated or installed with I used YAST to add an nvidia repository, do an online update, and then, with the software manager, add all matching recommended packages.

I declare this solved. Thank you for the assistance, particularly the suggestion that the nouveau driver might be the problem.