System freezes after update to 11.2

I upgraded my Dell 2.53G machine from 10.3 to 11.2 (KDE desktop). Everything seemed fine for the first day. Then the whole desktop froze. No screen update, no keyboard, and, though you could see the mouse move, clicking didn’t do anything. The only way out was to pull the plug.

After multiple attempts at fixing it failed, I repartitioned the disk and tried a “clean install”. Everything worked for about 2 hours. The system is currently frozen. The harddrive is quiet. The only “3rd party app” was Adobe Flash, pulled from the Non-OSS repository.


Next time don’t “re-install”, try checking forum & buglist in Bugzilla.

Does the CAPS Lock key do anything when it freezes?

Do you have another computer you could try ssh into the box and see if it’s X that’s wedged?

Try turning off any Desktop Effects, and see if the problem goes away.

Enable the “Magic Sys Req” key in YaST, then whilst holding CNTRL-ALT-SysRq type R, E, B, I, O, S

Magic SysRq key - Wikipedia, the free encyclopedia
Linux Howtos: Tips and Tricks -> Magic SysRq Key

Better luck, if you can find out if it’s just X (usually is), then you can make much better bug report.

I just turned it back on - the screen is black. It came up a couple of times yesterday but hung up on shutdown. So it’s had multiple hard resets & if the first time was any indication there are now corrupted/missing files

otherwise - no desktop effects (beyond default) have been loaded. I do have another computer - I’ll see if I can SSH a little later.

I had to do another re-installation. The file system was too corrupted to fix. This time the system lasted about 15 minutes before freezing up.

hitting Cap Lock does nothing. No light flashes on the keyboard.
Couldn’t connect to it using SSH - possibly the network connection has been lost.
I did a hard reset and tried the Ctrl+Alt+SysReq REBIOS (kinda hard on the fingers so it took a couple of tries) which rewarded me with a “keyboard error”, a reboot, and now I’m back to a black screen and no system response.

I’m going to try another version/distro and make sure I haven’t got a hardware problem. 10.3 had been falling apart on me, so maybe it’s more of a hardware thing.

On Wed, 25 Nov 2009 23:26:02 +0000, n hand wrote:

> I’m going to try another version/distro and make sure I haven’t got a
> hardware problem. 10.3 had been falling apart on me, so maybe it’s more
> of a hardware thing.

You might want to try running memtest86+ on the system overnight (or even
for a few days) and see if it finds anything. Should be on your openSUSE
media as an option when you boot from the media.


Jim Henderson
openSUSE Forums Moderator

I didn’t find memtest86+ on the disk. A search of openSUSeFactory gave me a couple of manual links that are no longer valid (404 errors) and a one-click install that just brings up a text file.

Found the utility & ran both hard drive & memory tests. The machine passed just fine.

Installed Ubuntu 9.04 (with ext3) on the machine & so far it’s working okay.

Installed Ubuntu 9.10 (with ext4) on an equally old machine & had it lock up minutes after it came up, right after loading Firefox.

Are there any known issues with ext4 on older disks? any settings that need to be changed?

boot with nolapic, see if this fixes it for you


on shut down - I left it for 2+ hours today - it hangs unloading the NIC. Did a hard reset, loaded SAX and had the screen flash a couple of times before the whole thing died again.

On Fri, 27 Nov 2009 19:16:02 +0000, n hand wrote:

> Found the utility & ran both hard drive & memory tests. The machine
> passed just fine.

How long did you let it run its tests for?


Jim Henderson
openSUSE Forums Moderator

It was 3-4 hours. It finished 4 passes and was 70% through the fifth one when I shut it down.

So far - I installed with default settings - it fails
I installed with ext3 instead of ext4 - it failed
I tried Ubuntu 9.04, with ext3, which seemed to work
& done an upgrade from Ubuntu 9.04 to 9.10 (keeping ext3)- which also failed.

the machine is a 2.53Ghz processor with an 80G HDD and 500MB of RAM, maybe I’m just asking too much of it.

I’ve been seeing something similar with a clean install of 11.2. What I’ve done to work around the issue is immediately after booting, I check to see if a particular process is running (I think it’s startup_preload, but I’m not at my 11.2 computer to check). If I recall correctly, it’s supposed to exit memory after the system boots, but about 75% of the time, it doesn’t. Instead, it sits there eating all of my memory. If I kill it, the system remains stable for the rest of the session.

Dunno if it’s the same thing you’re seeing, but I do know if I don’t kill that process, my system becomes completely unusable.

I found a “prepare_preload” on a VM I just installed. It was using 95% of the CPU after bootup, which would kill almost anything. I’ll reboot my desktop & try again.


That’s what it’s called. I knew it had the word “preload” in it, but I wasn’t sure about the first word.

Anyone else seeing similar behavior?

I re-installed the system

as soon as the system logged me in, I checked the monitor for anything hogging the CPU or memory. Nothing. A minute or so later, the updater found some updates that needed to be applied to the system. Prepare_preload kicked in. It ran for a couple of minutes, as needed by the updater, occasionally spiking to 90%, then shut itself off.

I re-booted the system… it’s currently sitting, waiting to “shutdown (localfs) network interfaces: eth0 name: BCM4401 100Base-T”. translation - it’s hosed (again)

Any word on this yet? I’ve seen in a couple places that there were some bugfixes for an inaccurate “PIDs got reused” error, but to this day, with all 11.2 patches applied, prepare_preload eats my RAM and CPU a few minutes after boot and doesn’t quit. I have to kill it manually every time.

On top of that, I’ve noticed that udev generates an incredible number of forks. Dunno if it’s related.

If you’re sure it’s this, uninstall ‘preload’ and ‘preload-kmp-YOURKERNELFLAVOR’. This will stop preload from being called.

That did the trick, but why? I like the concept of what preload does, and wish it worked properly on my computer.