System freezes after tumbleweed update

Hi,
I updated tumbleweed (sudo zypper dup) yesterday and everything worked fine. Today I shut my laptop lid, but when I opened again the screen was black (or maybe kind of greyish like login screen background, I don’t remember) and nothing happened. So I shut it down by pressing the power button. When I started I could log into tumbleweed, but as soon as I pressed anything it would freeze. I can change to different shells(?) by pressing ctrl+alt+F1 etc to reboot but besides that tumbleweed keeps freezing. That happens with both kernel options I can choose in grub, 4.14.9 as well as 4.14.6.
Does anyone know why that happens and how to fix it?
I’m using a Dell XPS 13 from last year with a Debian install next to tumbleweed.

Jonathan

Hit ‘e’ at boot and add the ‘nopti’ option at the bootcommand line, after ‘showopts’ and check if this stops the freezes.
If that doesn’t work && btrfs is used, you can boot in a previous snapshot throught the Advanced Options

Unfortunately that doesn’t change the freezing. I’m not using btrfs.

Hello
I’m having the same issue on my box and I think it should Plasma configuration related or auto-loaded application like Steam because it only happening on my main user account on plasma that was logged at the update time.
It doesn’t happen on Icewm or when logged other user on Plasma, also my laptop runs Tumbleweed 99.5% same software, didn’t have steam running at the update time, but it run fine until I start Steam then crashes and reboot!
It used to be possible to start a new plasma failsafe session or a new session ditching all last session opened programs but it seems it’s not possible anymore!

In my case it’s confirmed to be a Steam related issue whether Steam itself or Kernel, X, Wayland or something else.
Removing Steam executable allowed me to login on my main account.

It’s likely caused by the recent security fixes then.
In particular they are meanwhile known to break steam and other 32bit applications on some (AMD?) systems.

Try adding the “nopti” kernel boot option and see if it helps.

See also:

Yes, there are indeed cpu’s & gpus from amd around here! Many thanks!

I thought I read that they changed nopti to pti=off, but I’m not the final word on that.

Both “nopti” and “pti=off” should work.

From the update description:

This feature can be enabled / disabled by the “pti=[on|off|auto]”
or “nopti” commandline options.

Tried to update as you suggested the RPM database rebuild seem to go fine. When the updates were installing I bus - gtk 32-bit crash the system while updating, I happened to catch it while I was walking by. On reboot I received a message similar to Kernel Panic and I can no longer boot my system. Any suggestions on how to proceed?