System freeze with radeon driver + DRI / FireGL V3100 card

Hi all,

After a bit of work I got 3d acceleration (direct rendering) working on my system. Now, whenever I use intensive graphics, (certain screen savers, Google Earth overlay animations) all performs fine for a while (1-2 minutes) and then causes a full system freeze. Only solution at that point is a hard power reboot. I don’t know where to look for a solution, since I can not check any diagnostic files when the system is frozen. Any suggestions?

System:
Intel Pentium 4 CPU 3.00GHz
ATI FireGL V3100 graphics Card
OpenSuse 11.4 with radeon driver.

Thanks in advance.

maybe a heat or a power issue. can you test on windows, if installed? by far the easiest way.

Thanks. Windows has been installed but does not show this problem. I wonder if it can be a driver issue (memory leak?).

On 07/01/2011 06:06 PM, brian j wrote:
>
> maybe a heat or a power issue. can you test on windows, if installed?
> by far the easiest way.

testing for heat problems by running Windows will only serve to prove
that the Windows hardware drivers are very often able to run cooler and
use less battery power than the linux drivers…

@dutchy69, when you say “freeze” i wonder exactly what that means?

-did the scroll and caps lock lights flash?

-could you move your mouse, but not click on anything?

-if waited a full 15 minutes without clicking or moving anything, did
the system recover itself? (it will, sometimes)

-what happens if you press Ctrl+Alt+F1? do you see a full screen
terminal “login:” prompt? if so you do not need to do a “hard power
reboot”, those should be avoided if at all possible…instead you can
type in root, then root password and use this magic


shutdown -r now

which should cause a normal, smooth, full shutdown and reboot

-or, what happens if you press Ctrl+Alt+Backspace twice? (hold down Ctrl
and Alt and then press backspace twice, quickly) if your keyboard is not
locked out of the system it should cause a relative smooth shutdown of
Gnome and X, and present you with a GUI login screen where you can log
right back into Gnome…

even after the system is rebooted (if that is what is required) it is
still possible to look at the logs and see if there are any hints as to
what is going on…you can look at the ‘main’ log by using this:

-hold down Alt and press F2
-in the pop up type


gnomesu gedit /var/log/messages

the system will popup a dialog asking for the root password, give it and
soon gnome will open the “messages” log in a ROOT POWERED editor
by doing that you 'become root…so be careful do not make any
changes to the log and do NOT save it when you exit it…and do not
leave the editor open, if you do eventually you will forget it is root
and you take the chance of messing up something…

with ‘messages’ open you will see the first of each line begins with a
date/time stamp…just zing down to around the time of the “freeze” and
see what you can find…

you might not find anything…but, with nothing else to go on i’d wanna
investigate:
-how much RAM do you have
-how much swap do you have
-how much empty space do you have in your root and home partitions?


DD
-Caveat-Hardware-Software-

On 07/05/2011 11:11 AM, DenverD wrote:
> On 07/01/2011 06:06 PM, brian j wrote:
>>
>> maybe a heat or a power issue. can you test on windows, if installed?
>> by far the easiest way.
>
> testing for heat problems by running Windows will only serve to prove
> that the Windows hardware drivers are very often able to run cooler and
> use less battery power than the linux drivers…

sorry brian_j, i was not as ‘gentle’ as i could or should have been…i
sure didn’t intend to be disrespectful to you…


DD
-Caveat-Hardware-Software-

Thank you DenverD (and sorry for the late reply; the machine runs operational tasks at my office, so I cannot often do tests or reboot the system.).
With ‘Freeze’ I mean that there is no response at all from the system. The image on the screen remains static. Keyboard light do not flash, mouse cursor doesn’t move. No reaction either to ctrl+alt+F1 or ctrl+alt+backspace. And I tried waiting for more that 20 minutes, but the system does not automatically revive itself.

I also checked /var/log/messages, but did not see any interesting error message there.
Next thing I want to try is to see if anything shows up in my .xsession-errors file in my home directory. More about that later.

As for the system:
It has 1GB RAM, 1GB swap, and more than 10GB available in both my root an home partitions.

Exactly the same here with my DELL Latitude D810 with ATI radeon X600.
The system freezes reproducibly after like 1 to 5 minutes when a gfx intensive application like MPlayer, Kaffeine or xbmc is running, or with an openGL screensaver.

My system:

  • openSUSE 11.4 (i586)
  • Device: pci 0x3150 “Radeon Mobility X600 (M24) 3150 (PCIE)”
  • KDE 4.6.0
  • Module radeon: vendor=“X.Org Foundation”, compiled for 1.9.3, module version = 6.14.0

Same problem when I logon directly into a XBMC session (without KDE)…

  • hardy

Those of you experiencing the desktop freezes, does this happen with special desktop effects disabled ? If you switch to the vesa driver (read much poorer performance) do you still get the freeze?

@oldcpu

It also happened with disabled desktop effects, which I did control with: Personal Settings>Desktop Effects, un-check “Enable desktop effects”.
I will change to and test the VESA driver now and report the result soon.

Oops… When I searched the forum for “enforce VESA” and alike I found out that this is not necessarily a trivial thing.
Or has this changed with openSUSE 11.4/DKE 4.6 so I could switch to VESA and back to RADEON easily?

Its easy to force the vesa driver, assuming you have no /etc/X11/xorg.conf file. Simply edit the /etc/X11/xorg.conf.d/50-device.conf file to read:


Section "Device"
  Identifier "Default Device"

  #Driver "radeon"

  Driver "vesa"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

EndSection

That did the trick! Thanks a lot, oldcpu!

Actually, after adding the line:
Driver “vesa”
my 50-device.conf looked exactly as shown by you and after rebooting the VESA driver was active.

The openGL screensaver (I used “Stairs GL” this time) now never caused the system to freeze, nor did it happen when I played some *.mov files with mplayer.

Now I returned to the radeon driver and the system froze after like 5 minutes with the “Stairs GL” screensaver.
Note: This is not a"Stairs GL" problem, it happend with several other openGL screensavers before and since months.

If I understand correctly, the VESA driver will not support direct rendering nor hardware acceleration.
This may be the root of the problem here.

Yes, indeed direct rendering/hardware acceleration seems to be behind it. The trouble started when I first used this with the radeon driver. I can avoid the freezes by turning hardware acceleration off; but that means that some applications become really hard to work with (read: too slow), like e.g. google earth.
So, no solution here yet.

Well, I finally sort of kind resolved the issue by replacing the graphics card (now a ATI FireGL 3600; was a FireGL 3100). The radeon driver seems to like the new card better. No more freezes.
Thanks everybody for your suggestions and comments.

Just confirming the problem.
Happening with an old Radeon 9250 also.
When using KDE, freezing for minutes happens regularly when scrolling, moving windows etc.
Luckily somehow these problems don’t appear using fvwm.