System freeze and possible diagnosis

I have the same problem. In addition when I change the brightness from the keyboard (Fn + F4 or Fn + F5), it freezes.

I didn’t try that. However, based on what I have tried, it seems that anything that changes brightness has a good chance of causing a freeze.

This freeze problem seems to be fixed in 12.1 M3. I have tried all of the methods that were pretty sure to freeze the system, and it did not freeze.

Unplug power (which changes brightness); plug back in. This had a 50% chance of freezing the system with 11.4, but everything went well with 12.1 M3.

Change the screen brightness in gnome 3. That was a sure kill (freeze) in 11.4. With 12.1 M3, it works very smoothly.

Note that this is with the default kernel, 32 bit. I am still getting hangs attempting to load the desktop kernel. When M4 comes out, I will give 64 bit a try.

I did see a different problem - Xorg froze on me once. I also saw that in 12.1 M2. But it wasn’t a system freeze. I was able to ssh in from another system, and kill -KILL the Xorg process, to get the desktop running again.


I have same problem in the final version 12.1 on both x86 and x64 versions of this problem has happened in version 11.4 x64.

By changing the brightness of the LCD freezes the notebook.

> By changing the brightness of the LCD freezes the notebook.

does it help if you add these two parameters to the boot options:

acpi_display_output=vendor acpi_backlight=vendor

you can test if it will help by booting, and when the first green screen
pops up just start typing acpi . . .

then when finished and CHECKED for accuracy, press enter…

if that solves the problem let us know and someone can tell you how to
make that stick between boots, so you don’t have to type it each time…


I put the parameter on startup but the problem still happens.

Am 18.11.2011 13:46, schrieb alextrevisol:
> I put the parameter on startup but the problem still happens.
What hardware do you have? That would make it easier to answer in a more
specific way.

PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

My hardware is Dell Inspiron N5010 Core I5 4GB Video Intel Graphics.

Changing the brightness with function key two or tree times frezee notebbok.

The same problem hapend with brightness change by the sistem power save.

You can put “nomodeset” on the grub kernel arguments line. But that gives crappy graphics and a 1024x768 screen. The alternative is to avoid changing brightness as much as possible, so that the freezes are infrequent.

I used the first solution with 11.4. I am trying the second with 12.1. I left the power settings at their default, though increasing the timeout to dim display might have helped. Freezes are now infrequent, but still occur. And if I switch to running on battery, there’s a good chance that will cause a freeze. The “nomodeset” that I used with 11.4 was reliable (no freezes).

i too have a core i3 system (1st gen) with the intel HD graphics.

i dont have the issue where brightness causes freezing (i do have other eratic brightness issues), however i seem to have random freezes when certain system events occur.
so far, it’s been resume from suspend, and after reading through this thread and trying nomodeset, it froze on shutdown.
this isn’t a common occurrence, but has happened once between 12.1 release, and twice today.

the resume from suspend freeze call trace (i did have a look in /var/log/, but nothing that matches my picture):

i did have similar issues in 11.x releases on the same hardware. 12.1 did improve things as it included the correct intel drivers (video playback is now smooth, and Xorg process doesnt go insane with screen activity).

I have found out how to completely avoid a freeze.

If I login to icewm, then it does not freeze. I’ll note that I did install the full icewm, rather than the “lite” version that comes with a default install. So I have configured icewm to automatically start an xterm, nm-applet (for wifi), and synaptiks (to handle the touchpad). I can launch other applications at the xterm command line.

I think it never freezes, because icewm isn’t doing much of power management or changing the display brightness. It does blank the display after an idle period, but never reduces brightness. I have not been able to achieve that with other desktops. In KDE, I have set the power manager to dim the display after 3 hours. However, the display dims or the system freezes after 1 hour, and if it dims then it never undims and will soon freeze unless I reboot.

If I am using the system actively, I will still login to KDE. But if I am just leaving it sit idle for an extended period, then I can avoid freeze by either login to icewm, reboot to windows, or power down.

On 02/07/2012 04:26 AM, nrickert wrote:
> But if I
> am just leaving it sit idle for an extended period, then I can avoid
> freeze by either login to icewm, reboot to windows, or power down.

power down is the most earth and pocketbook friendly way anyway!

how much are you willing to spend/use/waste to save (what?) a two minute
(or less, maybe much less) boot time?

hint: when you power up don’t sit watching the machine and in a hurry
lean back and relax…
close your eyes…
take a deep breath…
exhale slowly and completely…
repeat twice…
breathe normally…
enjoy a few minutes of calm…

when completely relaxed, check and i guess your machine is waiting on
you, rather than the other way around.

Zen and the Art of Linux Management.

After almost a year you’re still having freezes? I just bought a laptop last month and dealing with freezing issues myself. I’d go crazy if I’m still having problems a year from now!

While searching for solutions for my problem, I found a bug report that you might be interested in.

They claim that using 32-bit OS stopped the freezes. I had to reinstall recently so I decided to give 32-bit a try. I get completely random freezes so my issue is not the same as yours but I hope this 32-bit thing works. Fingers crossed.

From the same link above, here’s some acpi related boot options you can try:

That does not help, in my case.

Booting with “nomodeset” does completely solve the problem. But then the video looks crappy. It is a lot better now than it was with opensuse 11.4. I will be an early tester of 12.2 (milestone 1 is just a few days away), hoping that fixes the problem.

This could pertain to your problem:

[Phoronix] NVIDIA Releases New Driver For X.Org Server 1.12](

Since I have intel graphics, no I don’t think that new Nvidia driver will help.

Have you visited the Intel graphics driver page?

Intel Linux Graphics

Follow up Have you tried adding this to Grub?


Then reboot your OS.

An alternate option I would try is to add an updated Xorg repository.

Index of /repositories/X11:/XOrg/openSUSE_12.1

Try updating Mesa and see if this helps.

Thanks for the suggestion.

My inclination is to try the 12.2 milestones, which will probably have a newer Xorg.