System freeze and possible diagnosis

This is a Dell laptop (Inspiron N5010) with Intel graphics card.

It had been working fine. But this morning, after I let it sit unattended for a while, it froze up solid. I had to power off to regain control. Then, about 1 hour later, it did the same thing.

I rebooted to Windows, wondering if Windows would also freeze. The Windows boot manager screen listed a memory test, so I ran that. It did not find any errors.

Then something occurred to me. I had made a KDE configuration change this morning. In the “Display and Monitor” setting module, I had turned on the screen saver. I undid that change, and the system has been running fine since.

I am guessing that there is a conflict between that screen saver setting, and the power management settings (which also turn off the screen).

I am posting this, in case anyone else runs into mysterious freezes of an idle laptop.

I had some more freezes today. The symptoms were different from last time. And I had gone several days without freezes, after the changes mentioned above.

On one of the freezes today, I moved the mouse. The screen brightened (from dim to normal brightness). And it froze at that instant.

A check of logs (after rebooting) shows system activity until just before the moment of the observed freeze.

Once again, I cannot be certain that I have identified the culprit, but it sure looks that way. Going from screen off to on does not appear to cause problems. But going from dimmed to normal brightness does seem to be a problem.

For the present, I have turned of the power setting option to dim the screen after 10 minutes. However, I left the option there to turn off the screen. We shall see what happens.

I guess it’s time to head over to bugzilla, look for freeze reports, and see if I can contribute to any of those.

My personal opinion: this is likely to be either a kernel bug or a video driver bug. Ordinary non-root user activity is not supposed to be able to cause a system freeze.

Good to know, thanks.

Is that with an Intel GMA 4500MHD, and/or what chipset?

I’m not sure how to tell the chipset. The Dell supplied documentation just says “Intel HD graphics”.
The Yast hardware info says “Intel Ironlake Mobil Graphics Controller” (under the framebuffer device heading).
The sysinfo in KDE says: “Arrandale Integrated Graphics Controller”.

I am currently running from the live CD 32 bit, to see if it freezes that way. Normally, I run from 64 bit installed.

It’s definitely not a GMA 4500MHD, and your personal opinion (post #2) is a good place to start. However, that is very useful information re Arrandale/Ironlake. If you search forum on e.g. Arrandale Ironlake GMA, you will understand the recent history concerning the “intel” driver (i915 kernel module/driver) and lack of working support with the standard 11.3 kernel 2.6.34 and upgrades through to 2.6.37.

Pay particular attention to posts by @SeanMc98 (particularly the more recent stuff), among others. There are variations (YMMV) with different PC make/model, and the Intel processors (?cores) and chipset will probably make a difference. Before doing that, I recommend you run from terminal as root (su -), the command: lspci -nnk to get your chipset and graphics details in the first few lines of those chipsets. Suggest you post those back here, in case you need further assistance, and SeanMc98 may see this thread. He made a lot of progress with this hardware and kernel updates up to 2.6.38, and if IIRC there were regressions along the way with various kernel release levels.

I also recommend you take a look through your /var/log/Xorg.0.log. It’s mentioned in many of the old posts, and you would need to attach it to any bug report. You will be able to see version details of the “intel” driver and chipsets supported (including Arrandale/Ironlake).

Thanks. Those sound like good suggestions. It isn’t my primary computer, so it might not be till tomorrow that I can get the output of “lspci -nnk”.

I do have spare disk space on that system, so I should perhaps experiment with Tumbleweed (on a different partition), to see whether new kernels help with the problem.

Unless I missed something, this seems to be all it says about the video card:

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integ
rated Graphics Controller [8086:0046] (rev 18)
        Subsystem: Dell Device [1028:0447]
        Kernel driver in use: i915

That is enough to confirm it. This pci id [8086:0046] identifies it as an Arrandale chipset with integrated Ironlake (the GPU).

Is the laptop’s processor an Intel Core i3 or i5?

Processor is Core i3.

Seen your post in that other thread with same graphics chipset as yours. Have suggested there (and explained) for both of you to try booting and running with nomodeset boot option to see if it runs without freezes (if it works), and report back. If/when you report bug, you will probably be asked to try it anyway.

Another day, another freeze.

What happened, this time, is that I pulled the power plug so that I could briefly use the system on battery in another room. It appears to have frozen at the instant that I pulled the plug.

This again points to screen brightness switching as being involved in the bug.

Laptop is currently running with “nomodeset” (from the boot page - I have not change menu.lst as yet). Seeing that MHGlenn had his system freeze with “nomodeset”, I don’t have a lot of hope for this helping.

Thanks consused. The nomodeset kernel boot option appears to clear up my problem.

Glad it helped mattm3a, and thanks for the feedback. I hope these problems get fixed, so you can enjoy a better performing graphics driver.

With “nomodeset”, it has survived at least one “pulling the plug” (switching to battery), and at least one screen dimming and recovering.

I’ll probably add that kernel option to the grub boot menu.

Ok. I imagine you are now on the “fbdev” driver and I suspect it may run with higher cpu utilization and no hardware acceleration. You can look through /var/log/Xorg.0.log to check for “fbdev” and see what it manages to do.

I took a quick look last night at the bug reports on Novell’s bugzilla. I didn’t see an appropriate report against 11.4 and the intel driver for these freezes. It could be useful if you raised one for your particular laptop, but you should check there for yourself. If a suitable report existed you could just add your own message to that.

I didn’t like the poor video with “nomodeset”, so I’m back to trying to avoid doing things that trigger the bug.

Yes, Xorg.0.log.old shows it using fbdev.

The screen, with “nomodeset” looked as if it was 1024 pixels wide, instead of 1366. That mismatch is probably why it doesn’t look good.

I’ll probably file a bug report later today or tomorrow.

@nrickert, thanks for the feedback. Yes, 1024x768 is probably the best it can manage (here LCD = lowest common denominator :D). Lets hope the bug report gets some attention and explanation from the devs.

Oops. I forgot to post the bugzilla id here. The link to the bug report is:
and the bug ID is 682528.

Took a quick look at it, and think it would help to attach a copy of /var/log/Xorg.0.log to the report with the “intel” driver loaded. (maybe to do that you have to add a message referencing the attachnent?).