System Freeze after install

I’m trying to perform a network install of OpenSUSE 11.2 on a Shuttle SN25P.
The machine has 2 hard disks installed with Windows 7 on one. I am trying to install OpenSUSE on the other.

The installation runs through as normal but the system freezes on the reboot, just after the message “Setting up service (localfs) network”

The screen goes blank apart from a solid cursor in the top left corner and the keyboard is totally non responsive

I have tried a few reinstalls but they all do the same

The Windows partition still boots OK from the Grub menu

I can’t find any similar symptoms via a web search.

Did you try a failsafe boot?

I tried a failsafe - it does exactly the same.

I tried a clean install of 11.1 and it worked fine.

I then upgraded it to 11.2 following the supported process on the openSUSE web pages. That worked OK as well, but Online Update wouldn’t work - it said that no update repositories were configured and I can’t find how to fix that, so I tried a clean install of 11.2 and now back to the old problem of crashing during boot, just after message Starting Service (localfs) Network
It does the same on a failsafe boot and the same if I try booting to run level 3

I guess I’ll wait for 11.3 and see if that works

Not long to wait for 11.3