System Freeze after 5-10 minutes. It's the new kernel!!

openSUSE 11.2
Toshiba laptop A100-110

When i log in and start using the system it freezes after about 5 - 10 minutes and i have to do a hard restart…

I have the same problem with all new distros running kernel 2.6.31… :frowning: The trick i used on the new ubuntu was that i installed Ubuntu 9.04 (kernel 2.6.28) and then upgraded to ubuntu 9.10 and it left me a choice to choose between kernels 2.6.31 and 2.6.28 and the older kernel worked perfectly fine but the new had that freeze… :frowning:

Yes, i’ve tried Fedora 12, Mandriva 2010, Ubuntu 9.10 and they all have the same problem when running the newest kernel, i asked on other forums and they also said that it’s the new kernel’s fault…

Now, could you please tell me how i can downgrade to kernel 2.6.28 with umm… maybe a quick konsole command? :slight_smile:


kernel 2.6.28 is no longer available for SUSE, unless you want to compile mainstream 2.6.28. You can however use an older distro kernel on 11.2, like the one from 11.1 which is from the 2.6.27.x series. Will this do it for you?

you can grab it from here Index of /repositories/Kernel:/SL111_BRANCH/openSUSE_11.1

Before installing, make sure to enable parallel installs in /etc/zypp/zypp.conf in the multiversion variable (where you set package names you want to have multiple versions of)

Yes, that will do but i’m afraid i don’t know to install a kernel, i would probably need a step by step tutorial… Would i still have an option to choose an older kernel if i upgraded from 11.1 instead of a fresh install? like in ubuntu…

  1. add the above repo (either with YaST or with zypper directly)
  2. go to /etc/zypp and open as root the zypp.conf file
  3. look for the multiversion variable, comment it out and put the following in it. kernel-default,kernel-smp,kernel-source,kernel-default-base,kernel-default-extra
  4. if you use kernel-desktop, then change above accordingly. Better yet, go to YaST, search for ‘kernel’ and look which packages are installed. Then add their names to the muliversion variable
  5. with zypper, do: zypper in -r <name_of_the_kernel_repo_you_just_added>. For a list of names and aliases, do zypper lr

To answer your other question. Yes… Note that using a kernel built for older distro version may cause small problems as it’s usually compiled with an older GCC version than the one present in the newer distro version. This may cause small issues when compiling drivers. For example, the NV driver, when manually installing, will complain if it detects that your kernel is compiled with a different GCC version compared to the one you have on your system currently. You can ignore this and it’ll work but I recall you’ll have to edit a file somewhere (or was it that you need to force an option during NV install?). My memory is fuzzy on that one. I haven’t used this in ages

EDIT: before installing new kernel, add the option nopat to grub. This will disable the page attribute table (it’s similar to the older mtrr) which some video drivers don’t support and cause lockups

About nopat, when you add it, see if this fixes your lockups. if it does, no need to install older kernel. I also advise to report these lockups on Novell’s bugzilla

I can’t figure out how to use that nopat… What is it? How/where do i add it?

I feel like i should report these lockups to Linus Torvalds and the kernel team… hehe

two ways to do it:

  1. when computer starts and you get the Grub bootscreen where you select your OS/kernel, you can enter it there simply by writing nopat. You will have to repeat this each time though so point 2) below is the better solution

  2. open /boot/grub/menu.lst as root and add nopat… example on my machine:

title openSUSE 11.1 - Neutrino
root (hd0,0)
kernel /boot/vmlinuz- root=/dev/sda1 resume=/dev/sda2 libata.force=80c elevator=as noexec=on noexec32=on splash=silent showopts vga=0x31A nopat
initrd /boot/initrd-

On 11/13/2009 07:26 AM, QueenZ wrote:
> I feel like i should report these lockups to Linus Torvalds and the
> kernel team… hehe

You should, but your level of documentation will have to be greatly improved.
The statement “my system freezes after 5-10 minutes” would not get any attention.

If you consider ALL the variations in systems - CPU, motherboard, BIOS, etc. -
is it surprising that some combinations are not found while testing a new kernel?

nopat didn’t work…

What’s weird is that failsafe mode works without lockups so i’m thinking maybe i could just copy some of it’s parametrs to default…?

Oh and btw, how do you edit /boot/grub/menu.lst? I used to do it with “sudo gedit /boot/grub/menu.lst” in ubuntu and there is no gedit in openSUSE so i installed gedit :smiley: Just wondering…

maybe acpi and/or apic is causing problems? try acpi=off (and maybe nolapic too) in menu.lst

How I edit? In kde4, I just go to /boot/grub, right click on menu.lst, choose open with and then type ‘kdesu kwrite’ :slight_smile:

It works with nolapic :slight_smile:

default 0
timeout 8

title openSUSE 11.2 -

root (hd0,6)

kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-FUJITSU_MHV2060BH_PL_NW9AT662A20T-part7 resume=/dev/disk/by-id/ata-FUJITSU_MHV2060BH_PL_NW9AT662A20T-part6 splash=silent quiet showopts vga=0x317 nolapic

initrd /boot/initrd-

It would be really nice if someone could explain me what is lapic and why it locked up the system without nolapic parameter… I didn’t need it in 11.1 and all other older distros…

Other than that, i am very happy with the new openSUSE 11.2, have been waiting for it for almost a year! :slight_smile: Good work!

Been having some problems with the sound, but that’s another story… :slight_smile:

microchip8 - Thank you so much!!!

APIC is the advanced programmable interrupt controller. It’s a controller which can handle more IRQs but is also more complex than previous PIC controller. However, certain HW bugs, like in the BIOS, can cause problem. Of course, SW bugs in the controller’s code itself can cause that too… often if there’s a SW bug somewhere, it’ll display many times so called spurious interrupts