system failure (dual boot with XP)

I have a Duall Boots system where suse 11.3 (GNOME) is shared with Win XP SP2

…my windows crashed last night …after that I tried to reinstall, but installation failed and it continually asked me restart the system again again without installing the windows, but copying the system files each time.

Then worst happened when I found even options for booting suse at start up is not showing up and instead an error msg is coming …

Plz Help

You can get SUSE back by following this
Re-Install Grub Quickly with Parted Magic

Once you have SUSE back, show us the result of this

fdisk -l

yeah it seems to be bit complicated …

I just want to know that if using GRUB will erase the data that are stored in lunux partition ?

furthermore i think my linux is quite intact …i think …but after i tried to install win XP …initial booting options that are used to show up is not showing

Nope it will just write a bootloader either in the first sector of the hard disk (MBR) or in the first sector of a partition, depending where you choose to install it. There are no data in this area.

furthermore i think my linux is quite intact …i think …but after i tried to install win XP …initial booting options that are used to show up is not showing

That’s perfectly normal. Windows has just activated its partition and overwritten the MBR. You have either to reinstall Grub in MBR or set the bootflag back on the Linux or extended partition which has Grub installed. It sounds more complicated than it is really.

Just follow my guide using Parted Magic
Read it carefully and you’ll be fine, it’ll not erase anything

Look your partition read this Partitioning external drive for Linux

thnx …will keep u updated when am done :slight_smile:


I might not be clever enough to understand the thread you refered to and already presented (in other threads) as the ultimate solution for dualbooting problems … but seriously … there are hundreds of posts - not to mention pictured howtos and videos, describing and/or explaining the method in a less confusing and more intelligible way.

personally when dealing with MS being also installed .I find my life WAY MUCH easier and having way less hassles
If i just let MS have the mbr .
and install grub on the FIRST linux partition and use gparted to place the boot flag there . .

this way the very “dumb” MS install disk can overwrite the mbr and not mess me up when a reinstall/“fix” is needed
also some third party applications have the windows OS put data on the mbr . If grub is there then windows can overwrite some of it and
Windows will not check if non MS code is there it assumes that it is the MS bootloader.

I understand!! Of course there are hundreds of posts which solve dualbooting problems. I do not diminish your intelligence!!!
I’ll take it as advice. But many Greeks which are members of this forum will not get it as advice but as an insult.

I felt the same way ten years ago … when I woke up and decided to stop using, installing, fixing, hacking and supporting Windows. :wink:

It’s not about the formulation (btw, my english is not better than yours). The present thread is about a very common Windows/Linux MBR problem that can be fixed in less than 5 minutes within the Grub shell (by reinstalling Grub in MBR) or with fdisk (by setting the bootflag on the Linux partition) … or by doing both. There is no need to introduce new factors, like scsi and external disks or involving the YaST partitioner where there is nothing to partitionate. Try to figure out the impression that the reading of that thread may produce on the OP:

No offense meant at all to you or to the people who invented democracy (and hopefully will keep up the revolution). :wink:

Please forgive me if I was abrupt. I understand that you are not a Greek, translation in a different language daily gives a clear meaning in language.:slight_smile:

Just be patient with it, and be sure to try and understand the process. If you are not familiar with this sort of work, it can seem confusing but it’s really not that difficult.
Don’t pay too much attention to the ‘Banter’ going on with some of the others posting here.

t’s not about the formulation (btw, my english is not better than yours).

I’ll say it again. We are here to help and not to make demonstration of knowledge. I together with other children from the Forum developed a help thread. Both as you read, were saying the same thing but with different words. Anyway I would not write again this comment comparison. The comparison between people do not like me and general comparison for knowledge.

Always Friendly!!!:wink:

i tried the follwing but it seems system is bit complicated

  1. my system looks like this Picasa Web Albums - pradipta - system problem

  2. partitioning is like this Picasa Web Albums - pradipta - system problem

  3. with fdisk - l it looks loke this Picasa Web Albums - pradipta - system problem

sda4 is the linux partition

but it returns menu.lst in (hd0, 7) Picasa Web Albums - pradipta - system problem

after scucessful run … system is restarted Picasa Web Albums - pradipta - system problem

but fails to boot linux … Picasa Web Albums - pradipta - system problem

Take the boot flag of sda1

You can remove or add as per this


That won’t help. And since the OP installed Grub in MBR (see Picasa Web Albums - pradipta - system problem ), the bootflag is irrelevant - Remember when I told you to remove any bootflag from your laptop?

Rather take a look at this picture: Picasa Web Albums - pradipta - system problem! The Grub menu is totally wrong. It tries to mount part-10 (which is a NTFS one) as the root partition. That’s the problem here: (hd0,9) and part-10 are wrong.

Please learn how to copy/paste in the forum (you’ll save time too). Then, according to this (Picasa Web Albums - pradipta - system problem) and assuming the root partition is mounted, type the following command in a terminal:

cat /media/sda8/boot/grub/menu.lst

And post the output here.

We can tell you exactly what to change in this file to solve the problem.
Again, please copy/paste in the forum, I can not modify text from a picture.

I see yes.
Quite frankly, that partitioning is a complete mess anyway.

:smiley: LOL with the avatar+
Makes you look like the superstar that you are.