System doesn't show login screen after installing Nvidia 684.90

Hello, after following this tutorial (in Portuguese, but says to download drivers from, hit ctrl + alt + f1, type “yast”, go to “System”, “System Services” and disable “xdm”, after , run “sh downloaded”). It installed successfully, but after rebooting my system does not load anymore. When it should show login screen, shows only an black screen with the mouse cursor (I can move it) and nothing more :frowning:

I tried to enable “xdm” again, but it does not show on “System Services” list (from Yast).

What should I do?

PS: Open Suse Leap 42.3

Is it a notebook?

Yes, with Nvidia Geforce 820m and Intel <don’t remember>

Need bumblebee

First remove the NVIDIA driver then follow instruction

Sorry for the delay… I tried to restore the default drivers, but i didn’t succeed =(
How to restore these drivers?

Can you boot to a terminal?

At boot screen press e find line starting linux or linuxefi go to end of that line (itwrapes) enter space 3 continue boot. This will lead to a terminal logon. Log in as root then run yast (text version) use tab and arrow keys to navigate go to software manager search for NVIDIA and remove all packages that have NVIDIA in it’s name.

Thanks, all working now. But how do I set nvidia card as default to all applications?