System doesn't boot after kernel upgrade

Hi everyone!

After the latest kernel upgrade an older laptop running 12.1, 32-bit, with the GNOME DE, ended up booting straight into the GRUB prompt. So I booted up a live cd,
mounted my boot partition, and discovered a very incomplete menu.lst

After some editing, trial and error, at least I was able to get the GRUB menu back, but I don’t seem to get around this error:

    2.052729] Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown block(0,0)
    2,053039] Pid: 1, comm: swapper Not tainted 3.1.9-1.4-default #1
    2.053267] Call Trace:
    2.053382]  <c0205243>] try_stack_unwind+0x163/0x180
    2.053578]  <c02040f7>] dump_trace+0x47/0xf0
    2.053751]  <c02052ab>] show_trace_log_lvl+0x4b/0x60
    2.053946]  <c02052d8>] show_trace+0x18/0x20
    2.054115]  <c066f988>] dump_stack+0x6d/0x72
    2.054285]  <c067178b>] panic+0x57/0x14e
    2.054446]  <c0a04ab1>] mount_block_root+0xab/0x12e
    2.054638]  <c0a04caa>] prepare_namespace+0x11c/0x162
    2.054834]  <c0a04859>] kernel_init+0x134/0x139
    2.055012]  <c068bde6>] kernel_thread_helper+0x6/0xd

I’ll boot up the Live-CD again, and provide the output of ‘fdisk -l’ and the contents of my “menu.lst” file. Sitting on another computer now.

This is the output of “fdisk -l”:

Disk /dev/sda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders, total 78140160 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0006daaa

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048     4208639     2103296   82  Linux swap / Solaris
/dev/sda2   *     4208640     4370431       80896   83  Linux
/dev/sda3         4370432    23246847     9438208   83  Linux
/dev/sda4        23246848    78139391    27446272   83  Linu

sda3 would be the root file system
sda4 is my home partition

And the contents of my “menu.lst”:

# Modified by YaST2. Last modification on fr. nov. 18 17:01:58 CET 2011
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

default 0
timeout 3
##YaST - generic_mbr
gfxmenu (hd0,1)/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 12.1
    root (hd0,1)
    kernel /vmlinuz-3.1.9-1.4-default root=/dev/disk/by-id/ata-TOSHIBA_MK4032GSX_96GH1141S-part3 resume=/dev/disk/by-id/ata-TOSHIBA_MK4032GSX_96GH1141S-part1 splash=silent quiet showopts vga=0x317
    initrd /initrd-3.1.9-1.4-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 12.1
    root (hd0,1)
    kernel /vmlinuz-3.1.9-1.4-default root=/dev/disk/by-id/ata-TOSHIBA_MK4032GSX_96GH1141S-part3 resume=/dev/disk/by-id/ata-TOSHIBA_MK4032GSX_96GH1141S-part1 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x317
    initrd /initrd-3.1.9-1.4-default

have you tried updating grub from the live cd?

Check the file
menu.lst.old

If you didn’t try editing the menu.lst again since this issue, it will contain your old boot code.
Post it here

menu.lst.old seems to hold pretty much the same entries as the file from the previous post. I’ve been messing around in there so… learning the hard way to backup my menu.lst file obviously.

I’ll just hoy some files from /home to an external disk and do another install, but for the sake of the thread I’ll keep the laptop as is for a day or two. Pretty much at loss to what happened here.

On 2012-02-15 18:16, back space wrote:
> mounted my boot partition, and discovered a very incomplete menu.lst

Perhaps Bug 745024. If it is, please post a comment on that bug.

For the next time, enable multiversion.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Had a look at Bug 745024 and it seems to fit, so I’ll add a comment in there. As for enabling multiversion, yeah, I think I might do that :slight_smile:

At least I didn’t lose any data…

Did you add a me too to the bugzilla? the more people that report it the larger the attention it will attract.

On 2012-02-15 23:06, back space wrote:
>
> Had a look at ‘Bug 745024’
> (https://bugzilla.novell.com/show_bug.cgi?id=745024) and it seems to
> fit, so I’ll add a comment in there.

Yes, thanks, but the kernel panic dump is a different problem that belongs
on a different bugzilla.

> As for enabling multiversion, yeah,
> I think I might do that :slight_smile:

It has saved many “backsides” :wink:

> At least I didn’t lose any data…

That’s a good thing.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)