>System doesn't boot after installing Leap 15.3 without UEFI

Hi,
Leap 15.1 just crashed on me on my 6-year old desktop. I couldn’t boot it anymore and decided to install Leap 15.3. As I wanted to reuse my existing partitions, I selected the expert mode and selected sdb1 for swap, sdb2 for / and sdb3 for /home. I then got a warning that there is not enough space for the boot manager before the first partition and that there is no boot partition for the boot manager (I don’t remember the exact wording). I then selected sda1 as /boot and got a warning that I need a BIOS boot partition. When I changed the type of sda1 to “BIOS Boot”, I got the same warning again. I ignored it. /, /home, and /boot are formatted with ext4. When yast displayed a summary, it told me that the boot information will be written to sda and that it will not write to sda1/boot. I changed it such that it writes to sda1/boot. After installation, I changed the boot order in the BIOS from “1. CD 2. sdb” to “1.CD 2. sda”.
When I boot now, it writes “GRUB GRUB GRUB…” over the entire monitor. Nothing else happens.

Any hints?

Thanks, Stephan

Sounds like you have secure boot enabled in the BIOS - if it is on OpenSUSE installs as secure.

The BIOS is set to “Legacy+UEFI”. All my previous openSUSE installations on that computer didn’t use secure boot.
I recently installed Leap 15.3 on a newer computer and there yast told me that I need an EFI boot partition.
I’m pretty sure yast didn’t ask me about secure boot this time. Can this be the problem anyway?

I forgot to state that I have 4 hard drives in the computer and that the old installation was on sdc and booted from sdc. I didn’t mount sdc, so even if there is a problem with sdc, it shouldn’t affect booting from sda.

As long as 15.3 sees UEFI - you get secure boot style install.
UEFI is code to allow to OpenSUSE 15.3 to install UEFI - you do not have to have secure boot enabled but you do need a FAT32 EFI partition of 128MB or more (I use 512 mb) to boot from or it just hangs. 15.3 will not allow BIOS in the install unless only BIOS in the BIOS.

They seem to follow Microsoft 10/11 in doing the default setups.

Thanks.
This is embarassing. I made 2 mistakes. First, I thought that my computer doesn’t support UEFI because it is so old. Secondly, I didn’t look at the partition setup yast proposed: it proposes a partition with 10 subvolumes, two of them are for boot.
The error messages I got are not helpful. I had set up two partitions on sdb, one for / and one for /home. When I wanted to proceed, I got the following warning:

Not enough space before the first partition to install the bootloader. Leave at least 256kiB.

Such a setup is not supported and may cause problems with the
bootloader now or in the future.

When I created a partition for / on my first hard drive (instead of the second), I didn’t get this error message, I got the warning about the missing BIOS Boot partition below.

I then added a boot partition: Type “BIOS Boot Partition”, mounted to /boot. I then got

A partition of type BIOS Boot Partition is needed to install the bootloader.

Such a setup is not supported and may cause problems with the
bootloader now or in the future.

This threw me off completely, ass I couldn’t figure out what was wrong with the boot partition I had just created.

I’m now trying this again, with Fat32 for the boot partition.

Hi
The BIOS boot partition is not /boot, it’s 8MB and used for a gpt type disk and Legacy boot…

This is my test setup…


lsblk


NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 119.2G  0 disk 
├─sda1   8:1    0     8M  0 part 
├─sda2   8:2    0    50G  0 part /
├─sda3   8:3    0    68G  0 part /data
└─sda4   8:4    0   1.2G  0 part [SWAP]


parted -l


Model: ATA OCZ-VERTEX4 (scsi)
Disk /dev/sda: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: pmbr_boot


Number  Start   End     Size    File system     Name  Flags
 1      1049kB  9437kB  8389kB                        bios_grub
 2      9437kB  53.7GB  53.7GB  btrfs                 legacy_boot
 3      53.7GB  127GB   73.0GB  xfs
 4      127GB   128GB   1325MB  linux-swap(v1)        swap

Hi,
well, it didn’t work. The strange thing is that I had to switch on secure boot after I did the partition setup, I didn’t see an option to do it before the partition setup. I’m trying again now without mounting the FAT partition. Can this partition be too big? I have a 10 GiB partition available and don’t want to change it.
I changed the BIOS setting from “legacy+UEFI” to “UEFI”, hoping that yast will behave differently.

Thanks, Stephan

EFI boot partitions are formatted FAT and so may possible have problems with large partitions. Not sure the max???

If you boot the installer in legacy mode the install will be legacy MBR booting not UEFI, which may be better for you since you will not need to fool around with secure boot.

my 15.3 - I use ext4 rather than btrfs


LLR1:~ # parted -l

Model: NVMe Device (nvme)
Disk /dev/nvme0n1: 1024GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  538MB   537MB   fat16                 boot, esp
 2      538MB   990GB   989GB   ext4
 3      990GB   1024GB  34.4GB  linux-swap(v1)


This is for EFI boot without simple dual boot with Windows. And IMHO swap partition is too big.
OP needs to decide what boot way to use: legacy BIOS or EFI.
It depends on a hardware and need for dual boot with Windows.

Hi,
thank you all for your help. After I changed the boot mode in the BIOS from 'LEGACY+UEFI", it worked. No more warnings from yast during installation and, more importantly, it booted without any problems after the installation.

Thanks again, Stephan

PS: It works better than before: on shutdown, it eventually unpowers the computer. I had to do that manually with my previous installation.