system does now automatic login on root

Hi,

I had a normally running system when I added another user and gave him a password. When I logged on as the new user, the system did an automatic login and started without asking the password. Now, when I login as root it also behaves the same way - automatic login. :frowning: Any ideas what could be wrong?

I am using openSUSE Linux 13.2

Many thanks
golpe

You should never log into a GUI as root. There is never a need to do it.

Go to yast etc sysconfig editor find Desktop-display manager DISPLAYMANAGER_PASSWORDLESS_LOGIN

put a no in the value

in DISPLAYMANAGER_AUTOLOGIN is set to blank ie no entry

Or go to YaST->Security and Users->User and Group Management, Click on “Expert Options” and select “Options for login”.
You can configure exactly the same things there without having to worry about how the variables are named or what’s the option syntax… :wink:

On 2014-12-16 18:56, gogalthorp wrote:
>
> You should never log into a GUI as root. There is never a need to do it.

Yes, but his problem now is that if anybody tries to login as root on
his system, he gets automatically in, as root, without even knowing root
password.

It is two things: login as root, and doing so without typing the password.

That it is even possible is a bug, IMO.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Could be a bug but then he may have somehow set root password to blank. Or autologin is set to root