System does not boot fron HD after upgrading to 42.2

Here it is the situation. An ASUS X551CA laptop updated from DVD (no new install, I used the update option from the DVD) from 13.2 to 42.2 now cannot see the HD under the boot options.

Since the system upgrade there is an error on the boot process indicating that no driver can be found. Entering the “bios”, on the boot options only the DVD is present. Under the SATA setup the HD is listed (on AHCI mode), but the boot loader does not see it.

If I start the install DVD and select More → Start Linux system, the HD is recognized and I can select the partition to start the system, which works without a problem. But I need to use the DVD workaround, otherwise the system does not boot.

On YaST2 the boot configuration looks like this (Spanish screenshot)

I tried (no luck)

reinstalling grub2
changing the bootloader to none, saving, reentering and setting grub2 again (the old “open and close the doors to see if the car starts again”)
added checkmark on “start from the MBR”
look on the “bios” for something like CMS, “legacy mode” or something like that (none can be found)

The background for this machine: I got it without OS a couple of years ago and installed 13.1 without a problem(1). Then, upgraded changing repositories to 13.2, also without a problem. Now upgraded to 42.2 from DVD and got this weird problem.

Any idea? Thanks in advance!


More info:

The error when trying to boot is

error: no such device: /efi/boot/fallback.efi

Looking on the partition table /dev/sda1 is set as an EFI boot partition formatted in FAT

Hi, just a guess, maybe you need the “GRUB2 for EFI” bootloader?
The ASUS X551CA also came with Win 8 and its BIOS should be recent enough to provide (U)EFI booting as default, even if I cannot tell for sure from the ASUS specs.
You should find a “Launch CSM” <enabled or disabled> option under the “Boot” tab in the BIOS setup if you want to use MBR booting.
Maybe booting the DVD in the “MBR” or Legacy mode while your HD was GPT partitioned and needed EFI booting messed things up.

Since you can boot the system using the DVD, check if your HDD is indeed GPT partitioned, as it looks like, with your favourite tool; then adjust your bootloader settings accordingly.

This looks like the system booted in (U)EFI mode prior to the update.
The update hasn’t changed the partitioning of the hard disk.

FAT is the default for the EFI boot partition.

You can check which kind of partition table / disk label you have, when you open a terminal and enter

sudo parted -l

Would be good to see the output of that here.

It will probably be GPT.

If you change the kind of the partition table, i.e. if you create a new partition table, ALL data on that disk will be lost !!

You should be able to check within the BIOS settings / boot menu of the BIOS if your hard disk is booted in (U)EFI mode, which would be in agreement to a GPT partition table / disk label.

But then you need “GRUB2 for EFI” instead of just “GRUB2”.
That you can change using YaST -> Boot Loader after booting your 42.2 from the hard disk - you wrote that you’re still able to boot that by means of the DVD.

Good luck

Thanks for your answers! In fact, it seem it was an EFI problem: on the Spanish forums an user suggested to try changing the boot loader to grub-efi, and it worked! Grub starts on text mode, though, and plymouth shows quite bad, but now the system boots by itself and from the login screen everything is as smooth as always! I’ll be testing everything on the following days (updates, install new packages, etc.), but the problem seems solved!