System died upon installing drivers - newbie posting

I’m sick of proprietary based operating systems so I’ve decided to try Linux, and after some research decided that I thought OpenSUSE, LEAP 42.1 is best for me. I’ve been following numerous guides as I’ve installed my system. I apologise for not providing more relevant system information, I’m using a Toshiba Satellite, L750. It uses some Nvidia Graphics card.

My OpenSUSE system was working fine except for one issue; the brightness wouldn’t lower. I tried using the GUI, and also modifying some values I found in a text file relating to such, but nothing worked. After doing some research, I learned that a number of people have experienced the same bug as I. I learned that I hadn’t installed the proprietary drivers, alongside numerous other updates: I mistakenly thought that installing the repositories installed the updates alongside them. Following an online guide, I used YAST, went something like Software-Extras-Install All Matching Recommended Packages. This selected quite a number of packages to install, including something Nvidia related.

Afterwards I updated my system, and when logging in I noted that the OpenSUSE login screen; with the little logo and three round dots that are filled with green to indicate it’s doing something, had a distorted resolution. Soon after such happens, I receive a white screen that says something along the lines of “Something has gone gone! Problems has occurred by the system and can’t recover; please log out and try again”. No matter how many times I log out or restart my system, I receive the same error.

I’m posting here because I’m rather overwhelmed with all of this and truly do not know what to do. I usually like to do some more research with this sort of thing, but feel I’m rather over my head and have no idea how to proceed. I note that the GRUB part of the start-up still works fine. I believe I’m likely going to need to provide more information about my computer, but not sure how to do this without being able to login into OpenSUSE (I’m running a Windows 10 Dual Boot that works fine). Any help is greatly appreciated.

I suspect you have an optimus (hybrid) based graphic system. Intel + NVIDA GPU. this requires special set up. First remove any and all packages that have NVIDIA in the name. DO NOT remove any that do not have NVIDIA in the package name. The normal NVIDA drivers do not work on optimus systesm

then follow instructions here

You can boot to a terminal by pressing e at the grub boot screen find line starting linux or linuxefi go to true end of line (it wraps) enter a space and 3 press F10 to continue boot. log in as root and run yast to search and remove packages