System crippled (no input)

OpenSUSE 11.2 x86_64
Kernel 2.6.33-34.1(from Kernel:HEAD repo)
KDE 4.4.1

Did the daily set of updates today, which included the kernel, but that update only had to do with enabling IPV6 on all flavors of the kernel. The update also included updates to the xorg packages from the X11:XOrg repo. However I was prompted that a requirement couldn’t be met and one of the options was to downgrade xorg-x11-driver-input to the previous revision (not previous version). I thought that wouldn’t matter so I did it. I reboot and I am able to choose the kernel I want in the grub boot screen, get to the KDM login screen, however, after that the input is totally dead! Mouse and keyboard don’t work whatsoever.

I have a Logitech Cordless Desktop Wave mouse (LX8) & keyboard so I tried it with a standard PS/2 wired mouse & keyboard but it produced the same exact problem.


Had some problems as well, crashing X server etc., took me all afternoon to puzzle my way out (and felt like doing that) What I did to resolve it:

  1. Removed the Xorg repo
  2. Started the software installer, searched for ‘xorg’, updated all packages in the list unconditionally.
  3. Found an error on libXi in /var/log/kdm.log, it appeared some link was left to one of the packages from the Xorg repo.
  4. Searched for libXi as wide as possible, found multiple packages, decided to remove the libXi6 package, left from the Xorg repo.
  5. Reinstalled NVIDIA driver, rebooted, writing this from a KDE4 session running on it now.

Hope this helps you through, now it’s MOVIENIGHT !!!

Thank you kindly for responding. I have done that sort of thing before to resolve similar problems. The problem is: how can I try any of that when I have no input? I don’t have a touchscreen. :wink: (I’m typing this from a second computer I have).

All can be done at the command line. Just run yast as root

I couldn’t even get that far, the mouse and keyboard were disabled.

Then I saw that they were failing with runlevel 5 so in the grub boot options I typed init 3. That got me to console login.

I then found the bug:

Doing this fixed it:


Good work


… faced same problem, but unfortunately before reading this post … :frowning: the special issue at my system, i don’t have a /etc/X11/xorg.conf ?! any ideas to help out of this problem?!

how do you not have an xorg.conf file? are you running a non X system?

xorg.conf is no no longer required it theory it is being phased out. It can help with trouble some hardware still.

Same problem here. I have no xorg.conf - it’s no longer required.

I updated from the xorg repository (I have an ati xpress 200M so need the newer versions in there to get a decent display)

Booting with no xorg.conf gives me no input at all - no keyboard, no touchpad & no mouse (plugged in a usb one to test)

Ran SaX2 which started X with no input driver!! hard reset…

Ran SaX2 -a which created an xorg.conf file. I added the AutoAddDevices stanza & now I have keyboard & a “touchpad” which thinks its a mouse - can’t turn of tap to click :frowning:

I do not have hald-addon-input running at all here with ps aux

I started it as root, and it runs & listens on /dev/input/event* but nothing changes. Running it as a user does nothing and gives no output.

… i’ve found an old backup of my xorg.conf. after editing and inserting the Option “AutoAddDevices” “off” in the serverflag section i’m able to use my mouse and keyboard again. :slight_smile:

but somehow my composite settings won’t work anymore …

What driver is the xorg.conf pointing to?

With the Xorg file it takes control so you need to specify your driver correctly

The mouse part that SaX wrote is:

Section "InputDevice"
  # Driver "mouse" will be disabled unless 'Option "AutoAddDevices" "off"'
  # is set in "ServerFlags" section.
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "SynPS/2 Synaptics TouchPad"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"

I can’t now remember what it should be for a synaptics touchpad, if you have one I’d be grateful :slight_smile:

I do have composite via AIGLX, here are those parts:

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
Option "AutoAddDevices" "off"
  Option       "ZapWarning" "on"

Section "Module"
  Load         "dri"
  Load         "dbe"
  Load         "extmod"
  Load         "glx"
Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"

Section "DRI"
    Group      "video"
    Mode       0660

Section "Extensions"

You appear to be missing anything to do with the video driver. Something like this

Section "Device"
  BoardName    "GeForce 6800 XT (0x00C3)"
  Driver       "nvidia"
  Identifier   "Device[0]"
  VendorName   "NVidia"

Also definition of your monitor

Oh, no - I have a whole & complete xorg.conf - I just posted parts of it.

I have an ATI Xpress 200M so use radeon (which is also the whole reason I use the bleeding edge xorg repos - they are the only ones which give me a proper display since ATI ditched support of my chip)

The only part that does not work properly is the touchpad, and that is because it has been defined as a mouse & I can’t turn off tap to click (very annoying) and other stuff. If any of you has a synaptics device section in your xorg.conf I’d like to see it :slight_smile:

Obviously, It would be better if I could go back to NOT having an xorg.conf at all - but if I do that I have no input devices at all, although everything else still works :frowning:

I had the same issue, no matter if I was using the xorg.conf or not. After reading through some bug reports, I deleted libXi6 and libXi6-dev and resolved the dependencies, after that I was able to update to
xorg-x11-driver-input 7.4-48.1(was downgraded)
(Only these three files couldn’t be updated before) without losing my mouse and keyboard.

I always keep an image of my installation that is no older than 2 days, in case something goes wrong I can go back very quickly, I recommend the same before someone tries out my way.

That’s weird, I already have those exact versions (my driver-input was also downgraded). I’ve not touched libXi6 which is currently at & -dev is not installed.

Still have no input unless I use an xorg.conf. With that file it all works, although I don’t know if it will autodetect a hotplugged mouse (for example).

Hmm, maybe what I have is something different then.

In my /var/log/kdm.log just as this first happened I have this sort of thing:

File radeon_dma.c function radeonReleaseDmaRegions line 346
Leaking dma buffer object!


(==) Using config directory: "/etc/X11/xorg.conf.d"
(EE) Failed to load module "fglrx" (module does not exist, 0)
(II) [KMS] drm report modesetting isn't supported.


The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Duplicate shape name ""
>                   Using last definition
> Warning:          Duplicate shape name ""
>                   Using last definition

repeated about 40 times.
It seemed to choke on not finding fglrx, although this has never bothered it before…

When I generated an xorg.conf, I only get the error about a leaky dma buffer object, and I get input.

same problem here! i thought i was the only one whose compositing was no longer active. activating it dumps me back to kdm login.>:)

i use the intel driver btw. (xorg-x11-driver-video-7.5-17.1.x86_64)