System Crash

System locked up playing the simple game MINES. I shut it down and it will not boot. I need advice on what to do to get my system to boot. I am not too Linux literate so if someone could give me guidance that is easy to understand I would appreciate it. Thanks.

I will enter screen data manually:

[3.848198] BTRFS: error (device sda5) in_btrfs_free_extent:5953: errno=-5 failure
[3.848337] BTRFS: error (device sda5) in btrfs_run_delayed_refs:2792: errno=-5 IO failure
[3.849366] BTRFS: error (device sda5) in cleanup_transaction:1577: errno=-5 IO failure
[3.849559] BTRFS: error (device sda5) in open_ctree:2896: errno=-5 IO failure (Failed to recover log tree)

Generating “/run/initramfs/rdsoreport.txt”

Entering emergency mode. Exit the shell to continue.
Type “journalctl” to view system logs.
You might want to save “run/initramfs/rdsoreport.txt” to a USB stick or /boot
after mounting them and attach it to a bug report

:/# 4.874148] sd 4:0:0:0: [sb\db] No Caching mode page found
4.874222] sd 4:0:0:0 [sdb] Assuming drive cache: write through

How do I proceed to get my system back? Thanks.

Boot to a live 13.2 disk/usb and run fsck on the partitions. Also could be that your disk is full due to snapper snapshots. how much space did you give to root? .

I do suspect that it is a space problem on my partitions. I can’t remember how I originally set up the partitions. However, when I try to boot off of my 13.2 installation usb stick I get the message “isolinux.bin missing or corrupt” . Do you think that I will have to prepare another usb ISO image so that I can get control of my machine?


Try the USB on another machine is you can

Snapper is a real problems if you don’t allocate enough space for root. Better to turn it off or at least modify the frequency and how many snaps it takes

I made a new boot stick on my 13.1 Opensuse machine. I still get the same error when I try to boot from the freshly made iso. Can someone tell me how to get from the sh or bash shell to a regular command line. I am stuck in no man’s land. I thought that if I can get to a regular command line I might be able to re-partition the disk from there and be able to boot normally. I will look at snapper once I get it up and running. Right now I can’t do anything.

There is a recovery mode option. When I run it, it ends with ‘Reached target System Initialization’, and gives me blinking cursor. I do not know where to go from that cursor.

Thanks for your help.

Log in as root then

init 5

that should start things and if not there may be error messages that point to the problem

I only have a GNU bash shell cursor to work with (:/#). When I enter init 5, I get the message “Failed to start Operation refused, unit may not be isolated.”

When I use cd root, the cursor changes to :/root# but gives the same error when init 5 is input.

/root is the root users home directory so is in fact immaterial to your problem

Check who you are with


should be root

Check space with df and if BTRFS then btrfs df

I don’t run btfs so you may want to check usage with

man btrfs

I’m assuming you are in emergency mode so only root partition should be mounted

Look at the partitions

fdisk -l

for the one that is root use fsck /dev/sdX# where X and number is the address for your root

This will not fix it but may report any problem. To fix it the partition must not be mounted so you have to do it from a live Linux boot disk

whoami input returns:
sh: shoami: command not found

man btrfs returns:
sh: man: command not found

it seems as if I am stuck in a worthless shell that I cannot exit from If I input: “if BTRFS then btrfs df” I get a “>”
followed by a blinking cursor. I can type anything after that but everything is dead.

Hmmm maybe you are in the grub command line. You can get there if things are seriously messed up. Are you seeing a sh: prompt not a # or grub>

Yes, I think that is where I am at. Grub starts before I get the crash output. The crash produces the output I gave in my first post. The cursor is preceded by “:/#” (I am getting worried. This is turning into a nightmare simply because my partitions were evidently too small) I went through the procedure to make the USB stick bootable that the opensuse site advises if you do not get a boot from the livestick. All to no avail. Every time I try to boot from a live CD stick I get “isolinux.bin missing or corrupt”. At this point I have no where to go. There seems to be no way out. If I could wipe the drive from the bios I would, but that is impossible. If I could get to a regular command line, I would wipe the drive and begin again with Leap. I do appreciate your help. Thanks. I am not at the computer now but I think the su: or bash: becomes part of the command line if I type in cd bash. . .I am not sure at this point) If I type ‘help’ at the cursor I get a list of commands that the shell will accept. But I have absolutely no idea on how to use those commands to get me out of this mess.

cd is the command to change directories not at all sure why you are using it and there is no /bash directory

the ;/# should indicates that you are on as root that is what the # sign means

type ls to show the directory you are in current it looks as if you are in / or root directory

There is normally a short string in front of the : that indicates the name of the machine but maybe the net is not started and thus it may be blank since that does come from the network setup

if ls works then you are in a good but restricted shell

try fdisk -l (note lower case L not a one) again that should list the drives and partitions

Do you know what partition the root is on? I can give you the commands but without knowing the details of how you set it up I can’t begin to guess.

And yes space is very important any OS requires free space to write temp files and other things and if it is not there it can not run particularly when we think about GUIs. This is why you need to know a bit about the command line which can rescue you when things go side ways.

ls gives:
bin dev early_cpio etc init kernel lib lib64 proc root run sbin shutdown sys sysroot tmp usr var

When I input fdisk -l at the flashing cursor which has :/# in front of it the output is bash: fdisk: command not found

disregard what I said about cd bash that was not true

ls is showing a normal root directory without a mounted home

Ok you may not have full root environment try

/sbin/fdisk -l

Input: /sbin/fdisk -l
Output: sh: /sbin/fdisk: No such file or directory

My effort from now on will be entirely to find out why I cannot live boot from a usb stick, as that is going to be the only way out of this mess. . . and what a mess it is!! Thanks for your help.

I am now beginning to think, based on what I have read on the “isolinux.bin missing or corrupt” problem that this may also be related to the messed up partitions. If that is the case this makes this an even more difficult problem to solve. I should say that when I installed 13.2, I think that I let the installation figure out the best way to partition the drive. I need help!!!

I think my only option at this point is to put this messed up RAID hard drive on another computer and wipe it out. Currently my computer spare holdings are 1.) A 1999 IBM desktop with a dual boot Win98 and Opensuse 13.1, not capable of a RAID drive so I think that system is out. 2.) A 2006 Windows XP system, RAID capable. (I also have a Win10 laptop and an Android tablet, but I do not think they would be useful here.) My question is, can I attach the messed drive to my XP system (not internet connected) and wipe the drive with the xp system so that it will still be accepted on the Linux system I am trying to get operational?

If I can do that, I think it is a good option. Thanks for any input anyone can give me.

There is RAID then there is RAID. FAKE RAID (BIOS assisted) is one thing then there is software RAID and real hardware RAID. AFAIK they are not inter compatible.

Instead of RAID, I think that I meant to say SATA. I used my XP machine to create a single partition on the corrupted HD. It has been wiped clean. However, I cannot seem to create a live boot stick to save my life. Can anyone tell me what the “isolinux.bin missing or corrupt” error is all about? These USB sticks seem to be demonized. LOL!

How are you making the stick?

following these instructions??

You use no extra boot helper just a straight up binary copy to the device NOT a partition on the device