System can't recover after last zypper dup

Hi! I was wondering if anyone else is stuck trying to log into their Tumbleweed only to watch it crash on a loop. It seems to have happened while I was zypper dup’ing a few moments ago and it suddenly gave the “system cannot recover” screen. I’ve tried the nopti /pti=off options, booting into recovery mode, booting to a previous kernel, but to no avail. Any ideas?
Grub loads fine and everything seems to go as usual. The last message I get before a blank screen and then the crash message are the starting session for user (me).
I’m using Gnome as DE, and I’m on an AMD A8-6410 2.0 HP Pavilion.
So sad ;_;

Don’t have something like teamviewer service running? If you get to grub and press the e to edit and add a 3 to the end of the line starting with linux (or linuxefi), does it boot up to the console session ok?

Not running the amdgpu-pro driver?

Hi, Malcolm, thanks for your kind reply.
I’m not running teamviewer. I can log in to console, yes. I’ve checked zypper and I get an ibus-gtk-32bit error (failed to remove, exit status 127) When restarting I also get a failed to start Load Apparmor (…) (I’m sorry I am not copying and pasting logs, I’m saying hi from the phone.)

When you get a chance can you login as root try and remove ibus-gtk-32bit?

Also check apparmor status;

systemctl status apparmor.service

Is the system set to auto login and your using the default gdm login manager?

Thanks again, Malcolm.
I’ve tried to remove ibus-gtk-32bit (I get 2 packages listed under the same name) but it fails with error
Error: Subprocess failed. Error: Rpm failed: /usr/bin/gtk-query-immodules-2.0: error while loading shared libraries cannot open shared object file: No such file or directory
Error: %preun(ibus-gtk-32bit-1.5.17-1.3.x86_64) scriptlet failed, exit status 127
Error: ibus-gtk-32bit-1.5.17-1.3.x86_64: erase failed

System tal for apparmor gives me loaded failed failed.

so unlucky!
Thanks again for your time and patience.

Oh, BTW I am in fact using amdgpu, as radeon would crash with mullions.

Oh dear, typing from the phone is a true nightmare. I just accidentally deleted my previous answer.
I tried to remove ibus-gtk-32bit but I get an error and it won’t be removed.
Systemctl says apparmor loaded failed failed
I di have auto login enabled, yes. I am also using amdgpu as radon would crash with mullins.
Thanks once again for your time and patience.

OK, so from runlevel 3 can you use yast ncurses and remove the auto login via /etc/sysconfig editor or use vi and edit /etc/sysconfig/displaymanager and remove your username from DISPLAYMANAGER_AUTOLOGIN. Then try booting again without using the 3. Which login manager is in use gdm?

Hi, Malcolm, thanks again for all your help.
Yes, I’m using gdm.
I’ve just removed my username from autologin but the problem persists.
I wonder if the message on boot reading “failed to load apparmor profiles” has anything to do with it, or maybe the ibus-gtk-32bit is to blame. (or both)

(finally managed to get home and log in from another machine) I managed to fix the ibus-gtk-32bit error by reinstalling libgtk-2_0-0-32bit, which I am guessing might have become corrupted when the system froze amid zypper dup’ing.
But I still cannot log in through gdm nor start the x-server properly. Apparmor still fails to load profiles on boot, and upon checking its status I get
apparmor.systemd[2646]: AppArmor parser error for /etc/apparmor.d/torbrowser.Browser.firefox in /etc/apparmor.d/torbrowser.Broser.firefox at l…
(…) Error: /etc/apparmor.d/torbrowser.Browser.firefox failed to load

I’ve tried reinstalling torbrowser, but that doesn’t seem to do anything.
Thanks for any help you can provide.

What if you uninstall torbrowser temporarily and see if that helps.

Do you have gnome shell extensions installed as well?

I did that and managed to get apparmor to work again. It seems to be the X server that crashes.
The error I get is that it can’t load any driver, and fails with /usr/lib64/LIBEL MUY. so. 5: file too short.
I think perhaps when it crashed during zypper dup it ruined numerous files, the x server being affected too.

Never heard of that library, is it What non standard apps (as in self compiled, home repos etc) have been installed.

Maybe a clean up of the rpm database and zypper and then do a fresh zypper dup.

Can you post the repos you have;

zypper lr -d

Hi Malcolm, thank you for your kind reply. The Library is (I think because I’m on the phone this silly device must have aotocorrected it or something)
I tried refreshing the database and performing a new zypper dup, which went OK but I still cannot startx.
The repositories I’m using are the OSS, NON OSS, Packman essentials, Games, and snap (which isn’t enabled and I was planning to remove).
I wonder if Steam might have anything to do with it? I installed it on Saturday for my nephew to play, and didn’t install nor removed anything after that and until the sad zypper dup.
Maybe I need to force reinstall the x server? I remember doing that years ago for Debian and my memories of it are not exactly happy, haha.

Not the x server, but libLLVM5 since that’s what’s broken apparently…

sudo zypper in -f libLLVM5

libLLVM5 is used by the Mesa/Gallium OpenGL drivers…

Hi Wolfi, thanks for your kind reply. I am going to try that as soon as I come back from work tonight and I’ll let you know how it goes.

Thank you Wolfi and Malcolm for your kind help! I’ve reinstalled libLLVM as Wolfi suggested, and I got several errors complaining about certain libraries in /usr/lib64 being empty, so I reinstalled those too, and now the system is up and running again. I’ll be checking the logs for any other errors, should there be any.
I can’t thank you enough. :grinning: