system automatic restarts every 11.5 hours

I’ve been running suse11.1 since its release on my server. Everything was running normally in that time.

Last weekend, I noticed repeated automatic reboots. I ran top every 30 seconds, directing into a log file. The reboots occur after exactly 11.5 hours everytime. I’m currently doing a better survey using ps aux hoping to see any hanging processes…the next 11.5 hour mark is coming up soon.

Thinking it might be an errant daemon, I reinstalled suse11.1 but that solved nothing.

I didn’t see anything suspect in the bios. Automatic restart on memory error is disabled.

Thanks for any help.

this may be a cron job which is doing this. Have you looked around in cron?

That is the first thing I checked.

I also got back the ps aux snapshot log I was taking every 15s. For the minute before the system rebooted no system processes started or ended.

I usually have an idea of what the problem is…this has me completely flummoxed!

Thanks for your help though. Sometimes troubleshooting alone can be a dead end road.

Some BIOSes offer a sleep/halt/reboot function which can force the computer to go off after a set period of time. That’s all I can think about, esp when you said that nothing is present in these log files

ok…since you said you reinstalled (and i ASSUME you mean you did a
format and fresh install with KNOWN good media) then it must be a
problem in the bios or hardware…hmmmm, do you have any bios
settings to allow input from the network…is another machine telling
your system to boot?


In case it helps:
MB: TYAN s4882 rev_E 1.02
Phoenix Serverbios3 release6
4x2 AMD opterons

There is one machine that is allowed reboot privileges, but I don’t get anything in /var/logs/messages that would indicate the machine is being accessed. The next step will be to just disconnect the machine it from the network to see if that helps.

The reinstall was a reformat of the OS partition, but not the swap. I’m not registering any disk errors in dmesg, messages, or on startup…fsck reads a clean drive.

I don’t see anything in the bios referencing restart. Could something involving the power settings/management be at work? In case it helps, I rebooted in failsafe mode and reset the bios to defaults.

Thanks for the continued help.