Systeem slaat soms vast

Heren,

Heb de volgende systeem specificaties:
**Merk: Acer, **ongeveer 5 jaar oud

CPU-gegevens

Processor (CPU): Intel(R) Core™2 Quad CPU Q8300 @ 2.50GHz
Snelheid: 2.003,00 MHz
Kernen: 4

Gegevens besturingssysteem

OS: Linux 3.4.6-2.10-desktop x86_64
Huidige gebruiker: jan@h-60-Acer
Systeem: openSUSE 12.2 (x86_64)
KDE: 4.8.5 (4.8.5) “release 2”

Geheugengegevens

Totaal aan geheugen (RAM): 5,8 GiB
Beschikbaar geheugen: 3,6 GiB (+ 881,2 MiB caches)
Beschikbaar wisselgeheugen: 2,0 GiB

Weergave-informatie

Leverancier: nVidia Corporation
Model: GT200 [GeForce G210]
2D-stuurprogramma: nvidia
3D-stuurprogramma: NVIDIA 304.43

Het overkomt mij regelmatig dat ik na 2 tot 10 minuten mijn systeem totaal blokkeert.
Na een herstart loopt het systeem weer normaal en kan ik er uren/dagen mee werken.

Moet ik mij zorgen maken over de schijf, geheugen of moederbord?

Misschien wel. Normaal is het in ieder geval niet. En de onregelmatigheid en onvoorspelbaarheid wijst inderdaad op hardware.

Met die herstart bedoel je dat je de power knop gebruikt? (Waarschijnlijk wel als ik je rapport zo lees).

Misschien een disk controle programma en/of een geheugen controle programma. Maar daar ben ik niet zo goed in. Er komt hier vast wel iemand die je iets kan aanbevelen.

Het zou inderdaad de hardware kunnen zijn, maar dat hoeft niet. Er zijn hier in de forums posts geweest waar Nepomuk/Strigi/Virtuoso de boosdoener bleek. Ook heb ik 't al eens gezien als gevolg van “memory-leaks” door Chrome. Wat ik in ieder geval zie, is dat je je systeem nog nooit geupdate hebt. openSUSE 12.2 heeft nl. al een kernel-update beschikbaar. Als ik jou was, zou ik eerst eens het systeem updaten. Doe dit alleen als je geen extra installatiebronnen hebt toegevoegd, behalve Packman.
Grafisch

  • Yast - Software - Softwarebeheer
  • Pakketten - Alle pakketten - updaten als er een nieuwe versie beschikbaar is.
  • Accepteren, aan het eind zal Softwarebeheer melden dat je een nieuwe kernel hebt, en opnieuw moet opstarten
    In een terminal
  • su -c ‘zypper ref’
  • su -c ‘zypper up’
  • accepteer het update-voorstel met " j ".
  • Herstart het systeem als e.e.a. klaar is.

Mijns inziens zou er over het fenomeen ook wel iets te vinden moeten zijn in de logbestanden. Met

su -c 'cat /var/log/messages | more'

krijg je de systeemmeldingen te zien. Met de spatiebalk kun je pagina voor pagina bekijken, totdat je aankomt bij de datum/tijd dat het systeem vastliep. Met de muis kun je dat stuk selecteren, met Ctrl-Shift-C kopiëren, en met Ctrl-V hier plakken, graag tussen CODE tags (de # in de editor, output moet tussen de blokjes in).

Ik ben zo vrij om te “lenen” uit een thread die op dit moment in het Engelstalige deel loopt.

Controleer het inwendige op stof (uitzuigen!) en kijk of je ventilatoren lopen.

Dan wordt daar een memory test aangeraden: “run memtest86+ for at least 12 hours”.

Ter aanvulling: memtest86+ is als 't goed is standaard geïnstalleerd. Kun je alleen als root draaien. Maar, wil je 't makkelijker doen, de installatie media hebben een “Memory test” optie als ik 't me goed herinner.

Inderdaad 10 seconden de powerknop ingedrukt houden.
Systeem reageert nergens meer op dus is dat dan nog de enige optie

Heb de update uitgevoerd, lijkt te helpen.

Ben in ieder geval blij dat het niet mijn hardware is!

Zal het eerst even afkijken! Indien het systeem weer eens vastslaat zal ik de foutmelding uit het logbestand toevoegen!

Alvast hartelijk bedankt!:wink:

Laten we hopen dat het over is. Succes.

Start vanochtend het systeem op.
Weer hetzelfde probleem!
Het systeem uitgezet door 10 sec. de powerknop ingedrukt te houden.
Daarna na het opstarten (enkele minuten gewacht) een zwart scherm, dus weer de powerknop 10 seconden ingedrukt gehouden!
Dan wel een doorstart maar nu is mijn bureaublad totaal veranderd, blanco taakbalk en de mappen/iconen op het bureaublad zijn nagenoeg allemaal verdwenen!

Nu de volgende stap uitgevoerd

jan@h-60-Acer:~> su -c ‘cat /var/log/messages | more’


jan@h-60-Acer:~> su -c 'cat /var/log/messages | more'
Wachtwoord: 
Jan 31 11:00:06 h-60-Acer logrotate: ALERT exited abnormally with [1]
Jan 31 11:00:06 h-60-Acer logrotate: #007/usr/bin/mysqladmin: refresh failed; error: 'Unknown error'
Jan 31 11:00:06 h-60-Acer logrotate: /logrotate.d/mysql failed, probably because
Jan 31 11:00:06 h-60-Acer logrotate: the root acount is protected by password.
Jan 31 11:00:06 h-60-Acer logrotate: See comments in /logrotate.d/mysql on how to fix this
Jan 31 11:00:06 h-60-Acer logrotate: error: error running non-shared postrotate script for /var/log/mysql/mysqld.log of '/var/log/mysql/mysqld.log '
Jan 31 11:00:06 h-60-Acer logrotate: redirecting to systemctl
Jan 31 11:03:15 h-60-Acer systemd-tmpfile[8147]: stat(/run/user/jan/gvfs) failed: Permission denied
Jan 31 11:05:01 h-60-Acer /USR/SBIN/CRON[8169]: (wwwrun) CMD (/usr/bin/php -q /usr/share/egroupware/phpgwapi/cron/asyncwrapper.php)
Jan 31 11:05:05 h-60-Acer sm-notify[3234]: Unable to notify 192.168.1.2, giving up
Jan 31 11:10:01 h-60-Acer /USR/SBIN/CRON[8289]: (wwwrun) CMD (/usr/bin/php -q /usr/share/egroupware/phpgwapi/cron/asyncwrapper.php)
Jan 31 11:15:01 h-60-Acer /USR/SBIN/CRON[8557]: (wwwrun) CMD (/usr/bin/php -q /usr/share/egroupware/phpgwapi/cron/asyncwrapper.php)
Jan 31 11:18:12 h-60-Acer dbus-daemon[608]: dbus[608]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Jan 31 11:18:12 h-60-Acer dbus[608]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Jan 31 11:18:12 h-60-Acer dbus-daemon[608]: no kernel backlight interface found
Jan 31 11:18:12 h-60-Acer dbus-daemon[608]: dbus[608]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Jan 31 11:18:12 h-60-Acer dbus[608]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Jan 31 11:19:17 h-60-Acer dbus-daemon[608]: **** Refreshing ATA SMART data for /sys/devices/pci0000:00/0000:00:1f.2/ata4/host3/target3:0:0/3:0:0:0/block/sda
Jan 31 11:19:17 h-60-Acer dbus-daemon[608]: helper(pid  8600): launched job udisks-helper-ata-smart-collect on /dev/sda
Jan 31 11:19:17 h-60-Acer dbus-daemon[608]: helper(pid  8600): completed with exit code 0
Jan 31 11:19:17 h-60-Acer dbus-daemon[608]: **** EMITTING CHANGED for /sys/devices/pci0000:00/0000:00:1f.2/ata4/host3/target3:0:0/3:0:0:0/block/sda
Jan 31 11:19:27 h-60-Acer dbus-daemon[608]: dbus[608]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Jan 31 11:19:27 h-60-Acer dbus[608]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Jan 31 11:19:27 h-60-Acer dbus-daemon[608]: no kernel backlight interface found
Jan 31 11:19:27 h-60-Acer dbus-daemon[608]: dbus[608]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Jan 31 11:19:27 h-60-Acer dbus[608]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Jan 31 11:19:59 h-60-Acer dbus-daemon[608]: dbus[608]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Jan 31 11:19:59 h-60-Acer dbus[608]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Jan 31 11:19:59 h-60-Acer dbus-daemon[608]: no kernel backlight interface found
Jan 31 11:19:59 h-60-Acer dbus-daemon[608]: dbus[608]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Jan 31 11:19:59 h-60-Acer dbus[608]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Jan 31 11:20:01 h-60-Acer /USR/SBIN/CRON[8608]: (wwwrun) CMD (/usr/bin/php -q /usr/share/egroupware/phpgwapi/cron/asyncwrapper.php)
Jan 31 11:25:01 h-60-Acer /USR/SBIN/CRON[8711]: (wwwrun) CMD (/usr/bin/php -q /usr/share/egroupware/phpgwapi/cron/asyncwrapper.php)
Jan 31 11:26:12 h-60-Acer su: (to root) jan on /dev/pts/1
jan@h-60-Acer:~> 

Wat nu?

Het systeem is stofvrij.
De ventilators lopen, het systeem vertoond de problemen net na het opstarten of binnen 10 minuten.
Dus ik heb het idee dat niet de warmte het probleem is.

Hoe kan ik die memstest draaien!

memtest kun je draaien vanaf de installatiemedia voor zover ik weet. Je zou ook 't systeem 's kunnen opstarten vanaf een LiveCD, aan laten staan en wachten of 't dan ook vastloopt. Heb 't enorm druk vandaag, zodra ik tijd heb zal ik die output eens doorspitten, en de hele thread nog eens lezen.

Heb nog een OpenSuse 12.1 live CD.
Systeem mee opgestart.
Loopt als een tierelier!

Kan het soms aan de gebruiker liggen?
Zal een nieuwe gebruiker aanmaaken en dan kijken hoe daar het systeem daar op reageert!
Zal morgen de resultaten weergeven!

Nieuwe gebruiker aangemaakt.
Heb het systeem een uurtje uurgezet.
Het lijkt allemaal goed te verlopen!

Kan de oorzaak bij het gebruikers-profiel liggen?

Helaas, werkt ook niet sloeg net weer vast.

Het lastige met dit soort dingen is, dat 't soms dagen goed kan gaan, oplossing lijkt gevonden, en opeens is het toch weer mis. Systeem helemaal demonteren (alles ook uit de slots) en weer in elkaar zetten, heeft bij mij ook wel eens een dode machine nog een paar jaar gegeven.

Theoretisch zou het in je home kunnen zitten, maar waarin??

Als 't van de LiveCD goed loopt, kan 't nog steeds in het systeem zitten, ook bijv. als die nieuwe gebruiker er geen last van heeft. Theoretisch kan het zelfs een stukje schijfcorruptie in jouw home zijn, maar de kans daarop acht ik eigenlijk nul.

Krijg steeds meer het idee dat de harde schijf de veroorzaker van de problemen is!

Ben een nieuwe installatie op een andere schijf gaan uitgevoerd.
Lijkt te helpen, nu nog even afwachten hoe de machine zich houd.
Had mijn data al op een externe schijf geplaatst.
Alleen mijn mail stond op
/home/jan/.thunderbird/65d1xvld.default/Mail/pop.gmail.com/Inbox
Deze map kan ik niet meer terugvinden. (ja, verborgen bestanden tonen stond aan)
Is geen grote ramp want ik heb nog een recente backup, maar wil eigenlijk wel weten waar de map gebleven is.
Ben ook wel nieuwsgierig of ik die data op een of andere manier kan herstellen?

Werk nu even alleen met webmail, werkt ook prima. Ben dus niets kwijt maar lijkt me een goede oefening.

Dus lezers bij onverwachte storingen op een systeem direct een backup cq. copy van je data maken want dat zijn toch de voortekenen van een crash.

Ik kan dat uit de dump van /var/log/messages niet halen, maar nu je aangeeft dat je thunderbird map weg is … Haal van die schijf af wat je er af kunt krijgen. Dat moet eerst. Vervolgens heb je allerlei opties. Een filesystemcheck lijkt me een eerste gegadigde, is ook iets wat je heel goed vanaf een LiveCD kunt doen, het filesysteem mag namelijk niet gemount zijn tijden het checken. Ook zijn er aparte opstart CD’s met speciale schijfanalyse/reparatie software, meestal ook linux gebaseerd.

Ben weer aardig gevorderd:
1- Heb een nieuwe schijf geplaatst.
2- Heb al de oude data van de oude schijf terug kunnen halen.

Heb nu de nieuwe versie van OpenSuse 12.3 geplaatst.
Loop nu tegen de volgende problemen aan.
1- Het geluid loopt niet.
2- Ik heb een dual boot systeem met MS-vista opgezet, Suse ziet Ms-Vista maar kan Vista niet opstarten.
Grub2 laat in Yast weinig mogelijkheden om de bootopties bij te stellen.

Weet iemand een paar tips om de omschreven problemen aan te pakken

Kun je hier even een nieuw onderwerp voor aanmaken? Het gaat nu niet meer over het huidige onderwerp, en de kans dat je wat meer aandacht krijgt met een nieuw onderwerp lijkt me groter, dan doorborduren op iets waar het eigenlijk niet meer om gaat.

Ok, doe ik.

We kunnen wel vaststellen dat het ongekontroleerd vastlopen van de PC een aanduiding was van het uitvallen van hardware!
Na het vervangen van de hardeschijf loopt de pc al weer twee weken prima.:slight_smile:
Nu nog even versie 12.3 bijwerken en dan kunnen we weer.

Iedereen bedankt voor de adviezen