Synpatics PS2 touchpad buttons stop working in Plasma 5

I have a Samsung NC10. After a few minutes in Plasma 5 (up to date 3-29), the mouse buttons no longer work. I can use keyboard input fine and the trackpad still moves the cursor. I can still switch terminals but can’t pull up krunner and while using Ctl-Alt-Del pulls up the logout menu, I can use the keyboard to select things but then it won’t actually take the action.

The hardware is working fine (it works fine in Windows, always worked fine in KDE 4). I also ran evtest while the problem was happening and it still shows the correct events.

I tried reinstalling the x86-input-synaptics package, and that didn’t help. The only thing odd in the logs I could find was that at 236 seconds after boot, in Xorg.0.log, it has a line where it refinds the trackpad.

Any ideas?

More debugging info:

xinput still finds the trackpad correctly while having the problem.

And if you have a program open, the window decorations respond as do all the menus and widgets in the programs.

What doesn’t work is plasma-shell and the screen locker, which means you can unlock the screen if it locks and can’t mouse launch any programs.

If I happen to have a konsole open, I can kill the plasmashell and restart it, and the mouse will come back. Unfortunately, this won’t work if the screen gets locked because then I can’t get to a konsole (starting from the VT didn’t work as it didn’t have the display).

So, it’s something in Plasma5 specifically.

Well, I did a full reinstall and it seems to be working correctly now. Something must have gotten corrupted in my install (I’ve had lots of update issues because it’s on a small partition).