Synchronize gmail contacts to KAddressbook

Hey people, I am searching a bit more the KDE tools those days because when I will install the new openSUSE 12.1 I decided that I want to use firstly KDE tools and then install anything else similar to that if needed.
So now I am to trying to synchronize gmail contacts to KAddressbook, I don’t want just to simply add my gmail contact but being able to change something in KAddressbook and that to change on gmail contacts too.
Anyone can help with a link or something?
I found some stuff but it was for older versions of KDE and for some reason they did not worked.
My KDE version is 4.6.5 (4.6.5) “release 4”
Thanks :wink:

After seeing your post on g+ I did some This is the way it works on my KDE 4.7.2, should be the same on yours:

  • Start kaddressbook
  • File - New - Addressboek
  • select Akonadi Google Resource
  • enter gmailaddress and password
  • allow kwallet access forever or as liked
  • done
    You’ll now see a entry under the addressbooks called “akonadi_googledata_resource_0-”, there’s a checkbox before it, check it. Now
  • right click the newly added addressbook, click update, wait for a while and …

Here’s your gmailaddresses in kaddressbook, if all is well akonadi takes care of the syncing. Let’s keep in touch, Kostas, I’m planning a complete move to the kontact-suite as well. And let us know whether the above worked :slight_smile:

I have a problem and maybe you can explain me why.
Here is what I did:

  • I Started kaddressbook
  • Went to File - New - Addressbook
  • Selected Akonadi Google Resource
  • Entered gmailaddress and password
    …and nothing happened, it did not made anything, like I haven’t give anything, no kwallet, no nothing…
    So I started again from start and again nothing happened
    Then I started kaddressbook from my terminal, then it was that actually nothing happened, kaddressbook did not opened so I said ok and pressed alt+f2 typed kaddressbook and selected that from the list, it started loading but once again, nothing happened, it was like it was not installed, so I went to my terminal and typed
kostas@linux-mcsv:~> sudo zypper in kaddressbook

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

root's password:
Retrieving repository 'Tumbleweed' metadata έγινε]
Building repository 'Tumbleweed' cache έγινε]
Retrieving repository 'Updates for openSUSE 11.4 11.4-0' metadata έγινε]
Building repository 'Updates for openSUSE 11.4 11.4-0' cache έγινε]
Retrieving repository 'openSUSE BuildService - KDE:Extra' metadata έγινε]
Building repository 'openSUSE BuildService - KDE:Extra' cache έγινε]
Loading repository data...
Reading installed packages...
'kaddressbook' is already installed.
No update candidate for 'kaddressbook-4.4.10-3.2.i586'. The highest available version is already installed.
Resolving package dependencies...

Τίποτε για να γίνει. = It's Greek, meaning nothing to be done

ok so I said let’s uninstall it and so I did by typing on terminal

kostas@linux-mcsv:~> sudo zypper rm kaddressbook                                                                                                                                                                   
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following package is going to be REMOVED:

1 package to remove.
After the operation, 785,0 KiB will be freed.
Συνέχεια; [y/n/?] (y): y
Removing kaddressbook-4.4.10-3.2 έγινε]
There are some running programs that use files deleted by recent upgrade. You may wish to restart some of them. Run 'zypper ps' to list these programs.

So I restarted my pc to be sure…

…and then again it kaddressbook opened once repeated the procedure and finally after got the same messages now kaddressbook does not open…

I am now testing it to my Tumbleweed laptop where I screwed things with KDE and had it installed again but that is a loooong story.
Sorry for the huge post but it was as better detailed as I could.

Looks like something is wrong in your KDE install. Is “akonadi-googledata” installed? Did you get the extra addressbook? If so, did you “update” it?

Yeap I did, f I hadn’t I would not had the option ‘Akonadi Google Resource’, I saw that on my Tumbleweed netbook where I had kaddressbook installed.
My KDE was installed during the installation of 11.4.
On one hand I would like to solve the problem just for the hack, since once RC2 will be out I think I will have that installed, or at the most when 12.1 stable will be out.
On the other hand, no matter what we do we could have avoided it just by waiting for the next installation.
I would go for the first but it depends on you, if you think you have the time and can help me just let me know what do you think I should do.

On my netbook on the other hand everything seems to be fine and working doing exactly as you said.
I have questions about it but I will read some documentation first :wink:


Just want to jump in & say that I have linked my gmail address book to kaddressbook. It does work, although its clearly in need of polishing.

Some observations.

  • If you get your gmail password wrong, akonadi blindly accepts it & it looks like it has worked but you have no contacts. (may have been fixed now).

  • I have lots of blank contacts (just an email address). akonadi seems to drag in the ‘auto-address book’ from google that remembers email addreses (that aren’t in your actual address book).

  • The name is stupid* - akonadi_google_data_resource_7. Needs a renaming option.

  • Also note the 7. This shows how many goes it took before I got it to work!

  • It does work though. I can edit my contacts in kmail/kaddressbook or google & everywhere updates

  • Kmail lists the address in the To: field when I start typing, dragged from kaddressbook.

  • My google calendar is linked similarly (with similar issues as well).

If I recall correctly, I had to turn off the suse firewall to get akonadi to sync to google. I may just have needed to open a port, or configure it better/properly. However I’m behind a NAT router, and I welcome hackers with warm arms, so I just disabled the firewall.

I’m using KDE4.7 from the 47 repo. I think the google-akonadi stuff is also from there, but I can check if you would like.

  • Ok, its not stupid. It’s perfectly clear what it is, but it still looks daft…

I continue searching and I opened Kontact, everything there seems to work fine except Kaddressbook and the missing icon of KOrganizer(???), other than that everything works ok…
I suspected a problem on Kontact as a long shot so I tried zypper up this but nothing happened.
I really cannot think of something…
I searched in YaST on add-remove programs and installed kdesdk4-kdeaccounts just in case, but nothing happened. Is there a way to remove the whole KPIM suite and them install it again?
I am thinking that maybe somewhere in all that there is that impossible to find broken or modified parameter, do you think it could make a change?

Hey weighty_foe
Can you please tell me more about that configuration you did on your firewall because I might experience some problems that i suspect my firewall causes them…

@Kostas, are you on the default KDE that came with 11.4? That might be the issue. I tested this morning on openSUSE 11.4, KDE 4.6.5 as described in my post, and it worked fine.

@weighty-joe: I see the same issues, with the exception of the name issue. If I right-click on the akonadi entry, pick Folder Properties, I can change the name of the addressbook to for example “Gmail Contacts”. My suspicions on the “empties” were the same as yours.

on my sysinfo:/ on konqueror I get
KDE: 4.6.5 (4.6.5) “release 4”
the point here is what is the issue, or better how can I find it. Tomorrow I have some work with translation-GSI-news Articles-openSUSE elections bla bla bla, but when I find some time can you tell me if it would change anything if I uninstall/instal the whole KDE PIM ?