synaptiks causing cursor to freeze

I am running openSUSE 12.1 KDE 4.8.1 64-bit.

I had synaptiks 0.8.1-21.1.noarch installed. Synaptiks was set to run at start. When the computer woke from sleep, the cursor would freeze, and I could not do anything at all in the GUI.

I ended up switching to the CLI and running rpm -e synaptiks.

I tried to reinstall synaptiks, but each time I reinstall it, the same freezing cursor occurs. I want synaptiks so I can tap my touchpad without needing to use the left and right mouse buttons.

How can I reinstall synaptiks and configure it so it does not freeze the cursor?

I assume I need to edit something in /etc/X11/xorg.conf.d/50-synaptics.conf. What needs to be edited?

SUSE Paste

Does anyone have any suggestions?

Do I need to provide more information? If so, what do you need?

I solved my issue. I created a new user, found the synaptiks settings, and saved those settings.

would certainly be helpful for individuals such as myself with the same problem to know what the contents of the default file were, and the location if you could please sir.

I’m running 12.3 and have a very similar if not the same problem
I did discover where the file you mentioned was from

linux-7v9h:~ # rpm -fq /etc/X11/xorg.conf.d/50-synaptics.conf
xf86-input-synaptics-1.6.3-1.1.1.x86_64
linux-7v9h:~ # rpm -V xf86-input-synaptics-1.6.3-1.1.1.x86_64
linux-7v9h:~ # 

But discovered that it had not been modified from the original, which works for 3 of my colleagues with the same hardware and same distro.

I cannot drop to console when this problem occurs, I am forced to do a hard-reset… which makes me cringe

To find the contents of a file, please use:

 cat /etc/X11/xorg.conf.d/50-synaptics.conf