Synaptics + USB wifi mouse

Any of you using a Synaptics touchpad, then sometimes switching to a USB wifi mouse?

It works for me but only if I dont specify the actual “Synaptics Touchpad”. If I do specify that I’m using a synaptics touchpad, the usb wifi mouse is no longer useable. Currently its setup as USB Explorer PS/2 mouse.

The problem with that is that the “scroll” area on the touchpad is not working and the touchpad is too sensitive.

dv9925nr is the laptop. thx

I would guess that the touchpad would work fine by itself, as long as you remove any extra pointing devices in the Yast pointing device setup that aren’t actually plugged in or exist(remove your USB mouse before doing all this). Then try plugging in the USB mouse after you are already logged in, then see if you have the same problem.

I dont know what you’re tryin to say… but yea, my config works as my original post states but the touchpad’s “special features” are not accessible in the installed method I described.

If you set the touchpad to Synaptics, and plug in the USB wifi mouse, how many devices are detected/listed in yast?

I just found out how to re-enable the Synaptics touchpad on my Vaio after years of putting up with basic functionality. However, in the process, it disabled my (wired) USB scroll mouse, which disappeared from Sax2 altogether.

After foraging in some old Xorg.conf backups I copied and pasted a section from the ‘xorg.conf.install’ file (which I assume was generated when I upgraded SUSE the other week, prior to my fiddling about) and which seemed to relate to my USB mouse. I left the Synaptics lines in and simply ensured the Identifier number didn’t clash. In my case it’s as follows:

Section "InputDevice"
  Driver     "mouse"
  Identifier "Mouse[1]"
  Option     "Protocol" "explorerps/2"
  Option     "Device"   "/dev/input/mice"

Having done this and saved the main xorg.conf file (make sure you back this up first), I ran Sax2 and it now had two mouse sections (Mouse1 and Mouse2), each of which could be configured independently. The USB mouse needed to be activated and set as the appropriate model, then saved. After restarting X, all is well and both live happily together.

So by entering details for a fairly generic mouse in xorg.conf it should cause Sax2 to pick it up, after which you can set it properly. With yours being wireless, however, you might have more issues. Perhaps see if you have your own xorg.conf.install file somewhere or another backup containing the relevant details.

One other point - I tried testing the Synaptics: Touchpad model in Sax2 and it was horrible. Instead, I used the ALPS: Touchpad. Not sure if this would make any difference to you. Providing the ALPS details appear somewhere in your start-up log and you have all the relevant synaptics packages installed, this driver should be what you require.