Synaptics touchpad treated as PS/2 Generic Mouse in OpenSUSE 11.2

Just like the topic says. My xorg.conf, which configures it as a Synaptics touchpad, appears to be completely ignored.

xorg.conf:


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "SynapticsTouchpad"  "SendCoreEvents"
EndSection

...

Section "Module"
    Load           "synaptics"
    Load           "glx"
EndSection

...

Section "InputDevice"
   Identifier  "SynapticsTouchpad"
   Driver      "synaptics"
   Option      "AlwaysCore"        "true"  # send events to CorePointer
   Option      "Device"            "/dev/input/mice"
   Option      "Protocol"          "auto-dev"
   Option      "SHMConfig"         "true"
   Option      "MaxTapTime"        "0"
EndSection

While hwinfo states:

60: PS/2 00.0: 10500 PS/2 Mouse
  [Created at input.183]
  UDI: /org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input
  Unique ID: AH6Q.U5GX9Ignjc0
  Hardware Class: mouse
  Model: "PS/2 Generic Mouse"
  Vendor: 0x0002 
  Device: 0x0001 "PS/2 Generic Mouse"
  Compatible to: int 0x0210 0x0003
  Device File: /dev/input/mice (/dev/input/mouse0)
  Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event1, /dev/char/13:65, /dev/input/by-path/platform-i8042-serio-1-event-mouse, /dev/char/13:32, /dev/input/by-path/platform-i8042-serio-1-mouse, /dev/char/13:63
  Device Number: char 13:63 (char 13:32)
  Driver Info #0:
    Buttons: 3
    Wheels: 0
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=no, avail=yes, need=no, active=unknown

As a PS/2 Generic Mouse it acts like I am constantly clicking the left mouse button while I move (due to the tapping functionality of a touchpad, I suppose).

Alright, and here are the really weird parts of this problem:

I’ve managed to get the touchpad to be treated like a synaptics touchpad before, using my xorg.conf settings. But while running Maya 3D, with a usb mouse, it will randomly seem to screw up my input devices, cause my touchpad to go back into a PS/2 Generic Mouse mode, and cause my USB mouse to act exactly the same way as the touchpad (act like it is continually clicking) until I unplug and plug it back in a few times). And then, when I reset the computer, the touchpad will still persist as a PS/2 Generic Mouse until I go back into my xorg.conf and funk around with it and reset multiple times!

Is this some bizarre hotplugging bug? It is really annoying and I need to figure out how to fix it ASAP so that I can start being productive again. Which means disabling the touchpad completely if I have to. Unfortunately there is no BIOS option to do so and my xorg settings seem flaky and inconsistent. I am hesitant to tear open my computer and manually disconnect the touchpad connectors but I am willing to do so if I have to.

First of all, get rid of your xorg.conf. It is already an old concept and you should not use it unless you have other reasons to use it. X now uses hal policies to dynamically configure devices.

mv /etc/xorg.conf /etc/xorg.conf.old

You create a hal policy file for your synatics touchpad.

File: /etc/hal/fdi/policy/20thirdparty/99-synaptics.fdi

File content (you may edit it as required):

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.touchpad">
      <merge key="input.x11_driver" type="string">synaptics</merge>
      <merge key="input.x11_options.SHMConfig" type="string">on</merge>
      <merge key="input.x11_options.Buttons" type="string">12</merge>
      <merge key="input.x11_options.VertTwoFingerScroll" type="string">1</merge>
      <merge key="input.x11_options.MaxTapTime" type="string">0</merge>
      <merge key="input.x11_options.MaxTapMove" type="string">0</merge>
      <merge key="input.x11_options.ClickFinger2" type="string">3</merge>
      <merge key="input.x11_options.ClickFinger3" type="string">2</merge>
    </match>
  </device>
</deviceinfo>

Hi,
I have a similar problem and i found that-YaST->System->Config /etc/sysconfig ->mouse device or mouse type- you need to put correct modul(glx) if it is replaced