Synaptics not recognized by OS [KDE][AcerAspire-5542][OpenSUSE 11.3][x86_64]

Hi everyone, I recently moved to openSUSE from mint Isadora, and got this problem, I can’t use the lock/unlock touchpad button. It works fine the first time (It locks the touchpad), but cannot unlock it back, I was searching a lot in this forum but can’t find an answer that suits my needs. (I’ve got the same problem on Isadora, fixed it but i just like OpenSUSE more than Isadora)

All the answers where related to the synaptiks drivers, and my OS simply can’t find it, I uninstalled the synaptiks package and re-installed it back, but Desktop Settings -> Mouse & Keyboard -> TouchPad keeps showing a warning that no synaptiks it’s installed.

I will higly appreciate all the help you can give. If no one found this bug before, I will appreciate a link to where report the bug.

PD: To make this post understandable, I need one of the following solutions;
*Get opensuse tho recognize the synaptiks drivers or
*a tweak to make the touchpad on/off button to work as expected.

Thanks in advance

The manufacturer does not support the advanced features of the touchpad. There is a link from the synaptics website to here:
Linux Driver for the Synaptics TouchPad
I believe you would have to package the driver yourself (help here!) before installation. There are no guarantees that the features you require would be available.

Have you tried “kcm-touchpad”?
Synaptic Touchpad in 11.3 - strange behaviour with dragging and middle click

I’ve Installed kcm-touchpad, but it’s no working,
synclient -l output is
Couldn’t find synaptics properties. No synaptics driver loaded?
But there is a /etc/X11/xorg.conf.d/20-synaptics.conf that I didn’t create!
Does this mean that it found the device at least once? or does the file come as default when Suse detects it is a laptop?

How can I Know why isnt’ synaptics loading? Should I open a new thread with this specific quiestion?

Same problem here. And I have a Dell machine, this is a command line tool, and I actually changed from 64 to 32 bits, because I guessed maybe 64 bits is not so common on laptops and there is no driver available.

So I think the KDE, Acer and x86_64 tags could be removed from this thread The problem seems to be very generic.

I’d guess all the graphical front-ends use the same backend, so the issue is really to get synclient work.

Hmm, that link is completely obsolet. It points to a newer page, but the newer one is not availalble anymore.

I think both of you don’t have a synaptics touchpad. This happens a lot: manufacturer says it’s synaptic, and it isn’t.

BTW mine has a non-synaptic touchpad, works fine here. Looks like kcm_touchpad is not available for KDE 4.5.2…

That could be the case. The kernel detects mine as a PS/2 mouse. Wonder how to find out what it really is. hwinfo command does not reveal anything.

My similar Acer also ID’d a PS/2 mouse but actually has an Elantech touchpad. I was only able to confirm this by booting Windows and checking Device Manager.

Are you able to configure it in any way? What does synclient say? (mine actually works, but I need to configure it because it is much too sensitive)

Had that idea, too. But the machine in question is not dual boot and Microsoft does not offer LiveCD. (Would be interesting to see their bloatware fit on a CD :wink:

I wish I could offer more encouragement, but I’ve not had much luck yet. However, part of the reason may be that I’ve been on the road for the past month and could not give this problem my full attention. I’ll be home late next week, so I’ll try again then. For a summary of my trials to date you could check here and here.

Had that idea, too. But the machine in question is not dual boot and Microsoft does not offer LiveCD. (Would be interesting to see their bloatware fit on a CD :wink:

Blue Ray disk ? rotfl!

synclient only works with synaptic touchpads. It’s synclient that “shouts” at you when you start ksynaptik for example. It shouts “No synaptics device found”.

AFAIK mine is an Elantech too, it’s discovered as a Logitech PS2 mouse, but doing all the things it’s supposed to do ( tapping, two finger scrolling etc), so I don’t bother about it.

Not really. For example the Elantech kernel driver just makes it look like a Synaptics device, so I suppose also synclient can still use it. See Elantech touchpad driver for Linux

I have both a trackpoint and a touchpad. Both work, but the touchpad is much too sensitive so I get unintended actions all the time. So I need to adjust the touchpad (or turn it off).

The problem is that my kernel has only a single input device /dev/input/event1, which receives pointing input. This single device gets all events, whether I use the trackpoint or the touchpad. I’ve tested this with the evtest tool.

I’ve now checked an older IBM Thinkpad, which also has a trackpoint and a touchpad. There the kernel reports 2 devices, an IBM trackpoint and a ps2syn touchpad. And there it was easy to disable the touchpad from the UI so I never had to bother about it. But probably it was done using synclient.

The question now is: Could my current Dell E6510 possible have such hardware that there is only a single output for both touchpad and trackpoint? Or is it just a lack of kernel support that both devices appear as one? Difficult to investigate, because I don’t know what my hardware really is.

I made some progress. I went to the Dell technical support site and checked what they know about the machine with my service tag. They offer a multitouch driver for Windows. It is an selfextracting winzip file (.EXE). Linux unzip command can unpack it.
And the README revealed that it is for an Alps device.

With that knowledge Google immediately found a kernel patch, that seems to address the issue:

Now I just have to build my own kernel, never done that for OpenSUSE…