Synaptic Touchpad

i’ve got an Fujitsu-Siemens Si1520, after installation of live-cd opensuse 11 the mouse did work as espected but after an reboot my pointer only work’s at the login screen, when the desktop is displayed my mouse pointer freezes.

Anyone else seen this behavior?

Help appreciated!


I have no idea what would cause that, but perhaps I could offer a few suggestions.

-Does your keyboard work? As a base test, if you hit CAPS LOCK, does the keyboard light up? Can you navigate the desktop with your keyboard, such as ctrl+etc to open the menu…

You could try booting into a more minimal mode and updating packages, that might help. If you can get into a terminal, run:

zypper ref
zypper dup
zypper up

This will likely be a huge download (1+ GB), and no guarantee of a fix. Hopefully someone with more specific knowledge will come along and help out!

The keyboard works properly but the touchpad is completely dead after login :frowning:

I will try out those update commands.


Could be linked to an open bug where this issue happens (mostly) after configuring the touchpad with the applet in Control Center.
You might want to add you comments to the bug to get this fixed.

As a workaround, so far I’ve only managed to ‘fix’ this by clearing my .gnome config files in my home directory and rebooting.

It should be fixed in factory but I haven’t tried it yet…

See here:
and here :

edit: If you plug in a usb mouse you should at least have back your control…

Didn’t help, all packages seems to be up to date.

Found the problem, it was too simple to be true…
The settings (sensitivity, acceleration) was set as default to zero in Touchpad preferences under control-center.
I increased the speed and now it works perfectly!!!


I’ve posted an workaround reply to the filed bug where others also had the same problem.

Good to hear it had an easy fix :slight_smile: Thanks for adding your comments!


thsundel wrote:

> Found the problem, it was too simple to be true…
> The settings (sensitivity, acceleration) was set as default to zero in
> Touchpad preferences under control-center.
> I increased the speed and now it works perfectly!!!

This looks like it is happening on an update installation - many of us
actually SET the sensitivity way low back about 10.2 just to tame the
@#$%^& tap sensitivity. On my Toshiba, the damned touchpad was so
sensitive it was actually a hazard to my mental health until I manually
mucked with it - the setup apps didn’t manage to get it where it was

Will Honea

I had this problem running opensuse 11.0, and i have a synaptics touchpad. When i used the gsynaptics touchpad applet in the control panel to turn tapping off, then i rebooted or restarted teh session, the pointer was stuck. After about 3 days of messing around with this I found my problem was with the touchpad applet and gconf xml file. It seems to be that when you use the touchpad applet, the xml settings for each attribute don’t get created unless you change them at least once. So the first time you configure it, if you just turn tapping off, the rest of the settings are zero because they weren’t altered, and you have no movement. So to get around this, alter each attribute in the applet at least once before closing, and all the settings will be written.

also, make sure “gsynaptics-init --sm-disable” is run when your session starts or it won’t read your settings from the conf. Mine was already set up under “Touchpad” in the sessions applet.

here is my /home/brandon/.gconf/desktop/gnome/peripherals/touchpad/%gconf.xml

<?xml version="1.0"?>
        <entry name="sensitivity" mtime="1216866754" type="int" value="1">
        <entry name="coast_enable" mtime="1216866106" type="bool" value="true">
        <entry name="edge_motion_use_always" mtime="1214089178" type="bool" value="false">
        <entry name="circ_scroll_trigger" mtime="1214089062" type="int" value="5">
        <entry name="max_speed" mtime="1216866750" type="int" value="192">
        <entry name="min_speed" mtime="1216866749" type="int" value="90">
        <entry name="accel_factor" mtime="1216866748" type="int" value="3">
        <entry name="circular_scrolling" mtime="1214089176" type="bool" value="false">
        <entry name="circ_scroll_delta" mtime="1214089176" type="int" value="0">
        <entry name="horiz_scroll_delta" mtime="1216865145" type="int" value="0">
        <entry name="vert_scroll_delta" mtime="1216866745" type="int" value="100">
        <entry name="max_tap_time" mtime="1216866742" type="int" value="0">
        <entry name="off" mtime="1216866740" type="bool" value="false">

here is the device in /etc/X11/xorg.conf

Section "InputDevice"
  Driver       "synaptics"
  Identifier   "Mouse[3]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Emulate3Buttons" "on"
  Option       "HorizScrollDelta" "0"
  Option       "InputFashion" "Mouse"
  Option       "Name" "Synaptics;Touchpad"
  Option       "Protocol" "explorerps/2"
  Option       "SHMConfig" "on"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"

Now my touchpad works perfectly, i have vertical scroll and i turned that silly tapping off, and best of all i can USE my pointer!

how to set this on KDE?
I have acer aspire 5315 and after installing os11 touchpad behaving very strange…

I thought at first that this was a KDE4 oddity and finally gave up on KDE4 after becoming so frustrated with difficulties navigating the menus. However switching to KDE3 I saw the same ALPS touchpad behaviour using openSUSE 11.0 final (plus updates) from a clean install (bad old HDD).

If you launch Yast->Hardware->Mouse Model it will bring up a description of the pointers. If you can manage to get the pointer over the picture of the mouse(*), then you can see which button and movement corresponds to your motion on the pad. I haven’t worked out how to “fix” it yet :frowning:

(*) For me, the top half of the touchpad seems to be mapped to ‘normal’ movement of the pointer. The bottom half maps Left to Right motion as Down & Up on the scroll wheel. The touchpad seems to have a top and bottom half defined as regions and ‘continues’ my motion across it; so dragging top right to bottom left moves the pointer all the way down the screen, however, the killer is that on my next movement the pad registers that I’m on the lower half of the pad and ignores or invokes the crazy scroll movement. This makes menu navigation very tricky - I have to remember to lift my finger and place it back in the top half of the pad to move about properly.

This is really, really, really, really, really, really, really, really annoying. So annoying that I’ve written this lengthy write-up of ‘broken’ behaviour hoping that the search engines will reference this point, before trying to sort it (or just plug a mouse back in, which is how I’ve kept my sanity in the last few weeks). I have a Sony Vaio B1XP.

Yast doesn’t find any reference to touchpad when using its search feature. Previously I used openSUSE 10.3, having upgraded through each major release since about SL9.2. I had full motion across the touchpad, with the right hand edge acting as vertical scroll, which was detected in KDE & xterms. I don’t remember ever doing anything special to get the touchpad to work normally.