Swithing to new user session results in system hanging

Although I’ve been using OpenSuSE and SuSE for almost 10 years now, and I would classify myself as a somewhat experienced user, this is the first time I actually have a problem I cannot solve. For the first time in 10 years… that actually is a thumbs-up for (Open)SuSE development and the community :). To start: my system has a AMD Phenom cpu and AMD/ATI RV710 graphics card (using dual screen configuration) and a bunch of harddrives in a dm raid configuration. The problem I encountered: after installation of OpenSuSE Leap 42.2 (KDE Plasma) on my system I cannot switch to a new user session anymore. My previous installation (13.2) worked fine. Also does my laptop with Leap 42.2. Once I select “Switch user” I get this splash screen displaying usernames and buttons to either Switch or Cancel. After selecting “Switch” my screens becomes dark and I just see a non-blinking cursor in the upper left corner. That’s all than. And with that, pressing ctrl-alt-fkey to select a different tty won’t work anymore either. Until now, I could not find a working solution elsewhere. So I’m still looking for an answer to resolve this problem… Thanks in advance.

And what Desktop Environment are you using (KDE, Gnome, …)?

BTW. some things changes in those 10 years. It is now spelled openSUSE.

I am using KDE Plasma 5.8.6 on openSUSE (;)) Leap 42.2 64-bit.
This was a clean install -just kept my /home partition- and I have all needed updates installed.

In addition I noticed on my system: when I log out, the screen that gives you 30 seconds to decide what to do, is displayed on both of my monitors. But when I select to Switch User, the screen is displayed in the centre of my two monitors. Maybe that could be (part of) the problem?

If your new user has a cyphered directory, it could be related to this problem :
And to this bug :

In his problem description the system hangs before he can enter new user credentials. So nobody and even the system knows what the new user is, let alone if his home directory is encrypted.

None of the users has encryption enabled, and indeed as hcvv said, the black screen with frozen cursor appears (and with that the system hangs) before I get the screen to select any user or enter credentials.

What video driver?

Further note: I don’t use the function myself but thought I would try. But only have one user currently defined it appeared to function but in the new session no menu item worked. So some thing is wacked in the function. The OP’s problem appears to be graphics related. For what it is worth . Here with NVIDIA card NVIDIA driver and single screen I had no lockup or blank screens but the function did not fully work leaving me in a broken session.

I’m using the ‘default’ ATI driver as installed with Leap 42.2, so Radeon it is.

But meanwhile I tried something else:

After login in to KDE Plasma on my system, as the ‘first’ user, I switched to tty1 text mode and logged in my ‘second user’ (in this case I started with root).

Than, I used the following command to start X:

$ startx -- :1 vt8

And this did the job. Now I have a second session at vt8. And I’m still able to switch to vt7 where my ‘first’ session is still running.

So the question now becomes why this fortunately works from tty, but not from the “Switch User”-option from the KDE Plasma menu?

A bit off topic, but that should not block you from using the functionality. It is prefect possible to create a second session for the same user.

And as pointed out earlier, the OP’s system hangs already when he tries to use it. It never reached the point where he will decide to use the same or another user.

This again shows that it is the KDE functionality, but not the X possibility to have more sessions. Again, you never reached that point from the “Switch user”. It is the KDE prepartion phase (opening some window to ask what you exactly want, asking for credentials) that fails. It has nothing to do with the users (same or other), his encrypting, or even the X session that is to be started.

BTW, why root? Either use the same user or create another one (using YaST this is very easy to do and also to delete the user again after the test if you want so, but a test user can come handy in the future). In any case, I strongly advise not to use root for such tests. It will at the least litter root’s home directory with all sorts of files and will making dangerous mistakes very easy.

I agree with your analysis. This could well be a KDE, and perhaps also graphics driver, related issue.

BTW, why root? Either use the same user or create another one (using YaST this is very easy to do and also to delete the user again after the test if you want so, but a test user can come handy in the future). In any case, I strongly advise not to use root for such tests. It will at the least litter root’s home directory with all sorts of files and will making dangerous mistakes very easy.

Good remark, I do have a ‘test’ user with limited rights which I normaly use. In this case I decided to go for root first, to make sure no right limitations or other restrictions might get in the way. But you’re right, for further testing I will use my ‘test’ user again.

But the littering of root’s home directory is already done now. :frowning:
I prefer to know/manage/understand what is in there and keep it at a minimum.

But with that: the question remains why I can’t switch users fron the KDE Plasma desktop? I now know switching users over tty with startx works, but how to find out what KDE process fails?

OK, I started a LEAP 42.2 system and tried. It is not hanging. I get a screen asking if I want to switch or not. When continuing, I get a login screen. I entered my user name and password and I got a “wait” screen (revolving circle and the large lightbulb. It takes some time, then the circle vanishes. The green lightbulb is there, but nothing happens. I can move the mouse and click, but nothing happens.

Using Ctrl-Alt-F7 brings my first session back (NOT locked). Using Ctrl-Alt-f8 gives me a black screen now.

So I am getting further then you, but not really a success.

As I advised you, I created another user. Now I get into the KDE desktop.

So it seems that, generally spoken, it work. Now, why is it not working in your situation?

Just reporting my experience. Yes it should work with one user and it kinda of does but results in a broken desktop.

In the mean time my experience is that using another user is OK, but trying to login as the same user ends in a failure (see above). But that is of course not what the OP experiences because he never reaches that point. And that again makes it difficult for us to help, because we can not replicate the problem :frowning:

Indeed, it is strange that loging in as the same user doesnt work as it should (because as far as I know, this always worked fine - I did it sometimes by accident).
And as you said… I don’t get to that point via KDE Plasma on this system. But the workaround via tty works fine.

Since replication of the problem is difficult (it works fine on my e.g. laptop), I’m guessing it must be graphics related because I’m using a dual-monitor setup. The “Switch User” screen (where I can select “Switch” or “Cancel” gets centered in between both monitors (single dialog screen). This is strange because all other login/logout related dialog screens are displayed full screen on both monitors (thus I see them twice). So I think this might indicate some sort of problem to start with…

This made me curious: before I tested om my laptop (HP Compaq 8510w, Nvidia graphics) with a fresh Leap 42.2 installation, whether I could switch to a new user which I could. Untill now, I didn’t test switching back.

And indeed, after loging in the second user, I press Ctrl-Alt-F7 to switch back to the first user. This gives me a lock-screen, but it is graphically corrupted (user icons missing, user name letters missing). I can login to the first session though. But then switching back tot the second using Ctrl-Alt-F8 also gives me a black screen, this time with blinking cursor.

And again: manually loging in a second test user via TTY using

 $StartX -- :1 VT8 

and switching back to the first user on VT7 works fine though.

So not only my AMD/ATI dual screen system has issues switching users in Leap 42.2, also does my HP laptop.