Switching to Prime (from Bumblebee)

I’ve been stubbornly working on keeping bumblebee up and running and Kernel 6 more or less put the nail in the coffin and I simply do not have enough spare time or desire to keep it up. I know Prime has been prominent for some time now and it seems that modern laptops with dGPUs do not need bumblebee to get the external monitors work properly.

Now the question is, where do I get access to up-to-date set of instructions for prime? I tried a handful of different ways most of which resulting in xserver refusing to start on boot/command and it’s not even due to botched configuration.

I tried : SDB:NVIDIA SUSE Prime - openSUSE Wiki but it results the same as my botched bumblebee installation: Nvidia module is not found by kernel 6, and I did invoke and did register the Nvidia included kernel with mokutils.

@SJLPHI Hi, so what is your Graphics hardware, are you using X11 or Wayland?

The following should provide that info;

inxi -Gxxz
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Dell driver: i915 v: kernel
    arch: Gen-12.2 ports: active: DP-2,eDP-1 empty: DP-1, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:46a6
  Device-2: NVIDIA GA107GLM [RTX A2000 8GB Laptop GPU] vendor: Dell driver: N/A arch: Ampere
    pcie: speed: Unknown lanes: 63 bus-ID: 01:00.0 chip-ID: 10de:25ba
  Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 bus-ID: 3-6:5 chip-ID: 0c45:6d1f
  Display: server: X.org v: with: Xwayland v: 23.1.2 compositor: kwin_x11 driver: X:
    loaded: modesetting unloaded: fbdev,vesa alternate: intel dri: iris gpu: i915 tty: 345x33
  Monitor-1: DP-2 model: Dell U3818DW res: 3840x1600 dpi: 111 diag: 953mm (37.5")
  Monitor-2: eDP-1 model: LG Display 0x06b3 res: 1920x1200 dpi: 145 diag: 396mm (15.6")
  API: OpenGL Message: GL data unavailable in console for root.

@SJLPHI those are recent gpu’s… and no nvidia driver installed either?

Have you deleted all the bumblebee install, xorg.conf files etc?

@SJLPHI I’s also be interested to see the output from;

xrandr --listmonitors
xrandr --listproviders

Yes, very modern. RTX A2000 mobile dGPU and Intel iGPU.

When I was testing Prime yes, at this current state I have nvidia G06 installed

~> rpm -qa |grep nvidia

along with disabled bumblebee and no xorg.conf

~> xrandr --listmonitors
Monitors: 2
 0: +*eDP-1 1920/336x1200/210+0+0  eDP-1
 1: +DP-2 3840/880x1600/367+1920+0  DP-2
~> xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x48; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 4; outputs: 6; associated providers: 0; name: modesetting
    output eDP-1
    output DP-1
    output HDMI-1
    output DP-2
    output DP-3
    output DP-4

1 Like

@SJLPHI So as can be seen it’s related the the one card (Intel), not both, since both monitors are present and the Nvidia device is not.

Do you have nomodeset in the boot options?

cat /proc/cmdline

Are there any graphics options in the system BIOS?


~> cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-6.4.6-1-default root=UUID=e7470be9-b42e-4da2-b8ce-2acffbc44bb3 splash=silent quiet security=apparmor nosimplefb=1 mitigations=auto

Yes but the standard things like dGPU only, iGPU only and etc. If I go dGPU only, Windows 11 auto re-configures back to dual GPU.on reboot

@SJLPHI Can you remove the nosimplefb=1 and reboot and try the xrandr commands again again.

Interesting about the switching, and you have checked it’s not changed?