Switching packages to packman doesn't "stick"

When I run a package update (zypper ref followed by zypper dup), I often get a run-time error about file conflicts. I then switch packages to packman, and then the package update works fine. However, switching packages to packman doesn’t seem to “stick”–I have to switch packages to packman again often the next time when I run a package update. Any advice? Thank you.

Change your repo priorities so that packman has a higher priority (lower priority number) than the other repos.

For Tumbleweed here, I use 95 for the packman priority, with other repos all at the default of 99.

Check the value of solver.dupAllowVendorChange in /etc/zypp/zypp.conf. And if it happens next time, provide full and complete transcript of your zypper dup run so we can see what happens.

This means that packman will always be preferred, even for the packages which you did not intended to switch. This may or may not be appropriate. In any case, the behavior described by OP is certainly not normal and is not default today.

name_here:/etc/zypp # cat zypp.conf | grep dupAllowVen
solver.dupAllowVendorChange = false
name_here:/etc/zypp #

Should I change it to true? Thank you.

No, the value is correct for Tumbleweed. It means every package should keep its “vendor”.

Next time provide full transcript of

zypper lr -d
zypper dup

and explain which packages you need to switch back to Packman after that. Show zypper search -s output for such package before you switch.

Thank you. It actually worked fine the next time, so I’ll see.