Switching KDE versions.

Following advice from these pages I downloaded KDE 4.2 using Yast.
I had assumed that it would be installed and it would be used from then on.

Wrong. Clearly I have missed something somewhere. I find that some software (KDE bugzilla wizard) reports that it I am using KDE 3.5.10 rel. 21.11,

System Information reports I am using 4.1.3 (KDE 4.1.3) “release 4.9”

Nowhere can I find 4.2 being used.

So how do I start using 4.2 and how do I flush out the superseded versions please.

Still very much a beginner trying to keep up!


Can you please open up a terminal and post the output of

zypper lr



On the login screen select Sessions and you should see KDE4 listed; select it and login.

Hi Ian. After posting I remembered I used one click install from KDE website. I shall send you the zypper lr output as soon as I am back on that machine. On laptop at the moment.
Many thanks.

No login screen as I opted for single user when installing. Read a thread on how to fix this here so will try and sort this out first.
Many thanks,


You can just do the whole login thing by clicking the application launcher then going to leave then clicking logout. It will bring you to the login screen. There you can choose KDE4.

I would like to see the output of zypper lr because if you have kde 4.1.3 repositories, there’s a good chance that you might have some mixed packages which would account for your system telling you you have kde 4.1.3 installed.

Good Luck,


Hi Ian,
Here it is:-

| Alias | Name | Enabled | Refresh

1 | KDE:KDE4:Factory:Desktop | KDE:KDE4:Factory:Desktop | Yes | Yes
2 | cdparanoia | cdparanoia | Yes | Yes
3 | devel:tools:building | devel:tools:building | Yes | Yes
4 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | Yes
5 | repo | VideoLan Repository | No | Yes
6 | repo-debug | openSUSE-11.1-Debug | No | Yes
7 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes
8 | repo-source | openSUSE-11.1-Source | No | Yes
9 | repo-update | openSUSE-11.1-Update | Yes | Yes
10 | repo_1 | Packman Repository | Yes | Yes

When I installed the KDE 4.2 I used the one click method from the KDE site. Hope you can give me some guidance please.

Hmm… Well you have the correct repositories installed and no trace of any previous KDE repositories, although you can still get the KDE 4.1.3 packages from the the OSS repository.

Try this,

Open Yast Software Management then for the filter choose patterns.

Right click on KDE4 Desktop Environment and choose All In This List>Update Unconditionally. Do the same for KDE4 Base System.

Good Luck,


Hi Ian,
Strange behaviour when I tried to log out so perhaps I had crossed packages. Anyhow I had to reboot and was then able to select KDE 4.2. I then did an update as many previous component updates had failed yesterday. Now system info says 4.2.2 so I guess all is OK. Many thanks for your help.

Now back to trying to get Kaudiocreator to work!


It still doesn’t.

The upgrading of KDe was rather neat. Is there any way I can upgrade from OpenSuse 11.0 to 11.1 in a similar way?


Yes, but you’ll lose all your programs you have installed. You’ll still have their configuration files so when you install them back onto your computer you’ll have all your settings and stuff saved.

You can do this if you chose the default options when you installed openSUSE which opted for a separate home partition. In which case you’ll just reinstall the / (root) partition. If you’re using the livecd method again, I would recommend doing it from a kde4.2 live cd rather than the opensuse 11.1 kde live cd.

You can find the .iso here “KDE Four Live” CD](http://home.kde.org/~binner/kde-four-live/)

This ensures that you’ll start off with KDE4 instead of having to upgrade to it. Since your current configuration is set for kde4 you won’t have to delete you .kde and .kde4 folders upon reinstall either.

Once again, after installation, you’ll have to perform the update to get hal to be able to mount your drives and you’ll also have to download your programs again that aren’t kde4 native (openoffice, firefox, wine, etc.)

Although, really, since you’ve just installed openSUSE and haven’t really done too much, it might be easier to just install openSUSE 11.1 fresh to avoid any complications. But if you do have files you want saved from 11.0 you can upgrade while keeping those files.

Good Luck,


Sorry, I was thinking of another user that just got KDE4 sorted out. You’ll definitely want to just upgrade and keep your settings. If you need any help with upgrading I can help with that.

Good Luck,


Hi Ian,
Having sorted out my new box I thought I would upgrade my laptop, which is why I asked, and thanks for the offer of help.

I have used Network install and the Internet several times on other boxes recently. It works well and only needs a small CD to start. However last night my broadband connection went bad (along with a few thousand others I am told,) so I did nothing.

There is nothing I need to keep on the laptop so will try again tonight.

Thanks again for the help.

Well I,m back using OpenSuse 11.1 installed as new network installation and with KDE 4.2.2 installed using one click install from KDE site. A couple of problems:-

  1. With original setup I had OS/2 Boot manager which enabled me to boot to XP, eCS and Opensuse. I forgot to stop Grub installation so now I boot to Grub and it offers Opensuse, Windows and OS/2 Boot Manager. Unfortunately the eCS option has gone from the BM menu. I think I can restore this using eCS CD.

  2. The text beneath the icons on desktop has a shadow effect which I had removed in previous setup. I cannot now find how I did this. Could somebody please remind me.

  3. Pointer movement (Using IBM Thinkpad) is more jerky than before when using Firefox, for example now on OpenSuse forum site. Is this movement rate adjustable?

Otherwise OK. One question following the KDE upgrade. How do I ensure following new boots will start with 4.2.2 and not revert to original installation version? Can I remove older version?


I cannot help you with the first question.

  1. Are you talking about on the Folder View widget? If so then you can just hover over it until the tab comes up beside it, then click the wrench looking icon. Under Display uncheck the box under Text Settings that says Show text shadows.

If your Desktop is the actual Folder View then you can right click on your desktop and then choose Folder View Settings and it will be under Display under Text Settings.

  1. If you click the application launcher (k icon or green openSUSE lizzard) then go to Applications>Configure Desktop (Personal Settings), under Computer Administration is Keyboard and Mouse. Click that then go to the Mouse category. Click the Advanced tab and there you can adjust the pointer acceleration.

As to your last question, I don’t understand what you mean. If you did a net install and started off with kde 4.1.3 and you installed 4.2.2 correctly then it will not revert back to 4.1.3 unless you completely downgrade all your kde packages to 4.1.3. So in essence, you don’t need to worry about uninstalling anything or anything reverting unless you downgrade your packages manually.

Hope this helps!


Hi and sorry it has taken me a while to reply with thanks. Been busy and lost broadband for a couple of weeks due to line fault.

Have sorted my boot problems although now grub comes up first and offers OS/2 boot manager as option rather than other way round but all working well.

Have removed shadows thanks! All the rest sorted too so thanks again.