switching from nvidia gt710 to igpu HD530 doesn't start anymore.

Hi everybody,
I gotta say I’m kinda of a newbie here, so please don’t kill me!
I got an issue which is last too long now and I can’t figured out how to fix it. Hope you can help.
Long story short, I had an nvidia GT710 which was way enough for my use (music production and some retrogaming). I always hated how the proprietary drivers works on Linux and I recently discovered I could use my igpu (HD530) to perform even better than the GT710 and without the boringness to have proprietary drivers running on my machine.
I simply switched my HDMI cable from my nvidia to the hd530 and it worked straight away. Everything beautiful, animation and transparency were better and everything was great, except the machine won’t poweroff or restart at all anymore. I had to do it brutally every single time.
This morning I decided to physically remove the GT710, remove all the proprietary drivers and all the “unneeded packages” showed in Yast (they were a lot), with the result the system doesn’t start anymore, however If I use “nomodeset i915.modeset=0” into the grub, it does start, no problem with restarting or poweroff anymore, but there is not 3d acceleration hardware (so no transparency, nice effects, animation, etc anymore). My igpu is kind of castrated lol!
Thanks to a friend from the italian telegram group, we figured out that my igpu is not working at all. Giving a “glxinfo | grep vendor” the result is “Error: couldn’t find RGB GLX visual or fbconfig”.
That’s all.
Any idea how to fix it?
thank you so much.

I do not understand why you did this action (it does not seem to have any relation with NVidia), but when i look in that list (which is 15.2, but I guess it is not mich different from Tumbleweed), there are several packages I use daily. So, IMHO, it is not really wise to remove them without further investigation. And I would not be surprised if you now have moved something you really need to get your system going.

I though so, but I always done it without issues. I guess I messed up this time.

“nomodeset i915.modeset=0” into the grub

Intel/AMD graphics need the kernel-modesetting.

Also see:

grep -i 'blacklist nouveau' /etc/modprobe.d/*

If nothing returned its good, if something like:

/etc/modprobe.d/nvidia-installer-disable-nouveau.conf:blacklist nouveau

its not deleted by uninstalling the nvidia driver and you have to do this by deleteing the file seen in the output.
But the last has nothing to do with Intel graphics

ok, but what do you think about the fact it doesn’t have 3d accelleration hardware anymore? without the kernel-modesetting it runs smoothly, with all the effects, transparancy and stuff.

yep, nothing returned.

Install susepaste and post your Xorg.0.log.

cat /var/log/Xorg.0.log | susepaste

here it is:


delete “nomodeset i915.modeset=0” from the grub cmd line on restart.

Does it work?

yes, it does, however it takes ages to boot and once it started there is not hardware accellaration also.

I have not had any nvidia system for a while. When I last had one, I found that after removing the nvidia drivers, I needed to reinstall mesa to get things working properly. I’m not sure whether that still applies.

There is no BIOS setting to ensure it’s using the integrated gpu, are there configuration options for the gpu, memory etc?

My setup is the same, I use onboard intel and have discrete cards (including a GT710), you could have left the GT710 in there for offload (or not used at all…).

Check the Xorg log in ~/.local/share/xorg also the output from journactl -b to see what’s what. Maybe some maintenance running, check systemd-analyze blame.

Hi, yes it does. I can switch from “igpu” to “PCI Slot 1” which I did when I first swapped the hdmi cable. Memory allocated as well. I set up minimum 64mb to MAX.

Yes, that is what I’ve done at first. I kept the gt710 and I simply changed the hdmi cable and setted up my bios to boot from igpu. The system booted up with all the effects, trasparency etc but it didn’t power off or restart at all. I had to do it manually and brutally everytime.

sorry I’m not good to read these outputs. I can’t see any “systemd-analyze” ~/.local/share/xorg Can you tell me how to share with you the outputs? thanks.

Thanks for that. I tried but it didn’t start X anymore :frowning:

Two separate commands, open a terminal and run;

less ~/.local/share/xorg/Xorg.0.log

systemd-analyze blame

thanks. here they are:



If you boot with plymouth temporarily disabled, and press the esc key while booting, do you see more info?

Add the following to grub boot line;


Do you by chance have some nvidia config file down in /etc/X11/ or /etc/X11/xorg.conf.d/?

Is there still a nouveau blacklist file down in /etc/modprobe.d/

fgrep "nouveau" /etc/modprobe.d/*

Since you removed the nvidia driver, have your rebuilt initrd (switch to root user)?

su -

You can reboot from the command line if required as root user;

systemctl reboot

Thanks for the time you’re taking to help me. really appreciated.

ok, so…

this is the only extra info I got before it logs in:


checked and nothing seems to be left there, however I still did action fgrep “nouveau” /etc/modprobe.d/*

done. this is the output: SUSE Paste

It would appear to me you have not updated the system (zypper dup only)?

cat /etc/os-release

You should be at 20210318 and 5.11.6 kernel…

just realise I still have 50-nvidia-default.conf.rpmsave
it could be of any cause?

00-system.conf                  60-blacklist_fs-f2fs.conf
10-unsupported-modules.conf     60-blacklist_fs-freevxfs.conf
50-blacklist.conf               60-blacklist_fs-hfs.conf
50-bluetooth.conf               60-blacklist_fs-hpfs.conf
50-broadcom-wl-blacklist.conf   60-blacklist_fs-jfs.conf
50-ipw2200.conf                 60-blacklist_fs-minix.conf
50-iwl3945.conf                 60-blacklist_fs-nilfs2.conf
50-libmlx4.conf                 60-blacklist_fs-ntfs.conf
50-nvidia-default.conf.rpmsave  60-blacklist_fs-omfs.conf
50-prism54.conf                 60-blacklist_fs-qnx4.conf
50-yast.conf                    60-blacklist_fs-qnx6.conf
60-blacklist_fs-adfs.conf       60-blacklist_fs-sysv.conf
60-blacklist_fs-affs.conf       60-blacklist_fs-ufs.conf
60-blacklist_fs-befs.conf       99-local.conf
60-blacklist_fs-bfs.conf        firewalld-sysctls.conf
60-blacklist_fs-cramfs.conf     mlx4.conf
60-blacklist_fs-efs.conf        truescale.conf
60-blacklist_fs-erofs.conf      tuned.conf

I always update with zypper ref && sudo zypper dup --allow-vendor-change

DId I do it wrong since the beginning?

NAME="openSUSE Tumbleweed"
# VERSION="20210307"
ID_LIKE="opensuse suse"
PRETTY_NAME="openSUSE Tumbleweed"