Switching from NetworkManager to Systemd-Networkd

Hi,

Due to a unsolved issue with nfs and my laptop not shuting down, I would like to switch from NetworkManager to systemd-networkd. But somehow I can’t seem to find the info I need to do so.

systemctl mask NetworkManager.service
systemctl stop NetworkManager.service 

This does stop the NetworkManager but I can’t find th right commands to make the switch to Systemd. Anyone to point me in the right direction? Thx.

[Running opensuse Tumbleweed, latest snapshot, Gnome desktop]

Greetings,

Martin

Will be moved to Tumbleweed , … and is CLOSED for the moment.

Moved from Network/Internet and open again.

Use Yast Network Settings. Switch to using “wicked” in place of NetworkManager.

I did that recently on my laptop, for exactly the same reason. I was occasionally mounting an nfs file system using “autofs”. If I remembered to check, and manually umount before shutdown, this was fine. If I forgot to do that, shutdown would take somewhere between 5 minutes to forever. It seems that NetworkManager is shutdown before autofs is shutdown.

It is working fine with “wicked” handling the network.

systemctl enable systemd-networkd.service

Does it not work?

Wicked is working indeed. I hope it will for a while :slight_smile:

That’s what you should think yes. But unfortunately SystemD is dying after it is started:

systemctl status network● systemd-networkd.service - Network Service
   Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
   Active: inactive (dead) since zo 2015-07-19 20:23:11 CEST; 6min ago
     Docs: man:systemd-networkd.service(8)
  Process: 863 ExecStart=/usr/lib/systemd/systemd-networkd (code=exited, status=0/SUCCESS)
 Main PID: 863 (code=exited, status=0/SUCCESS)
   Status: "Shutting down..."

So, after ’ systemctl enable systemd-networkd.service’ there is no internet connection. During the next reboot the system hangs for a few minutes on boot.

**Another thing that I would expect is, that it is listed in Yast networking, just like Wicked and NetworkManager. But it isn’t. Although it is prt of systemd, there is no ‘systemd-networkd’ entry in Yast. **

You already mentioned that wicked is working for you. Why are you trying to use systemd-networkd?

BTW, some interesting discussion on the implementation of openSUSE’s wicked, which explains why (open)SUSE took the direction it did…

http://lists.opensuse.org/opensuse-factory/2013-12/msg00219.html

First off: We started to look into options for the next generation
of network interface management 1.5-2 years ago. A lot of stuff was
floating around at the time, but nothing really up to the job.
There was a virtual team doing this (and I was not part of this).
They looked at a number of alternatives including NM and connman,
and decided to pick wicked.

networkd didn’t come up until pretty recently, and it seems there
is a lot of parallel thinking going on. Which is good, as it validates
our approach over the RedHat approach of extending NetworkManager.

FWIW, we did have a pretty good discussion with Tom Gundersen a couple
of days ago, where we agreed that we have a lot in common - and we’re
talking about how to align some of our efforts better.

and some comments from Tom Gunderson about systemd-networkd

http://www.reddit.com/r/linux/comments/1rlrph/some_background_on_the_new_systemdnetworkd/

You realize that you have to configure it, do not you?

Some good info on using systemd-networkd in this archlinux wiki page.

Thx all for the info. Sticking with ‘Wicked’ for now. Configuring Systemd like in the Arch wiki, is too much of a hassle for me.